OpenSuse 12.2 RC2 install on Asus UX31A (UEFI)


today, I tried to install OpenSuse 12.2 RC2 on Asus UX31A.
First I started the KDE Live CD and the system was running well. Afterwards, I tried to install the system (I deleted the Windows system on the machine). After reboot: nothing :(.

Then I tried the complete OpenSuse 12.2 RC2 installation media (I found also following page: As suggested, I created 4 partititons: 200 MB VFAT (for some EFI stuff), 2 GB Swap, 16 GB root, 200 GB home. I choose the Efi bootloader and directly got an error message (the same with grub-efi), then I choose Grub2 (with MBR for grub). After reboot: nothing, only my USB stick wanted to boot :’(.

Was somebody able to install the OpenSuse 12.2 on a UEFI machine?

Best wishes


I haven’t tried. But the article you mentioned applies to 12.1, which setup doesn’t include grub2-efi. How about blanking the MBR and let the setup create the EFI partition? And make sure that your BIOS doesn’t switch to Legacy compatibility mode before booting!


thanks for the reply.
The OpenSuse 12.2 RC2 installation (from USB stick) does not detect EFI and does not suggest to create a partition.
How can I blank the MBR?
How can I enforce the Bios not to switch to “legacy compatibility mode”



P.S.: before my first installation the Bios showed a Windows system in the EFI Bios menu. After my installation trys its gone (that’s OK, because I don’t want it ;)). There is also a menu point to search for new EFI systems “launch EFI Shell from filesystem device” = “Attempts to launch EFI shell application (Shellx64.efi) from one of the availabe filesystem devices”)
In Addition I found in the Bios point where I can add new EFI boot options

AFAIK UEFI booting is only from the DVD not the LiveCD’s.

I’m using it here fine, but installed via the DVD.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 1:57, 2 users, load average: 0.06, 0.05, 0.12
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

That’s true. I also mentioned it in the article about 12.1. However if 12.2 setup offers to install grub2-efi, how can it be that it doesn’t boot in UEFI mode? It doesn’t make sense. Does it? Btw Ubuntu live CD also boots in UEFI.

If the device you boot from only includes MBR booting, then it is normal that your UEFI BIOS switches to legacy. Otherwise you might have to call the BIOS setup (every time before booting) and make sure that the UEFI device has boot priority.

Not sure, I would imagine some extra work needs to be done. I know
I mentioned about adding it on the LiveCD’s in the ML about Secure Boot.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 4:45, 3 users, load average: 0.04, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Thanks to everyone for the answers and tips :).
I will try to install the final version on wednesday using a DVD (and an external USB DVD drive). I will add a comment if it worked.


Hi, michaelhust,

You asked in Chinese sub-forum

It’s about when dual-boot Windows 8 and openSUSE. if install Windows 8 first, openSUSE will create a second partition table which breaks Windows 8.

our temporary solution is to run Windows 8 DVD again, it’ll delete the new partition table openSUSE creates. then openSUSE and Windows 8 can boot together.

It is because Windows 8 doesn’t follow its own UEFI standard to create protective MBR. so openSUSE fixes it. then Windows 8 eats its own ****.

Hello MargueriteSu,

thanks for giving the answer in the english forum.

Best wishes to Beijing (I have been there two times and like the city)



I installed the final version using a DVD and everything went fine lol!.


Michael, you create : 200 MB VFAT (for some EFI stuff), 2 GB Swap, 16 GB root, — GB home and at the end of the install you choose Grub2-efi and it’s ok ? You format the first part (VFAT) ?
Thank you.

Hmm … Thinking twice, if the LiveCD would include UEFI boot, it wouldn’t be possible to install openSUSE 12.2 64bit on “older” Apple hardware with 64bit CPU but 32bit EFI firmware.