OpenSUSE 12.2 RC2 black screen after login into KDE

Hello!

I recently installed OpenSUSE 12.2 RC2 on a Fujitsu Esprimo E910. The installation process ran flawlessly. But after getting the login screen and entering the credentials the system starts to load KDE and suddenly the screen turns black.
KDE itself starts up I think, because the welcome sound can be listened to after a short time.

dmesg says:

138.577326] [drm:i915_hangcheck_elapsed] ERROR Hangcheck timer elapsed… GPU hung
138.577331] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
145.078733] [drm:i915_hangcheck_elapsed] ERROR Hangcheck timer elapsed… GPU hung

i915_error_state ist quite big, more than 2MB, if you need it, please tell me, where and how to post it.

GPU is a Intel HD Graphics 2500.

Thank you!

>
> GPU is a Intel HD Graphics 2500.

try: at the first green screen type

nomodeset

into the
“Boot Options” line…

see http://tinyurl.com/23mgej6 for more

and, check and see if a bugzilla has been logged against that graphics
set on 12.2…


dd http://tinyurl.com/DD-Caveat

You can also try to collaborate with the user from this thread: http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/477474-opensuse-12-1-black-screen-hp-pavilion-laptop.html

That user is using 12.1 and with a NVIDIA based GPU. Totally different from what you are using, but the issue sounds similar.

Here is his youtube capture of the black screen: MVI 4577 - YouTube

Similar to your case, it was suggested in the other thread to use the “nomodeset” option as one of the optional boot parameters. Try dd’s recommendation and report back =) I’m curious because this is an intermittent problem I have on all of my KDE machines running 12.1 x64; one has NVIDIA (proprietary drivers) and the other uses intel onboard graphics card with nouveau.

Either I get the blackscreen or the desktop loads, either way it hangs for about 30s to 1m before I hear the default startup sound (kde chime) and the rest of the desktop loads (network, audio…) where you can see them appear near the clock at the bottom right.