openSuSE 12.2 on hp ProLiant ML310 G8 v2

I have been trying to install openSuSE 12.2 on a out-of-the-box hp ProLiant ML310 G8 v2 server. The machine is equipped with two 1TB hard drives, so I thought that this would make a great setup for a RAID-1 installation.

The server has a Dynamic Smart Array B210i controller which unfortunately is not recognized by oS 12.2. I created a logical drive but the oS installer still sees two distinct drives, /dev/sda and /dev/sdb.

Next, I removed the logical drive and performed an installation using the linux RAID system. At my first attempt, I had the following setup:
/dev/md0 consisting of /dev/sda1 and /dev/sdb1 mounted as /
/dev/md1 consisting of /dev/sda3 and /dev/sdb3 mounted as /home

The installation completed without any incident but after the restart the server could not boot. It behaved as if it there were no bootable hard drives. However, using eg. a Knoppix live DVD I could see, using mdadm commands, that the partitions were actually there and that they were members of the correct md devices.

For my second attempt, I created the following partition setup:
/dev/md0 consisting of /dev/sda1 and /dev/sdb1 mounted as /boot
/dev/md1 consisting of /dev/sda3 and /dev/sdb3 mounted as /
/dev/md2 consisting of /dev/sda4 and /dev/sdb4 mounted as /home

With this setup I had exactly the same results as with the previous one, a non-bootable server.

I want to use this server with a RAID disk setup. I don’t necessarily want to make use of the B120i as a RAID device but I would at least like to be able to setup this machine using the normal linux RAID mechanism and also be able to boot from any of the hard drives in case of a disk failure. I also would not like to move away from oS 12.2 as it is the version deployed on other of our servers as well (with non-RAID configurations) and it is a tried and tested version.

Is there anything else that I should do so that I can get to my desired result? Has anyone else used this server and had success? Any help will be greatly appreciated.

This maybe isn’t the solution you are looking for, but it is a viable:

I have a system not very different from yours. I am running many variant of openSUSE on it, but not the way you are trying to do. I have installed VMWare ESXi hypervisor on it, and used that to set up the RAID the way I want it. Then I install openSUSE under that, making the RAID invisible to Linux. The ESXi hypervisor is different from VMWare Workstation, in that it is much faster so you do not loose speed the way you do on your desktop under VMWare Player or VMWare Workstation (it doesn’t run on top of any OS, you install VMWare ESXi hypervisor “on the iron”).

It adds flexibility (you can run many Linuxes in parallel - you disk-space, processor configuration and RAM amount are the main limiting factors for how many Linuxes in parallel being practical in real life), and it is a free option. It isn’t open source, but that is about the only negative I’ve found so far, and I decided that shouldn’t be allowed to be an obstacle in this situation :).

If you need help setting up VMWare ESXi, you should consult VMWare forums (also free), if you need help running openSUSE under VMWare ESXi, you can get help here through the Virtualization forum here.


Aside from the folly of installing 12.2 (you should be installing 12.3 minimum, 13.1 recommended),
During boot you do have an opportunity to add alternative drivers if necessary.

But, I’m just plain surprised that you have a problem with an HP SmartArray, period. Although I haven’t installed on that controller, my impression is that Linux is well supported on practically any and every SmartArray controller. Be certain you haven’t made a mistake setting up.

And then, download 13.1.


SmartArray B210i is a SATA RAID and is not supported by the older CCISS driver that worked on practically every system previously (they were mainly SCSI/SAS arrays) but instead by the new HP hpvsa driver.

HP ProLiant ML310e Gen8 v2 Server driver support didn’t arrive until 12.3+ so you’re a bit out of luck.

You might want to try these;

Unfortunately HPVSA is a proprietary driver and I cannot compile it against 12.2 for you, I would have done it otherwise.

Hi, I don’t know if you can solve the problem, but I have the same problem and solve partial. View on this link, in spanish :

basically you must deactivate the RAID controller and use a ‘normal’ SATA configuration.

Whilst you will be able to use the non-RAID version, you’re sacrificing way too much: you give up hardware error correction, battery backed up cache (BWCC) which on HP servers like this mean a MASSIVE performance hit and RAID features such as seamless rebuild, monitoring and proper hot-swap (albeit hot-swap works for normal SATA it’s nowhere near as “safe” and usually requires user intervention where-as HP cciss/hpvsa handle the rebuilding on their own automatically).

Reading the referenced HP driver download and instructions,
It looks like the procedure does not require disabling RAID support, quite the contrary. The option to disable RAID is made only at the end, almost in passing.

The main part of the documentation looks like full RAID and AHCI is supported, but needs to be configured in “SATA” mode.
As I described in my earlier post, if you disable “automatic configuration” during the install, in one of the early forms you should be given an opportunity to add custom drivers and repositories.