OpenSuSE 12.2 on external USB 3.0 hdd-> shutdown powers off too early

Hello,

I have installed OpenSuSE 12.2 on an external USB 3.0 hdd (Ext4 partition).
This is not my “main system”, but it looks quite stable and usable except that normal “shutdown -P now” seems to power off the USB hdd too early it seems, leaving a corrupted file system behind (fsck complains at boot time).

There are no problems if I use “shutdown -H” and power off manually, after the system is halted.

Is there a way to use “shutdown -P now” to shut down more gracefully?

Perhaps to wait some time before powering off?

Thank you

Why not open up terminal and post the output of these commands:

su -
cat /etc/fstab
fdisk -l

Post the output into Code # blocks. Do you use Grub2? Do you use systemd or did you switch back to system V?

Thank You,

If using systemd then, /sbin/shutdown ponts to

# ls -l /sbin/shutdown
lrwxrwxrwx 1 root root 14 Jan 10 11:40 /sbin/shutdown -> /bin/systemctl
linux-akl:/home/dean # ls -l /sbin/poweroff
lrwxrwxrwx 1 root root 14 Jan 10 11:40 /sbin/poweroff -> /bin/systemctl

Why not use

systemctl poweroff

On 2013-01-17 15:56, theo222 wrote:
>
> Hello,
>
> I have installed OpenSuSE 12.2 on an external USB 3.0 hdd (Ext4
> partition).
> This is not my “main system”, but it looks quite stable and usable
> except that normal “shutdown -P now” seems to power off the USB hdd too
> early it seems, leaving a corrupted file system behind (fsck complains
> at boot time).

I assume that the external disk is powered via usb. When the usb goes
down during the halt process, well… I don’t know what can be done
about that.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

I assume that the external disk is powered via usb. When the usb goes
down during the halt process, well… I don’t know what can be done
about that.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

Well, I would hope that udisks/udev is consulted, and any removable media partitions unmounted before the halt process kills the usb subsystem.

FWIW, I see similar questions asked on other forums (most with inadequate answers or conclusions):

Puppy Linux Discussion Forum :: View topic - Unmount drives before shutdown? ANSWERED
mount - Does shutdown -P now safely unmount a USB drive mounted to /dev/sdb1? - Unix and Linux
Why don’t my external USB hard disks umount when I shutdown? - Ask Ubuntu
External USB hard drive doesn’t unmount cleanly at shutdown

I have a USB 3.0 External Hard Drive and while I don’t boot from it presently, I did set it up that way just before openSUSE 12.2 came out. I even requested (through a bug report, saying you could not boot USB 3.0) that the USB 3.0 driver be placed in initrd by default and was told it did get setup that way so you could boot from USB 3.0 if your PC supported such booting with openSUSE 12.2. At the time I was chain loading a 12.2 RC candidate from my USB 3.0 drive and I never had a problem with data loss. That is why I think we need to see the fstab file and a fdisk -l to make out more of the situation. A USB 3.0, 3.0 TB hard drive with a GPT disk on a UEFI PC trying to boot openSUSE might present some issues. But, it is working he says, but just corrupts data. All of the external hard drives I use are self powered, but a small 2.5 : drive might be USB powered perhaps and this may be where the problem comes in. I know that some computers provide continues USB power for charging and you could enable the feature and plug your self powered drive in there. You can also buy a adpter that allows external 5 VDC to be supplied to a USB device, separate from the PC.

Thank You,

Thank you.

Yes, the hdd has no separate power supply, and yes, there is a switch in the Bios for continuous USB power.
I’ve tested that after my original posting. It works too, in the sense that I have no corrupted file system using this, but after shutdown, the drive simply continues to spin until I pull the plug of course. So it is not very convenient either.

My partitioning is a little “experimental” but, it basically works.


/dev/disk/by-id/ata-TOSHIBA_MQ01ABD050_828TT6A9T-part2 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-TOSHIBA_MQ01ABD050_828TT6A9T-part1 /                    ext3       acl,user_xattr        1 1
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 Köpfe, 63 Sektoren/Spur, 60801 Zylinder, zusammen 976773168 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2dfc7fbf

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1            2048   104855551    52426752   83  Linux
/dev/sda2       104855552   174063615    34604032   82  Linux Swap / Solaris
/dev/sda3   *   174063616   383776767   104856576   83  Linux
/dev/sda4       383776768   976773119   296498176    f  W95 Erw. (LBA)
/dev/sda5       383778816   488632319    52426752   83  Linux
/dev/sda6       488634368   593489919    52427776   83  Linux

Post the output into Code # blocks. Do you use Grub2? Do you use systemd or did you switch back to system V?

The rest is a fresh installation from KDE-Live using Grub2 and all the defaults.

The only thing I see theo222 is that you don’t have a separate /home partition. You say the hard drive is USB 3.0, but are the USB port on the PC USB 3.0 rated?

Thank You,

Yes. The components are rather inexpensive, but the mainboard has two USB 3.0 ports.
Barbone almost like this, but supports Ivy bridge out of the box. ASUS - Barebone PC- ASUS S2-P8H61E
HDD Toshiba - STOR.E PARTNER

Of course it is not a big problem for me, but as deano_ferrari says:

Well, I would hope that udisks/udev is consulted, and any removable media partitions unmounted before the halt process kills the usb subsystem.

I think it would be nice if this issue could be addressed for a future release or update.

Thank you.

My suggestion is since I have not seen this problem due to using self powered USB hard drives, you need to consider posting a bug report here: Bugzilla Main Page

Thank You,

I will do that after some more tests. For example, I want to know if Fedora behaves differently.

Thank you.

That is fine to test more as it makes good info in your bug report. Unless someone else has a similar type of hard drive, you may be one of the few that can help fix the issue. We wish Fedora all the best, but we want openSUSE to be fixed first.

Thank You,