OpenSuse 12.2 keybord problem again

I’m sorry to reopen this issue. I’ve read previous posts but there is nothing there that seems to help me.
I want system messages in English, and I have a Swedish keyboard. The keyboard does not respond as Swedish, although I cannot
find any place where the system could have gotten it wrong…

On yast-> system keyboard configuration I have the desired choice, i.e., Swedish
On /etc/sysconfig/keyboard I have KEYTABLE=“” which is compatible with the above. Also the last line reads:
YAST_KEYBOARD=“swedish,pc104” which seems OK to me.

On yast-> language I have English as primary
On /etc/sysconfig/language I have en_US.UTF-8, which is compatible with the above.

I run kdm and fvwm on top of that (not kde). Anyway, in KDE:system settings I have:
Locale: Country Sweden, preferred language American English. Still seems correct.
Input Devices:
Under “layouts” I only have Swedish layout. No english whatsoever. I tried having both and switching order, without any result.
Under Hardware I tried different choices, without differences. Current setting is Logitech Cordless. I also tried Generic 104 and Generic 105.

The problem: The keyboard is not Swedish as it should, namely the key near the right shift gives /? instead of -_ as it should.
This happened after upgrade to 12.2.

What am I doing wrong?



cat > /etc/X11/Xkbmap

See file $HOME/.Xkbmap


cat > ~/.Xkbmap
-layout “se” # (for swedish. Use fr, fi or whatever you need)

Next time you login the keyboard will comply with the choice in ~/.Xkbmap

I have the same problem, and I am tired of dealing with such back to the 80’s problem !

Nevertheless I have observed the following :
I have installed 12.2 on my desktop, full fresh install (upgrade from 12.1 lead to system not founding the disks… !) the keyboard problem rises (I have selected fr_CH as locale with french language for the interface (except for root, which have locale set to fr_CH but language is english)
I did the exact same installation of 12.2 on my laptop → no single problem, the keyboard layout is correct
I did the fullk new install onto kvm, virtualbox, qemu, vmware ESX4, ESX5 and workstation 7 and I had no problem

The only difference is that I use Logitech keyboard on my desktop through USB and my laptop has the embedded keyboard, using the legacy keyboard conector, I mean that the laptop keyboard is not connected to USB buses, as other embedded devices are (fingerprint reader etc…), this is also true for all vm’s, the emulation does not emulate USB keyboards, but instead legacy keyboards.

I did the desktop install again, using another keyboard (USB, but another model of Logitech) same issue

I will continue searching why, but it looks like kdm is not seeing USB keyboards and sets to “en” layout (default)

On 2012-10-02 21:26, mnatiello wrote:
> cat > /etc/X11/Xkbmap
> # See file $HOME/.Xkbmap
> ctrl-d
> cat > ~/.Xkbmap
> -layout “se” # (for swedish. Use fr, fi or whatever you need)
> ctrl-d

You should not need to touch /etc/X11/Xkbmap, as ~/.Xkbmap supersedes it. If it doesn’t, it is
probably a bug you should report in bugzilla.

Unless what you mean is that the file does not exist.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))