[opensuse 12.2 kde 4.8.5] firefox 37.0.2 installAn

Greetings !!

I have a particular problem: I try to update to 37.0.2 each computer in the lab that runs opensuse 12.2.

Basically we have the firefox 26.0 version.
I downloaded the firefox version and installed on almost all the computers but one of them have issue.

When downloading file in /root/Documents for example (only on this computer) when I try to use “open containing folder” I got dolphin opened with path like /home/Downloads’/root/Documents/’.After this the system came unstable, I got to log off/on to recover a perfect responsiveness.

I tried to uninstall firefox (with zypper) remove 37.0.2 reinstall firefox 26.0 → it works
I reinstalled 37.0.2 → the issue came back

Any idea ? I checked only two computers on 12.2 it worked and one computer on 11.4 it also worked (the feature “open containing folder”)… I have no idea but trying to find in the source and try to fix this.

Thanx in advance for any advices ^^

Your problem is probably the out of date 12.2 OS. Where did you get the 37.0.2 FF install file?? You can not mix apps compiled for newer OS versions with older. What make thing worse if you used a newer repo to get FF is that you probably pulled in a bunch of other incompatible things. But you did not say wher you got the FF install so I’m guessing based on you saying you tried uninstalling with zypper

I wasn’t precise enough → I get the install file from mozilla website.

The zypper was used to uninstall MozillaFirefox-branding-upstream (tried with branding-openSUSE also) and MozillaFirefox.

More precisions concerning how I installed firefox 37.0.2 on every computer of the lab (10 12.2 and 5 11.4)

I downloaded from mozilla website the 37.0.2 (english us version)
I put the .tar.gz on a folder named /installz/firefox
I renamed the /usr/lib64/firefox to /usr/lib64/oldfirefox
I uncompressed the tar.gz into /installz/firefox
I moved the firefox folder to /usr/lib64/
I copied the firefox.sh from /usr/lib64/oldfirefox to /usr/lib64/firefox

It worked on three computers I tested.
The fourth I could test before ending my day → I got the described issue.

Well, I don’t think this is an installation issue.
I would rather suspect that this “corrupt” path comes from Firefox’s settings/profile.

So, check in the settings what download folder is configured. And try with a fresh user account or after removing the ~/.mozilla/ folder whether the problem still occurs.

In 28.0 that is working the working path is /

I used already the about:config feature in 37.0.2 to check if there is something wrong (the append of the folder selected for downloading with quotes) to /home/Downloads (that is not correct when logged with the root user).
I didn’t see any properties that wrap the selected folder name in quotes.**

browser.download.folderList** must be set to 2 regarding

browser.download.folderList
**Indicates the location users wish to save downloaded ****files to. ****
Values: ****
0 - The desktop is the default download location. ****
1 - The system’s downloads folder is the default download location.
****2 - The default download location is elsewhere as specified in **browser.download.dir.
If invalid, userDownloadsDirectory
will fallback on defaultDownloadsDirectory.

Looking at the firefox sources, there is a file nsDownloadManager that makes an Append() (c++ method call) when NS_UNIX_DEFAULT_DOWNLOAD_DIR can not be loaded.

But I tried not enough to be certain the issue is located at this part of the code.

That can not explain why it worked on the three other computers.

I tried with a brand new user → same issue.
The issue is Application related. No other application do the same (Konqueror works perfect).