openSUSE 12.2 - Grub2 screen and tty1 Gecko logo

I installed Opensuse 12.2 today with GNOME thru the live ISO. When I rebooted, my GRUB2 screen was black & white (no graphical mode).
Plus, when I switch to tty1 there’s no background screen and no Gecko (wich made me very sad).
There’s something I can do to change the GRUB2 looks and rescue my Gecko in console?

I had the same problem with a live KDE install, Grub looked like something from a ZX81. Open Yast/bootloader/bootloader options. Default boot section tick ‘Use Graphical Console’ and pick console resolution and console theme - when you click browse there is only one ‘theme.txt’ pick that. OK - reboot to check.

Thank you very much! I did that and it works fine! About the background screen in tty1, i did some research and found no answer. Some people said that it had to patch the kernel and recompile again to have the gecko and the background screen in tty1. Others said that it might have something to do withe the framebuffer option. I was wondering if the KDE users have this working fine and maybe is just GNOME’s fault. Anyways, I’m installing the KDE just to check this up!

Which graphic card do you have? I have that on my PC with proprietary
nvidia drivers that the virtual console has no background and a low
resolution, but I have not investigated until now how to solve that.
Graphical grub2 selection screen is shown with high resolution, as soon
as plymouth starts it switches to I think 1024x768 until the x server
starts and sets that to the native 1920x1080, tty remains on the low
resolution plymouth had and without framebuffer support from what I see.

PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

My graphics card is Intel. I really like to have a background and Geecko in my tty console. I think that as a differential feature of openSUSE and don’t know why don’t work in 12.2 since it works in 12.1. My GRUB2 is working with the theme selected and plymouth works to.

It seems the gecko has been removed in 12.2, I checked that on the 5
systems which I have updated until now (2 nvidia and 3 intel graphics).
Two of them are KDE systems, three are Gnome 3 systems, so it looks
unrelated to that.
Sorry no idea how to get the tty background back, I have not tested what
happens when the system is switched back to grub legacy and I am
reluctant to do so, all systems are grub2.

If that is important for you maybe you could ask at the mailing list if
a developer can answer why it was removed and if that was intentional or
by accident. I also found it nice and pleasant but it is not really
important for me so I missed that it disappeared on all 12.2 systems here.

PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

Thanks a lot. I will try to do that!

Same issue here. Please let me know what they say.

Thank you

I don’t know if there is a better way, but I did eventually manage to get the Gecko logo back after lots of fiddling around. Filtering out all the stuff that got me nowhere, here’s what worked:

  1. zypper in bootsplash
    (‘plymouth’ will be removed)
  2. mkinitrd
    (then reboot to see changes)

From what I can tell, I don’t think the Gecko background has been removed; rather, the change to Plymouth for the boot sequence animations appears to deactivate it on the tty. Apparently bootsplash is pretty old, so if anyone knows how to make Plymouth behave the same way I’d like to know.

Side note: I didn’t much care for the 12.2 background, so I looked around more and discovered there are “themes” for bootsplash in /etc/bootsplash/themes. The documentation for bootsplash seems kinda sparse, so I just copied over the jpg files in /etc/bootsplash/themes/openSUSE/images/ of an old openSUSE 11.4 installation to the the 12.2 one… going for a “retro” look :wink:

Sorry to dig this.

I think I found out why.

tty1 gecko is implemented by a kernel patch, bootsplash-branding-openSUSE and bootsplash package.

we openSUSE developed that kernel patch on our own, it’s in patches.suse.tar.bz2 and got enabled in configs.tar.bz2 “config_bootsplash=y”. so the kernel part is good.

and the bootsplash-branding-openSUSE is good too.

The only thing is that plymouth replaced bootsplash package.

So either you have the tty1 gecko(console background) or you have a boot animation.

I’m asking in #opensuse-factory ML to see if there’s a way plymouth dev can get them reworked in plymouth.


Thank you very much for all the answers!

I’ve tried to uninstall plymouth and install bootsplash package, and unfortunately, it didn’t work.

The weird thing is:
I’ve installed an openSUSE 12.2 from a full dvd disc iso.
There was a plymouth splash and at the very beginning of installation, I could see the Geecko
and a green background when I hit “esc” to see the installation info. The background was the same from plymouth.
Soon it booted from HD, the background and the Geecko were gone :frowning:

Plus, there’s something wrong with the text in the terminal. Looks like it lost the reference of the leftmost column of the screen.
Sometimes it chains the strings like it has no idea of the display format.

Thanks again, and sorry for all the trouble.

I received Virga’s PM and I dig this thread again.

because I found a workaround, letting you have both the tty1 gecko and plymouth animation. what’s more, you can have geckos in every tty.

so here it is:

install fbterm package from M17N and fbgrab package from home:MargueriteSu

use google-translate to read this wiki written by me: SDB:Fbterm - openSUSE

it will tell you how to setup fonts/mouse/everything in Fbterm, I have no time to translate it into English, but anyway the command line and .fbtermrc is alway English. there’s also something about input method which you can just skip.

then make a shell script:

          # fbterm-bi: a wrapper script to  enable  background       image with fbterm
           # usage: fbterm-bi /path/to/image fbterm-options
echo -ne "\e?25l" # hide cursor
           fbv -ciuker "/etc/bootsplash/themes/openSUSE/images/bootsplash-$YOUR_RESOLUTION.jpg" << EOF 
          export FBTERM_BACKGROUND_IMAGE=1 
          exec fbterm "$@"

Then name it anything like cfbterm, c stands for China, you can name anything like defbterm or frfbterm or just susefbterm

then copy it into /usr/bin

and paste this line into you .bashrc

 $(tty) == \/dev\/tty[0-9]* ]] && cfbterm

that’s it!

now everytime you switch to any tty, login, it’ll be switched to fbterm and you have your any background.

  • for gecko lovers, you may need to combine opensuse logo and jpg background together using gimp. I suggest you put gecko to the top right, because unlike bootsplash, fbterm use the whole screen, top left will be covered by your bash prompt…

  • and remeber: to save that background in **png **format. jpg displays ugly in tty mode. screenshots can see my last link.


Hi to all. I’ve installed recently oS 12.3, deleted plymouth and got black tty1. :frowning: So I backported bootsplash package from oS 12.2 (link) and installed it and bootsplash-branding-kde package and ran sudo mkinitrd. I saw that my resolution 1280smth wasn’t supported and set 1024768 at both of yast grub2 settings options. Then I rebooted and got black tty1 again. :\ I ran sudo mkinitrd again and saw that bootsplash found kde theme! So I rebooted again and got pretty light-blue tty. :slight_smile:

Sorry for revive this thread, but I have to thank DarkSS for the bootsplash package backport (Thank you very much DarkSS!!).
I installed in openSUSE 12.3 and it works just fine!
Also, I search in for “bootsplash-branding-openSUSE” and installed it, after installing the bootsplash package provided by DarkSS. Yast prompts you to remove “bootsplash-branding-kde”, installed with the bootsplash package.
After all that I run mkinitrd as sudo and reboot.
Bootsplash was there with Geeko :o !