openSUSE 12.2, Firefox, and Java problem? 64 bit machine

Ever since I updated to openSUSE 12.2, I get this error on several sites, youtube and facebook included, that says: “Additional plugins are required to display all the media on this page”. Youtube video pages tell me that I need to install a plugin to see the videos. Naturally, when I click “Install Missing Plugins”, it never works (and never has on my Linux PCs), so I have to figure out on my own what plugin it is. When I go to , I see that IcedTea is an unknown plugin. I uninstalled it as well as openJDK 1.6 and openJDK 1.7. I reinstalled just 1.7 no IcedTea plugin. Now I still get the message saying that additional plugins are required, and when I go to I get a message saying: “For your safety, Firefox has disabled your outdated version of Java. Please upgrade to the latest version.” When I go to about:plugins to try and enable it, Java isn’t even listed to enable it. If I install IcedTea again, the browser still tells me I need a missing plugin, and it is listed in about:plugins as an unknown plugin again. If I remove IcedTea again, it still says I need a missing plugin and tells me again that Java is disabled because it is out of date, but again there is no way to enable it. So… what can I do to resolve this?

Also, I’m assuming it’s Java that is the problem because I have no way to check, but it may be another plugin… I do have Totem and Shockwave flash, so I don’t know what else I may be missing…

Thank you,


You are probably missing flash as youtube is complaining
Please check this guide
Also checkout mmcheck

I have flash installed; however, I ran through all the steps on both guides, and I still have the same issue with firefox. I’m going to try a new profile on Firefox and see if that works. Anything that mmcheck found that was missing I installed, and now everything checks out, though there are a few more packages than it lists. For example, it says that with openSUSE 12.2, no sun java packages are included, but I had two installed, and for flash, I had 4 packages, not just 2 or three. I had the normal 2, plus flash for KDE and flash for Gnome.

Any other ideas?

Thank you,


Edit: I have now tried another profile on Firefox, and youtube and facebook work just fine. Ugh… do I have to blow out my profile and reinstall all my extensions???

I am afraid you need to do it. Also unless you use sync please backup your bookmarks

Well that seems to have done it. I had a similar problem on my laptop when I upgraded to 12.1 on my laptop, which I think I posted in these forums, but my desktop still worked with firefox on 12.1 for some reason, and blowing out my firefox profile on my laptop fixed that issue. This time, since my laptop’s motherboard died just last week, I restored my laptop’s profile onto my desktop hoping it would work and I would not have to reinstall all extensions. Fortunately it worked. So, that’s my wordy way of giving the resolution to this issue. The brief unwordy solution:

Problem was in the profile. Solution: Create a new profile (or use one that works on another machine with the same OS).

Thank you to each of you who helped to look for the solution. :slight_smile:


do backup yours bookmarks and stuff or use sync so that you are not inconvenienced when you move between profiles.