OpenSuSE 12.2 DVD won't boot in UEFI mode


I’m trying to install OpenSuSE 12.2 on my laptop (Dell Inspiron 15z Ultrabook), alongside with the preinstalled Windows 8 - hence I have to stay in UEFI mode.

The installation DVD will not boot in UEFI mode. It prints the following lines :
ELILO boot: …
Loading kernel linux… done
Loading file initrd…

Then it prints something I do not even have time to read (errors ?, and reboots. I have tried several times but it’s too fast for me to read the messages…

I used the same DVD some days ago in legacy mode and it worked.

I did disable the SecureBoot option.

Thanks in advance for your help.

Press TAB on ELILO prompt, you should see possible choices. There should be failsafe (do not remeber exactly). Try booting this one (just enter exact word and repss ENTER). Does it boot?

Also testing current 12.3 beta1 would be helpful to know whether this is kernel issue which is already fixed.

You only have linux and rescue and no graphics options of the same.

@DarkMagus237 when it looks like it’s stopped, if you press ctrl+alt_F4 you should get an output screen on what the system is doing, what errors? Maybe a screenshot with a camera posted online and the link posted back? You can use SUSE Paste please set the image to ‘not expire’ in the drop-down.

Thanks for your replies.

@arvidjaar : I indeed tried the various boot options, but there is no failsafe. I’ll check the 12.3 DVD soon.

@malcolmlewis : the problem is, the computer reboots automatically after the error messages, not giving me enough time to read them. But I can try capturing it with a video, if I’m lucky. I’ll check and post the results.

Okay, I was able to retrieve the message by making a video (quite fun to use one laptop’s webcam to film the other BTW).

Here’s the full message :

ELILO boot: …
Loading kernel linux… done
Loading file initrd…done
elilo.c(line 276):
ExitBootSvcs: failed, memory map has changed.

elilo.c(line 279):Main_Loop: Retrying,… have to rebuild boot params

Though it doesn’t give much information when googled.

Oh :frowning: That’s pretty bad, it means ELILO is incompatible with your motherboard. Please open bug report on, specify your exact motherboard model and BIOS version. Also please test current 12.3 (although I do not expect any difference as it is still using the same ELILO). Please post bug number here.

As I see you have two options assuming grub2 works

  1. try to install using grub2 from USB stick. I do not have experience with creating USB installation media, someone else hopefully can tell more
  2. install in legacy BIOS mode, create USB stick or grub2 recsue ISO with grub2 bootloader, boot using it in EFI mode and finally fix your bootloader

Unfortunately, to verify whether it works we already need Linux installed. It may be possible to create grub2 image with RAM disk containing all modules and try to boot Linux from installation DVD using it. But it needs time to prepare.

Thanks for your help. I filled in the bug report 800035 on BugZilla.

For now, as a temporary workaround, I installed in legacy mode and installed GRUB manually on an USB stick.