openSUSE 12.2 Beta

Hello at all,

I have installed openSUSE 12.2 Beta 1 on my computer (I used GRUB2 and skipped insttall from images) The installation works until when it comes to logging in to KDE after rebooting, when I try to enter my password, nothing happens, just the login screen stays as it is. I haven´t found any thing in Bugzilla. :-(( Any ideas??

thanks in advance!!


Make sure the session is kde-plasma-workspace

Just be careful typing the password… some have reported a 12.1 bug being carried over to 12.2

Yes, I confirm both, kde-plasma-workspace isn’t automagically selected, and the second-carachter-missing-bug also exist installing on a real machine (grub1), in a virtualbox install (grub2) the bug is absent.:-))

I sometimes have to click the enter button on the screen.

Normally, I enter password and hit enter on the keyboard, and that works. But if, after entering password, I click one of the other buttons (to select the session, for example), then a subsequent ENTER on the keyboard doesn’t do anything. The mouse focus is probably at the wrong place. The enter button on the screen does work.

Yes I had the same issue when I [finally] got SUSE to install. I was unable to log in at all using the account credentials supplied at install, only being able to login as root.

It seems [in my case] that the user account is not created at install time so I had to log in as root and create the user manually, logout, and all was well again. Logged a bug for anybody interested.

Good evening Geekos, openSUSE 12.2 Beta 2 is out: openSUSE News
You can get it from here Index of /factory/iso -> build451

I had installed openSUSE 12.2 Beta 2 using openSUSE-NET-i586-Build0451-Media.iso.
Installation when smooth without any issues; the same goes for the first time configuration. As far as i noticed the software management module is still crashing but the vbox guest additions packages are working as they should. KDE has an issues with widgets that use python, they dont show up an error just empty space see this bug report The boot splash is well... different, i cant say i like it too much, still flying dots that merge in to one is kind of funny :slight_smile:

PS: a moderator could change the title of the topic in openSUSE 12.2 Beta 2 ?

On Wed, 20 Jun 2012 19:26:02 GMT
creatura85 <> wrote:

> I had installed openSUSE 12.2 Beta 2 using
> openSUSE-NET-i586-Build0451-Media.iso.

Beta2 is build 452. I tried 451 from KDE liveCD and NET but both
stalled mid-install on two different machines. Just downloaded Beta2
DVD and hope for better luck when I try it out tomorrow.

Graham Davis, Bracknell, Berks.
openSUSE 12.1 (64-bit); KDE 4.8.4; AMD Phenom II X2 550 Processor;
Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

Just installed 451 GNOME Live CD in a vmware player machine, installed
fine, and desktop effects working… sofar so good for me.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.31-0.9-default
up 19:54, 2 users, load average: 2.98, 1.91, 1.66
GPU GeForce 8600 GTS Silent - Driver Version: 302.11

The 64 bit DVD is build 452. The other formats are mostly build 451.

I am already having problems with build 452. More later.

build 451 live kde has been failing with yast second stage. everything seemed ok on openqa but not on my real hardware.
I am downloading the full dvd build 452 and see if that helps.

Here are the problems that I have had thus far:

1: Install from DVD. The partitioner wanted to format “/home”. I suggest that you watch carefully. It might be because “/home” is encrypted, but this has never happened in previous installs, not even with Beta1.

Apart from that, the install went well up till the reboot. On reboot, it hung in plymouth. So it never completed the final configuration steps of install.

Worse still, there is no “failsafe” boot. In its place, there is a repair boot. But that’s not equivalent. The final stages of install would complete in text mode (curses mode) with a failsafe boot (that happened with Beta1). That does not happen at all with Beta2 and the repair mode boot.

2: Second install attempt from the DVD. This time, I took the default KDE and did not try to install other software. That was mostly to speed up a second test of the plymouth problems.

This time the grub2 install failed. I’m guessing that there’s a dependency problem. Some of the other software that I installed for the first try may have brought in what grub2 requires. Note that grub2 did install for the first attempt, but not for the second.

Then it hung in plymouth again.

3: I booted the KDE live image and selected “installation”. It hung in plymouth.

4: That gave me a clue that it was a graphics problem rather than a luks encryption problem. I booted the KDE image again, selected “installation” and then added “nomodeset” to the boot command line. It booted into the installer. Now that was a big hint.

5: I backed out of the live image install, and tried booting my installed system (from 2 above) with “nomodeset”. The final configuration stages of install now completed.

6: I rebooted, without “nomodeset”. That works, now that the final configuration steps are done.

Sigh! So much time spent to discover this. And I’ll need to make some bugzilla posts (I’ll wait till tomorrow for that).

[opensuse-factory] Status: Beta2](


I’ll upload Beta2 any time soon (build451 basically) and after
that create and bootstrap openSUSE:12.2

I’m not yet sure where to put the resulting FTP tree, but we’ll
find a place :slight_smile:

Greetings, Stephan

I zypper dup’d from M3 to Beta1 and now from Beta1 to Beta2. Worked fine both times. Looking good.

Hi All

I installed the Beta 1 (from live cd) with the live installer on the running live system because the “installation” the screen stay black
Then I update ta Beta 2 with no problem. All seems good for me except I have to desable then re-enable wireless for it to work

That rocks really good work !

My experiences with openSUSE Beta 2 DVD (Build 452)…

  • The final configuration stage of installation failed to run completely, resulting in a incomplete installation. However, there was no problems installing with images enabled like there was with Beta1.

  • Grub2 installs this time but by default it sets the graphical console to a resolution which is too high and is unable to be displayed on my monitor reporting “Screen mode not supported”. Grub2 still accepts keyboard input however and I was able to progress with the boot.

  • Trying to boot into the partial installation failed with it hanging at the animated splash screen. Attempted reboots and this problem persisted.

  • Reinstalled Beta 2 and altered the Grub2 graphics console (via installation gui) to a supported resolution but the change didn’t appear to save and on reboot the result was the same (unsupported screen mode). However, this time the installation managed to get past the animated splash screen to the login window.

  • Was not able to login using the user credentials created during installation. Instead I logged in as root and noted that the user account is not created at all. Had to create user manually and logged back in ok. This problem was also noted in Beta 1. Managed to change the boot loader resolution again and this time it saved and Grub2 menu became visible.

  • Similar problems shutting down the system with the animated splash screen hanging.

  • Noticed a couple of errors being reported just before the Grub2 menu appears but they flashed up too quick to get the details. I suspected it may be to do with the Grub2 graphical console background file is missing from /boot/grub2/backgrounds/.

  • Just like to add that initially I had Beta 1 installed and after much tweaking managed to get that working and updated via the network to Beta 2 with no visible problems. This was in stark contrast to a clean installation from the Beta 2 DVD. Beta 1 allowed the configuration stage of installation to run but in the reduced text mode. So Beta2 as far as installation is concerned is a huge step backwards.

Boot with “nomodeset”. Since you have grub2, hit e on the grub screen and edit the command line. Add “nomodeset” (without the quotes) after the video part.

That got the installation to complete for me. It seems to be a failure between plymouth and yast. The system works after that.

To the SUSE Team: Thank you very much for all the hard work, it is great to see the progress…

Using Virtualbox 4.1.18, did a “zypper dup”, all seems to be Ok, or may be Not…

GUI: YaST Search gives:

YaST got signal 11 at YCP file PackagesUI.ycp:280
/sbin/yast2: line 427: 4626 Segmentation fault $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS

Yes I was trying to do that after reading your post further up. I was just struggling trying to see what I was doing within the Grub2 menu. Perhaps if I can configure the boot command line from within the installation program I can add “nomodeset” there instead of from within Grub2 menu.

Yes, there is a place in the boot configuration screen where you can modify the boot command. I don’t recall exactly how I got to that. Just experiment with the available buttons. I think it was 'boot options". But then, after the initial boot, you will want to change it back. You would need to edit “/etc/default/grub” and then rebuild the grub.cfg file. Or edit both “/etc/default/grub” and “/boot/grub2/grub.cfg”.

Incidentally, I have reported this problem as Bug 768185.