[openSUSE 12.2 -- apache2] without mod-perl and with mod_perl impossible to launch perl script

Greetings !!

I tried to access an old local web site with perl scripts that were running ok with apache2 under openSUSE 11.3 (test server)
I lost the configuration files of the apache2 server so I can’t remember how I fixed the fact that the script is either displayed on the screen or there is a dialog asking to do something with the .pl file found on the site.

I remember it was particulary heavy to make apache2 running perl scripts but I didn’t took notes and I can’t remember how I did.

The server is running ok.
I tried with mod-perl and without → same results.

I got no errors but the script is either displayed or there is a dialog asking to do something with the .pl file (I use firefox, same behaviour with konqueror).

I’m confused with the AddHandler and AddType directives and what both mod_mime-default and mime-types files content…

The log always tell me things like

[Sun Mar 30 00:33:41 2014] [warn] Cannot get media type from 'perl'
[Sun Mar 30 00:34:19 2014] [warn] Cannot get media type from 'perl'
[Sun Mar 30 00:35:12 2014] [warn] Cannot get media type from 'cgi-script'
[Sun Mar 30 00:35:43 2014] [warn] Cannot get media type from 'script-cgi'

I added/removed tried so many things that I’m completly f***** up with this apache2 perl configuration.

On perl forums there is people saying we don’t really need mod-perl, some are saying there is no other way to run perl scripts but install mod_perl… all the exemples given are not working… I got the dialog asking to do something with perl scripts (.pl ext)
There is no apache2 forums only mailing lists that sucks.

It works on 11.3 with apache2_mod-perl… same web site skeleton.

The script is chmoded to 755 (in case of…)
The directory containing the script is +ExecCGI and I tried the mod_perl strange (never seen before) things like:

SetHandler perl-script
PerlResponseHandler ModPerl::PerlRun
Options +ExecCGI
PerlSendHeader On

…but it never worked better than without those never-seen-before directives (are they new ???)

I always used the oldschool directives as

<Directory "/www/cdm2014/cgi-bin">
        #PerlResponseHandler ModPerl::PerlRun
        #PerlOptions +ParseHeaders
        AllowOverride None
        Options +ExecCGI -Includes
        Order allow,deny
        Allow from all

…it has always worked (and still works on a 11.3 computer running apache2 with mod_perl) I tried the same configuration but that failed…

I created a new folder called perl-scripts to handle all the perl scripts to be run for this virtual host. But the behaviour is the same: dialog asking for doing something…
I did that thinking that if I declare a cgi-bin in my vhost config I must specify another entry in my conf.d/mod_perl.conf file…

Still not working anyway

It works…

I was tired so I wasn’t focused enough.

The issue has been solved by commenting the line

# Include /etc/apache2/conf.d/*.conf

…I used a2enmod -d perl mod_perl to be sure apache2 won’t load them.

antares:/var/log/apache2 # a2enmod -l
actions alias auth_basic authn_file authz_host authz_groupfile authz_default authz_user autoindex cgi dir env expires include log_config mime negotiation setenvif userdir reqtimeout

I searched for each .conf file to never refer to AddHandler/AddType/SetHandler concerning perl scripts (.pl|.pm|…).

…and now it works… as it was before I jumped to 12.2.