openSUSE 12.2 64 bits - GNOME - NVIDIA GeFORCE 9500 GT - grahics screen problem


I have a dual boot system.
I installed 12.2 with no problem, but when I started openSUSE I get a messed-up screen. This means that I can see a title bar with Applications, and when I click on it, I can see Firefox etc. on the left hand side of the screen, but the screen itself is snowy blocks in different colors. The cursor is a small rectangle.
I can CTRL-ALT-F2 to a monitor screen which is fine.
I then su root and call /sbin/yast2 which is OK as well, but I get no hardware issue on graphics card nor screen definition.

IMHO there is a graphics card (?) problem, but how can I resolve it ?

When booting I get the green lizard screen, then comes my login screen which is already abnormal, and then my session screen is fully abnormal.

Any help will be greatly appreciated.


If the default graphics driver does not work, you often must download and install the proprietary video driver. You can start off by using the nomodeset kernel load option. You can use the following blog, showing how to enter a 3 to go to run level 3, thus not loading the graphic desktop, but instead, you enter the kernel load option called nomodeset instead.

How to Start openSUSE 12.2 with Grub 2 into Run Level 3 - Blogs - openSUSE Forums

Once you get a stable operating system, here are some other information to consider. Don’t forget you can use the command Ctrl-Alt-F1 to open a terminal session and use the terminal program Midnight Command (just mc at the terminal prompt) to go to different folders and to edit system files, if you logged in as root.

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums


LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.46 - Blogs - openSUSE Forums

And to deal with the new Grub 2, have a look here:

GNU Grub2 Command Help/Config Editor - Version: 1.85 - Blogs - openSUSE Forums

AND to edit system files are you get your desktop running, have a look here:

SYSEdit - System File Editor - Version 1.00 - Blogs - openSUSE Forums

While you are online, I would read through everything I could before taking any action. You can always make a LiveCD or Even USB, which to use to download bash scripts, though you would need to copy the files to your normal /home/username folder to be useable later.

Thank You,

Hello James,

Thank you for your very comprehensive answer.
I have not been able to answer yet because I was too busy at work and my wife is not happy with me spending hours with my computer.
I already tried during the week-end though, but I got a message I had to resolve dependencies for “gcc”. I do not know how to do it.
The One-Click solution did not succeed either.
I’ll keep you informed.




I tried all kinds of way until eventually I tried LNVHW, as root, of course, and in the directory usr/local/bin. I first chmod +x the file.
This gave me the following error :

-bash: /usr/local/bin/lnvhw: /bin/bash^M: bad interpreter: No such file or directory

Did I forget to install something ?

Thank you very much for your answer.


PS : it is very difficult to see everything on a nomodeset screen : I can’t even see all the buttons on my form.

  1. Open Terminal and run the following command:
sudo rm /usr/local/bin/lnvhw ; sudo wget -nc -O /usr/local/bin/lnvhw  ; sudo chmod +x /usr/local/bin/lnvhw
  1. Next, you need to edit the file and change the line 34 that reads : nVidia_folder="/home/username/Downloads" so that username is changed to the name of your /home area, basically your openSUSE user name and save the file.

  2. To edit the file you can do:

From Terminal Only: sudo vi /usr/local/bin/lnvhw

From KDE: Alt-F2 then: kdesu kwrite /usr/local/bin/lnvhw

From Gnome: Alt-F2 then: gnomesu gedit /usr/local/bin/lnvhw

  1. Before running lnvhw, you must download the latest nVIDIA driver, now up to 304.51 from the nVIDIA Web Site. You can find nVIDIA links in this article:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

I am not sure what else to post.

Thank You,

Hello James,

Well, I got quite a bit further now. I minutiously followed your advice and for the first time, I managed to execute your file.
But, somehow I got the following log-file, which I give you entirely.

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Oct  3 20:36:39 2012
installer version: 304.51

PATH: /usr/lib64/mpi/gcc/openmpi/bin:/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games

nvidia-installer command line:

Using: nvidia-installer ncurses user interface
-> License accepted by command line option.
-> Installing NVIDIA driver version 304.51.
-> Running distribution scripts
   executing: '/usr/lib/nvidia/pre-install'...
   Kernel image:   /boot/vmlinuz-3.4.6-2.10-desktop
   Initrd image:   /boot/initrd-3.4.6-2.10-desktop
   Root device:    /dev/disk/by-id/ata-ST3500830AS_9QG5BBZB-part5 (/dev/sdb5) (mounted on / as ext4)
   Resume device:    /dev/disk/by-id/ata-ST3500830AS_9QG5BBZB-part2 (/dev/sdb2)
   modprobe: Module hid_generic not found.
   WARNING: no dependencies for kernel module 'hid-generic' found.
   Kernel Modules:    thermal_sys thermal processor fan pata_via sata_via ata_generic scsi_dh scsi_dh_hp_sw scsi_dh_alua scsi_dh_emc scsi_dh_rdac xhci-hcd hid-logitech-dj 
   Features:       acpi plymouth block usb resume.userspace resume.kernel
-> done.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
ERROR: Unable to find the kernel source tree for the currently running kernel.  Please make sure you have installed the kernel source files for your kernel and that they are properly configured; on Red Hat Linux systems, for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM installed.  If you know the correct kernel source files are installed, you may specify the kernel source path with the '--kernel-source-path' command line option.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at

So what do I do with that ?

I think your bash-file is extremely well made, but somehow, I got stuck.

Thanks, as always, for your answer,


So from the following link, already provided, I specified added things you needed to do: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

Open YaST / Software / Software Management - Select the View Button on the top left and pick Patterns. Now, you will see several Patterns listed and you want to select:


[X] Base Development
[X] Linux Kernel Development
[X] C/C++ Development

Then Press the Accept button on the bottom right and allow these applications to install.

There are several things one must do to get this to work and the first is to read through the links I have provided. I can say that some things you need to do are foreign to many, but I don’t set the requirements that nVIDIA decided you need to load their driver. I am just trying to help the best I can do.

Thank You,

Hello James,

I did as asked, now booting in normal graphics mode.
Thank you for your effort. It was quite complicated, though.

But I succeeded eventually.

Thank you,


Well I like to hear about success. The process to install a proprietary video driver can seem complex and it really has to do with how much experience you have with Linux and openSUSE and getting hardware to work. Windows is not without its hardware issues either, but no one will make it with new hardware unless it supports Windows. Yet, a lot of companies don’t see the need to support Linux. This last problem is what gets us, as most support for hardware in Linux, is driven from volunteer support with little help from the manufacturers. Even so, I can attest that built-in video support is getting better every day with each new Linux Kernel release. In the last two weeks I have got two nVIDIA video systems working just fine with the open source drivers. Perhaps the next time you load openSUSE, you will not need to do anything to get your video to work. As always, if we can help you in any way, you only need to ask and good luck in using openSUSE.

Thank You,

Or goto 15. Graphics Drivers - Install Nvidia or ATI/AMD 3D Driver for a very quick and good solution!