opensuse 12.2 64 bit - slow internet / resolve host issue with software manager & default browser

Hello,
I am currently preparing a move from my not longer supported Ubuntu 11.04 to something else. I am an Ubuntu user since long time but I cannot work with the Unity interface so I started recently a little research, like in the past (some 5 or more years ago) on what DE and distribution I would use. I have played with 9 distros, first on my ubuntu 11.04 machine with virtualbox and now with a bootable USB stick on a test laptop.

I like the OpenSuse installation. It is easy, clear and within the installation you can choose the DE (gnome, KDE, …), meaning no need for several iso files to download and test.
I am now running OpenSuse V12.2 64 bit kernel 3.4.11 gnome 3.4.2 with the latest patches on an intel core2 duo T7100 with 4GB RAM.
I didnot pimp my OS or applications yet so it is fresh out of the box.
Everything seems to work nice and smooth but my all time favourite browser Firefox is very very slow on loading sites.
I checked already some threads but couldnot find any solution yet.

Pre-tests:
[ul]
[li]I did the test with wired & wireless internet connection but the result is the same, so at first sight it is not network hardware related[/li][li]I turned off the software firewall on my laptop but no performance gain[/li][li]I tried other browsers like epiphany( is even worse) and chromium (strange because this seems to be working)[/li][li]I checked with gnome system monitor the network traffic but almost no traffic load[/li][/ul]

What I have checked so far:
[ul]
[li]loading pages (for example Yahoo!) with browser:[/li][LIST]
[li]firefox message: looking up, … waiting for Yahoo! → after waiting for minutes finally loads the page but some parts on it are not loaded[/li][li]Epiphany message: oops it was not possible to show this website. … cannot resolve hostname (Yahoo!)[/li][li]chromium: shows almost immediately the page[/li][/ul]

[li]I guess the same problem occurs when using the Install/remove software (software management Yast).[/li][/LIST]
After opening this app I got the message “cannot access installation media … → skip autorefresh?”
message: download 'curl) error for ‘http://download.opensuse?org/distribution/12.2/repo/non-oss.content’; error code: connection failed; error message: could not resolve host: download.opensuse.org, name or service not known

It is not clear to me what could be the issue. I remember I read something about a name resolving, DNS issue on the newer Ubuntu version then I use.

Does someone have the same experience or know how to check more in detail for the problem and so providing a solution.
cheers,
Franky, a wanna be OpenSuse user

Welcome here!

It could be a bad DNS service. Please post the output of

cat /etc/resolv.conf

And please post this ((like any computer text copied/pasted from a terminal window in any future posts) between CODE tags. You can use the # button in the forum’s editor toolbar for this. And plaese allways post including prompt, command, output and next prompt. Thus showing everybody that the output is complete, who did it and what was the working directory.

Recommend testing several apps, even other browsers like Chrome, Chromium, etc.

If you find your problem is specific to FF, you’ll find a number of relevant posts in the Apps Forum. I myself disabled HW acceleration in FF and since I mainly use WiFi changed my tcp/ip congestion control algorithm to VENO.

HTH,
TSU

I couldnot find a quick solution for the copy/paste from a terminal to another window so I used a output file.
content / output of

 cat /etc/resolv.conf | tee ./output.txt
### /etc/resolv.conf file autogenerated by netconfig!#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search home site
nameserver 192.168.1.1  

I checked the output of the command on my working laptop with Ubuntu and see little difference.
output of

 cat /etc/resolv.conf 
# Generated by NetworkManager
domain home
search home
nameserver 192.168.1.1  

cheers,
Franky

On 12/07/2012 11:06 AM, vdmfrg wrote:
> # Generated by NetworkManager
> domain home
> search home
> nameserver 192.168.1.1

Before that nameserver line, add ‘nameserver 8.8.8.8’ and ‘nameserver 8.8.4.4’.
You will then use Google’s public name servers before it tries the one in your
router that forwards requests to your ISP. Does that help? It does for me.

If you manually edit, the file will not automatically update unless you delete the file and re-generate. This may not be an issue if your machine is used in one place, in one network… But would be an issue for a portable device like a laptop.

An alternative is to modify your network settings in Network Manger, connection properties allow automatically configuring all network properties using values handed from DHCP, or in your case only IP addresses allowing you to manually specify nameservers and the lookup order.

Have you tried using nslookup? Using the utility you can query your existing default nameservers, and query candidate alternate nameservers to see if there is a difference.

also, re the YAST software repo connection error, that happens from time to time… Not often but is usually resolved on its own within an hour or so… so is not yet a true indicator of possible DNS problems unless the problem persists.

Don’t overlook my suggestion to modify Firefox itself, its renderig engine might have problems with some content which might appear like name resolution issues but is not.

HTH,
TSU

On 12/07/2012 02:16 PM, tsu2 wrote:
>
> If you manually edit, the file will not automatically update unless you
> delete the file and re-generate. This may not be an issue if your
> machine is used in one place, in one network… But would be an issue
> for a portable device like a laptop.

Yes, it will not be updated; however, the Google nameservers are valid everywhere.

If every network you connect to is a public shared network like WiFi hotspots, using Google’s nameservers all the time would not be a problem.

But if any of the networks provide local (network) resources, then it’ll typically be a problem because you <must> connect to private DNS to resolve those names.

TSU

Thanks for the info.

I removed OpenSuse from my test laptop and did some more tests:

  1. I installed OS12.2 again but this time I unticked ‘use automatic configuration’. I never never finished the installation because of some errors I got when the installer was at the configuration part. I removed it again.
  2. I installed OS12.2 but with the default ticked ‘use automatic configuration’. I tested the speed of FF V14.0 and it was slow or not usable like I mentioned before. So this is a good sign because I can repeat the situation.

As TSU proposed 2 methods to test I tried to do this.

  1. manually edit the file
    → I didnot find how to do that yet. I will read some howto’s and other specific OpenSuse stuff when I am actually using OS12.2
  2. using the networkmanager
    I found how to start/stop the network or to open the network connection gui on a terminal (cmd: service network restart ; cmd: &nm-connection-editor)
    Using the network icon and select network settings I could change the options for wired and wireless network settings.
    Step 1
    In my case I changed on tab3 (IP4 settings) for wireless connection method to 'automatic (DHCP) addresses only and added in the DNS servers field 8.8.8.8 8.8.4.4
    I tested it and the difference is incredible. FF is fast! :slight_smile:
    I continued the test and turned wireless off and turned on the wired. FF is slow!

Step 2
In my case I changed on tab3 (IP4 settings) for wire connection method to 'automatic (DHCP) addresses only and added in the DNS servers field 8.8.8.8 8.8.4.4
I tested it and the difference is incredible. FF is fast! :slight_smile:
I continued the test and removed the settings I changed in step 1 and turned wired off and turned on the wireless. FF is slow!

I never had to change these settings in Ubuntu. Very strange I have to change this in OS12.2 but I am glad FF is fast as before and also the update part is going fast.

Thanks for the persons who helped me on this forum.
I hope other people will read this thread and will be helped with the info.
cheers,
Franky

Cool!
Glad to hear it worked.

Remember your DNS config is connection specific. If you connect to another network by default you wiil use that network’s DNS but now you should know if the conditions are similar to your current how to change.

TSU