openSUSE 12.1 x Kyocera 1020d

Hi, first of all, sorry for my pour english.
Someone please help me to install my printer on new openSUSE 12.1. I take this from documentation:


Autodetected: Icon-checked.png, USB, Suse 10.3

Works perfectly. (incuding duplex and optional paper slot)

Autodetected: Icon-cross.png, USB, Suse 11.1

Unfortunately yast doesn’t find a driver for the printer. (see details below) The trick is to

  • get the ppd-file for the printer from

  • start the web interface to cups: http://localhost:631/

  • install the printer using “Manage Printers”

  • if asked for the printer name, use the ppd file (loaded with the button - cups only listed the newer FS1030D model)

Details for yast: The printer is detected, but no driver found.

Trying to install PPD from vendor CD: PPD seems to be parsed and accepted, but yast still complains about missing driver.

But when I got do web interface of CUPS, and I click on Add Printer I got only these options:

Add Printer
Local Printers: HP Printer (HPLIP)
Discovered Network Printers:
Other Network Printers: Internet Printing Protocol (http)
AppSocket/HP JetDirect
LPD/LPR Host or Printer
Internet Printing Protocol (ipp)
Windows Printer via SAMBA
Internet Printing Protocol (https)
Backend Error Handler
Internet Printing Protocol (ipps)

How can I use the PPD file? Please!
Thansk in advice.

… ok, let me give it a try…
I have a FS1020D myself. And it is working just fine on 12.1 (Connected by USB)
Unfortunately, it is not at the computer I’m working at right now. So I have somewhat to guess.

I had big problems with it, I think on 11.4 or some such. But for 12.1 I don’t remember any particular problems.
(Had it set up by yast during installation) So it is definitely supported by yast2.
First thing - just to make sure - is to do an “Online Update” in yast, to make sure you got all the newest parts.

The second thing then, is to “play” a little bit with the “Driver” search field in yast2. IIRC there was some mess here some time ago. So trying only substrings (like “1020”) and things like that might help. Don’t use the full name. (There had e.g. be problems with “Kyocera” <=> “Kyocera Mita” <=> “…” for the name)


With my old problems, my recommendation is to “play” a little