openSUSE 12.1 won't install on HP P6-2023de

Hi all,

I have tried to install openSUSE 12.1 on a HP P6-2023de (specifications can be found here) but so far i have not successful.

What I have done so far:

  • Removed the partition which holds HP recovery software
  • Reinstalled Windows 7 Home Premium (64 bit) in legacy mode in one giant partition (~2 TiB), although the Windows installer created two partitions (one for MSR, the other for OS)
  • Tried to install openSUSE but it fails with the message “The partition on disk /dev/sda is not readable by the partitioning tool parted, which is used to change the partition table. You can use the partitions on disk /dev/sda as they are. You can format them and assign mount points to them, but you cannot add, edit, resize, or remove partitions from that disk with this tool.”
  • Verified that both partitions are NOT dynamic but basic partitions
  • Resized the Windows partition to have 100GB unallocated space at the end of the hard disk. Installer then continued and let me create 3 partitions (swap, / and /home) but hangs during the installation of the kernel (Desktop, 64bit). I tried to reboot but couldn’t load Windows 7 anymore (“no OS installed” message, although Windows 7 partition is still there untouched, only MSR partition was fubared)
  • Tried Ubuntu 11.10 but the installer wouldn’t even load and instead hangs during hardware recognition(?)
  • Read the thread Grub cannot install boot loader on HP ProBook with 500 GB HD which confirms that HP is pure evil and no one should ever buy one of their products

Does anybody have any idea how to proceed?

Do you have a proper Windows install DVD?

Are you installing SUSE with a DVD or CD?

If you have a live CD can we see

su -
fdisk -l

Have you verified your media?
http://dl.dropbox.com/u/10573557/12.1_install/01_bootsplash.jpg

Thanks for the fast reply!

Yes, I have a proper Windows install DVD.

I am using the openSUSE 12.1 DVD and verified that the installation media is OK. I had to choose the safe settings kernel. The default kernel wouldn’t work, the installer just sat there on the green openSUSE screen and never got past that.

I have tried to boot the Ubuntu Live CD (11.10, 64 bit) but couldn’t get it to load. It hangs during hardware detection in legacy mode. In UEFI mode it simply says “Error: prefix is not set” and won’t load at all. I have tested the installation media on another PC and it works just fine. I have also tried to load Parted Magic. Same result, it won’t load completely and hangs (“EISA: cannot allocate resource for mainboard” or “drivers/rtc/hctosys.c: unable to open rtc device (rtc0)”) using Default and Safe settings.

I guess there is something seriously wrong with the components used in HP computers…

Oh yet another MS only machine.

:frowning:

Hold on, not so fast. I was finally able to load Parted magic using the “KILL Nouveau” option from the Extras menu. I will post fdisk -l output in a second! Don’t give up on me yet! :slight_smile:

LOL ok then try nomodeset as an kernel option. That will stop nouveau from loading. You will also most likely have problems later e on until you install the Nvidea proprietary driver. Untill then you will need to type nomodeset at boot.

Ok, here it is.

root@PartedMagic:~# fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x690fbf09

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848  3907026943  1953410048    7  HPFS/NTFS/exFAT

Having been able to load Parted Magic leads me to believe that there has to be a way to install Linux on this machine. If not, then this would be the first time in 14 years I failed to do that.

Oh a GPT formatted disk Ouch. Check the forms here it has been discussed a fair amount lately. Basically grub legacy used in OpenSUSE does not support this type of format. the newer grub2 does.

Launching GParted immediately threw an error message at me.

/dev/sda contains GPT signatures, indicating that it has a GPT table.
However, it does not have a valid fake msdos partition table, as it should.
Perhaps it was corrupted – possibly by a program that doesn’t understand GPT partition tables.
Or perhaps you deleted the GPT table, and are now using an msdos partition table.
Is this a GPT partition table?

Is this because I did not install Windows in UEFI but legacy mode?

Possibly but UEFI is not the same thing as GPT. UEFI is the new standard BIOS. GPT is a new partitioning scheme that allows greater then 2 TB on a disk. It probably needs UEFI to effectively use GPT but that is not a certainty, I simply don’t know yet, Maybe someone with more hands on can jump in and tell us.

Legacy Grub, which OpenSUSE uses, does no understand GPT Grub2 does. You can use Grub2 but it is somewhat of a bear to get working since it not yet supported in Yast which means you have to hand do everything.

Couple of articles, read them
http://forums.opensuse.org/content/102-booting-opensuse-uefi-bios-elilo-grub2-linux-only-multi-booting.html

http://forums.opensuse.org/content/105-booting-opensuse-uefi-bios-elilo-grub2-windows-dual-boot.html

I will read those articles. Thanks so far for the feedback. Also, I will UEFI reinstall Windows first to see if the error message GParted showed goes away.

Just a short update. After a UEFI install of Windows I now have a GPT that looks correct and GParted no longer complains. However, I am back to square one since the installation procedure hangs during kernel installation (desktop and default). Is there a way to see why it exactly hangs?

I don’t recall you confirming the media check
http://dl.dropbox.com/u/10573557/12.1_install/01_bootsplash.jpg

There are also complications having openSUSE beyond 128GB from the start of the HD

I did a media check, DVD is OK. See my second posting in this thread.

I do not think I have the 128GB problem. IIRC this is a BIOS limitation and I never got an error message before starting the installation procedure.

Also, I noticed that after a clean UEFI install of Windows 7, I am now experiencing shutdown problems, Windows hangs on the shutdown screen.
Could be the reason why the HP recovery DVDs only do a legacy install of Windows with a classical MBR. I am going to continue to investigate.

Ok, some progress. I reinstalled Windows 7 using the recovery DVDs and I now have a classical MBR, no more GPT. Also, I created a 100 GB partition at the end of the hard disk. Next, I launched the openSUSE installer with “nomodeset” as a kernel option (as advised by gogalthorp on the last page of this thread) and voilà, the kernel installed just fine. Now, however, I am experiencing problems installing GRUB. I am getting the dreaded error 25 (“Error 25: Disk read error”) and the command issued is

grub> setup --stage2=/boot/grub/stage2 --force-lba (hd0) (hd0,5)

For boot loader location I chose “Boot from Master Boot Record” and “Boot from Extended Partition”, both options lead to error 25. Can I install the boot loader using Parted Magic?

Oh, and here is fdisk -l output.

root@PartedMagic:~# fdisk -l

Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x028fd78e

   Device Boot      Start         End      Blocks   Id  System
   /dev/sda1            2048      206847      102400    7  HPFS/NTFS/exFAT
   /dev/sda2          206848  3697311919  1848552536    7  HPFS/NTFS/exFAT
   /dev/sda3   *  3697313792  3907028991   104857600    f  W95 Ext'd (LBA)
   /dev/sda5      3697315840  3701536767     2110464   82  Linux swap
   /dev/sda6      3701538816  3764463615    31462400   83  Linux
   /dev/sda7      3764465664  3907008511    71271424   83  Linux

I managed to install ubuntu 11.10 64 bit and it is running fine. I will reinstall openSUSE now and see if I can load it with ubuntu boot loader.

I wouldn’t call it a progress, but it’s probably the easiest option. Now you’re using legacy BIOS and MBR. Installing openSUSE on this machine should be the same as on any legacy BIOS based computer.

Oh, I meant progress in a sense that I am actually installing Windows and Linux in a dual-boot configuration without getting error message after error message. This by definition is progress.

It is the only option for the time being since doing a UEFI install of Windows leads to shutdown problems (Windows hangs on the shutdown screen or the screen goes into standby while PC does not shutdown completely). That is probably the reason, why this machine came with a legacy install of Windows 7 and the recovery DVDs do not support a UEFI install. I found another HP owner who ran into the same shutdown issue on similar hardware. I didn’t investigate this any further, because my knowledge of Windows 7, this hardware, the OEM drivers and UEFI is limited and all I want after almost a week of reinstallation-purgatory is to have a running system. Should I ever decide to abandon Windows completely I will try a UEFI install of openSUSE.

I can’t get the bootloader to install (error 25) but managed to install Ubuntu (with bootloader) just fine. Again, at this point I do not care any longer why ubuntu’s installer suceeded where openSUSE failed. All I want is a running system. I have just finished installing openSUSE without bootloader and will see if I can integrate it in existing bootloader configuration.