Opensuse 12.1 wireless problems

Hi, I just upgraded from 11.2 to 12.1 and am encountering problems with wireless connections.
Wired is no problem.

NetworkManager times out during ‘Setting network address’ giving me the message that it failed.

Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]
        Subsystem: Intel Corporation WiFi Link 5100 AGN [8086:1211]
        Kernel driver in use: iwlagn

1425.604640] wlan0: authenticate with 00:0c:f6:46:16:74 (try 1)
 1425.606578] wlan0: authenticated
 1425.607696] wlan0: associate with 00:0c:f6:46:16:74 (try 1)
 1425.613424] wlan0: RX ReassocResp from 00:0c:f6:46:16:74 (capab=0x831 status=0 aid=2)
 1425.613428] wlan0: associated
 1462.979360] martian source 192.168.0.255 from 192.168.0.101, on dev wlan0
 1462.979369] ll header: ff:ff:ff:ff:ff:ff:00:1f:e2:52:b4:87:08:00
 1471.214665] wlan0: deauthenticating from 00:0c:f6:46:16:74 by local choice (reason=3)

I have tried several things including:

  • disabled firewall
  • disabled IPv6
  • removed files in /etc/NetworkManager/system-connections

I’m basically stuck now and hope someone can point me in the right direction in to solving this issue.

I’m on a Compaq 610 laptop and 12.1 is running very well … apart from the wireless part.

Thanks in advance!

On 01/31/2012 04:16 PM, h0mp wrote:
>
> Hi, I just upgraded from 11.2 to 12.1 and am encountering problems with
> wireless connections.
> Wired is no problem.
>
> NetworkManager times out during ‘Setting network address’ giving me the
> message that it failed.
>
>
> Code:
> --------------------
> Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]
> Subsystem: Intel Corporation WiFi Link 5100 AGN [8086:1211]
> Kernel driver in use: iwlagn
>
> --------------------
>
>
>
> Code:
> --------------------
> 1425.604640] wlan0: authenticate with 00:0c:f6:46:16:74 (try 1)
> 1425.606578] wlan0: authenticated
> 1425.607696] wlan0: associate with 00:0c:f6:46:16:74 (try 1)
> 1425.613424] wlan0: RX ReassocResp from 00:0c:f6:46:16:74 (capab=0x831 status=0 aid=2)
> 1425.613428] wlan0: associated
> 1462.979360] martian source 192.168.0.255 from 192.168.0.101, on dev wlan0
> 1462.979369] ll header: ff:ff:ff:ff:ff:ff:00:1f:e2:52:b4:87:08:00
> 1471.214665] wlan0: deauthenticating from 00:0c:f6:46:16:74 by local choice (reason=3)
>
> --------------------
>
>
> I have tried several things including:
> - disabled firewall
> - disabled IPv6
> - removed files in /etc/NetworkManager/system-connections
>
> I’m basically stuck now and hope someone can point me in the right
> direction in to solving this issue.
>
> I’m on a Compaq 610 laptop and 12.1 is running very well … apart from
> the wireless part.

Your symptom is usually the result of a faulty encryption “secret”, but in your
case, that martian source is killing the networking. Is your network
192.168.0.X? Is your IP 192.168.0.101, or is that someone else?

lwfinger, thanks for your reply.

Actually, I don’t know who 192.168.0.110 is.

Starting Nmap 5.61TEST2 ( http://nmap.org ) at 2012-02-01 07:30 CET
Nmap scan report for sitecomwl312.sitecomwl312 (192.168.0.1)
Host is up (0.00089s latency).
Nmap scan report for 192.168.0.107
Host is up (0.032s latency).
Nmap scan report for 192.168.0.109
Host is up (0.00045s latency).
Nmap scan report for 192.168.0.111
Host is up (0.00035s latency).
Nmap done: 256 IP addresses (4 hosts up) scanned in 2.61 seconds

I did have my wife’s Windows PC on the network though.

Anyway, 192.168.0.111 is eth0 and 192.168.0.109 is wlan0.
That’s right, it’s connected. Don’t ask me how but after booting just now, I saw 1 failed attempt and didn’t notice it again while writing this reply and found out wlan0 is actually up and running.

Now, this is fine with me of course but I don’t know why it didn’t work all day yesterday… I was at it for 5 hours straight.

So, problem solved.
How to solve it? I don’t know :frowning:

I wonder if this is related
http://forums.opensuse.org/english/get-help-here/wireless/449584-dell-latitude-e6500-cannot-turn-intel-5100-wifi-card.html#post2250628

Unfortunately, the happy times were short lived.
This morning the wireless connection did work but the connection was very, very slow.
By now wireless isn’t working again.

I tried the fix pointed out by caf4926 but didn’t make any difference.