Opensuse 12.1 starting in Fallback mode and not in Gnome3

Hi Guys,

I yesterday installed opensuse 12.1 but it is not starting in gnome 3 instead it opens in Fallback mode.

Is there a configuration that solves this problem.
My system configuration is intel core2Duo, 1 GB ram, intel 956 GMA graphics.

May be my system is incompatible with gnome 3 of opensuse but I was having the same problem in Gnome 3(Fedora 16)
but solved it by just changing in the /etc/X11/xorg.conf the word “vesa” to “intel”.
There is no xorg.conf in opensuse 12.1 and no setting for vesa or intel.

It also sucks because in fallback mode ,the display is very dull and there is no crispness in the display.

Please Help…

On Wed, 07 Mar 2012 02:36:03 +0000, gauravsinghfzd wrote:

> Hi Guys,
>
> I yesterday installed opensuse 12.1 but it is not starting in gnome 3
> instead it opens in Fallback mode.
>
> Is there a configuration that solves this problem.
> My system configuration is intel core2Duo, 1 GB ram, intel 956 GMA
> graphics.
>
> May be my system is incompatible with gnome 3 of opensuse but I was
> having the same problem in Gnome 3(Fedora 16)
> but solved it by just changing in the /etc/X11/xorg.conf the word “vesa”
> to “intel”.
> There is no xorg.conf in opensuse 12.1 and no setting for vesa or intel.
>
> It also sucks because in fallback mode ,the display is very dull and
> there is no crispness in the display.
>
> Please Help…

Do you have the xorg-x11-driver-vide-intel-legacy package installed?

It may be that you just don’t have the driver installed that you need.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Thanks Jim for this quick reply. Yes, the package xorg-x11-driver-video-intel-legacy is installed during the installation of opensuse in my system.

I got one step forward. I managed to improve the display quality of Opensuse.
I read somewhere that I have to change some entries in

/boot/grub/menu.lst

(that is to remove the “nomodset” option, in my case it was only present for failsafe menu and not for the default menu).

I also copied /etc/X11/xorg.conf.install as /etc/X11/xorg.conf and changed all the entries related to “vesa” driver.

The consequence of these steps is that:

  1. Display is now fullscreen and has become crispy and bright as I wanted.
  2. I can no longer use the default kernel because after few minutes the user account automatically logs out and does not logs in again using GUI.

I can use my System with fullscreen display only using failsafe kernel mode but still cannot use Gnome3.

Any Ideas…

maybe you should show us your /etc/X11/xorg.conf.

Please paste it between data tags. When entering your post press go advanced button to show all the possible tags.

vesa is the incorrect driver for an Intel video chip.

Sorry I am unable to show my /etc/X11/xorg.conf because after writing my last comment I installed KDE desktop from the package Manager and this made my system unstable. So I format it and reinstalled the whole system again.

I am starting to think that the change in xorg.conf did nothing positive because it had a lot of entries for various devices.
The display improved because of the removal of option “nomodset” in the failsafe grub boot menu.
Normal boot menu makes system unstable and makes it to crash xserver or even the whole system…

Opensuse guys make there system much complex than other distros. Because I solved the same problem in fedora 15 and RHEL 6 by just changing two entries in grub’s menu.lst and xorg.conf 's nomodset.

I don’t know what to do. because making some entries in /etc/X11/xorg.conf.d/50-device.conf makes the system to load in RUNLEVEL 3 and I cannot start the GUI before undoing the changes in 50-device.conf.

What makes you think it would be different in openSUSE? Just write xorg.conf with the correct device and monitor sections. It doesn’t exist by default, but if you create one, it will be used. You can also apply the same kernel options. Once you get something working under one distro, it’s not a big deal to get it work on another one, especially if we’re talking about X and video drivers.

Don’t mark me wrong. I like opensuse than any other distro. If a version of opensuse fails me, then I install a next or a previous version.

Ok I want to know what is to be written in the xorg.conf because these are the entries that is given in /etc/X11/xorg.conf.install file:

Section “Device”
Identifier “vboxvideo”
Driver “vboxvideo”
EndSection

Section “Screen”
Identifier “vboxvideo”
Device “vboxvideo”
EndSection

Section “Device”
Identifier “vmware”
Driver “vmware”
EndSection

Section “Screen”
Identifier “vmware”
Device “vmware”
EndSection

Section “Device”
Identifier “cirrus”
Driver “cirrus”
EndSection
Section “Screen”
Identifier “cirrus”
Device “cirrus”
EndSection

Section “Device”
Identifier “fbdev”
Driver “fbdev”
EndSection
Section “Screen”
Identifier “fbdev”
Device “fbdev”
EndSection

Section “Device”
Identifier “vesa”
Driver “vesa”
EndSection

Section “Screen”
Identifier “vesa”
Device “vesa”
EndSection

Section “ServerLayout”
Identifier “Layout”
Screen “vboxvideo”
Screen “vmware”
Screen “cirrus”
Screen “fbdev”
Screen “vesa”
EndSection

In Fedora I used to change “vesa” with “intel”. but here what is to be commented and what is to be changed.

here what is to be written “intel” or “intellegacy” …

The easiest would be to copy your working xorg.conf from Fedora and use in on openSUSE. It should work . I can not help for Intel’s drivers since I don’t have Intel graphics cards, but as long as you’re using the same driver, you can use the same entries (at least the same Screen, Device and ServerLayout sections) in xorg.conf on all Linux (and even Unix) systems. Obviously sections containing absolute paths - if there are any - such as Font and module paths may differ.

I believe you can not use “nomodeset” for Intel, since it needs KMS support, but someone would have to confirm that.