opensuse 12.1 no sound whatsoever

Have a Zotac Ad-02 with AMD 350, installed os 12.1 fresh from DVD, pc connected to TV with HDMI

Read several posts regarding sound, but nothing worked


AMD/ATI Driver
edit kernel option radeon audio =1
Pulse off/on
Uninstall soundcards in Yast and re-install

output of alsa info loaded to upload=true&script=true&cardinfo= !!################################ !!ALSA In -

Any help would be appreciated, thanks in anticipation

Did you do

Dear Henk,

thanks your immy reply.

carried out one click, no change except my boot partition is almost full now. There is no sound in yast in the first place.


Dear Henk,

thanks your immy reply.

carried out one click, no change except my boot partition is almost full now. There is no sound in yast in the first place.


It is a bit outside your problem, but do you have a separate /boot partition? When yes, installing software like multimedia stuff does not go there, how can it fill that /boot partition?

Also wouldn’t it had been better when you had started this in the Multimedia subforum? That is where the sound/video/etc. experts are expected to look out for nice problems.
And when you posted here in the hardware forum because you thought this is about your sound hardware, you did not even mention one tiny piece of information about that hardware.

Dear Henk,

thanks a lot your reply.

yes, I do have a boot partition and I was surprised too, when receiving the warning during one click install, indeed this should have nothing to do with /boot

I was asking myself, whether this does belong to hardware or multimedia, but found other “sound” threats here and so chose to post here, should I change?

Thanks, rgds

Apologies, as I appear to be coming in late, … I only saw your post this AM, and its my wife’s birthday, so I was a bit occupied.

I have some time now, and I think the answer to this problem was given in the first post in the diagnostic script output you posted ?

I looks to me that you have sound set to come out of the HDMI device, which is why you don’t hear it.

I note this:

!!PCI Soundcards installed in the system
00:01.1 Audio device: ATI Technologies Inc Wrestler HDMI Audio [Radeon HD 6250/6310]
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)

followed by this:

!!Aplay/Arecord output
**** List of PLAYBACK Hardware Devices ****
**card 0**: Generic [HD-Audio Generic], **device 3**: **HDMI **0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
**card 1:** SB [HDA ATI SB], **device 0**: ALC892 **Analog** [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
**card 1:** SB [HDA ATI SB], **device 1**: ALC892 **Digital** [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

from that it is pretty clear to me that the HDMI sound device is being setup as the 1st (default) sound device, which by DEFAULT is ‘card 0’. Hence removing pulse audio won’t solve anything (but everyone tends to blame pulse audio for the slightest problem in audio - which while once quite plausible, is no longer IMHO fair).

Further, from the aplay I can see hw:0,3 is HDMI device, hw:1,0 is analog sound, and hw:1,1 is digital sound.

If I assume that one is trying to get sound out of the analog device hw:1,0, then this could yield sound (as a test):

aplay -D hw:1,0 -c2 test.wav

where test.wav is a .wav file that you need to make up and put on your PC. I am assuming 2 channel sound here.

or this

speaker-test -D hw:1,0 -c2 -l1 -twav

where again I am assuming 2 channel sound.

Now if those work (and even if they don’t work) I recommend you install the application ‘pulse audio volume control’ (pavucontrol) and then run pavucontrol the 1st time you run any multimedia application and tune it for your audio. I have a blog entry here which goes through this: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

Good luck !

On a subject DIFFERENT from your sound, I note this:

   13.864361] [drm] Radeon display connector DP-1: No monitor connected or invalid EDID
   13.971168] [drm] Radeon display connector HDMI-A-1: Found valid EDID
   13.981291] [drm] Radeon display connector VGA-1: No monitor connected or invalid EDID

which suggests you may also have graphics problems ?

If so, you may wish to start a separate thread on that, if you have not done so already.

Reading again, are you trying to sound out of the HDMI ? If so, then my above post is inaccurate.

Does this give HDMI sound :

aplay -D hw:0,3 -c2 test.wav

where test.wav is a .wav file that you need to make up and put on your PC. I am assuming 2 channel sound here.

or this

speaker-test -D hw:0,3 -c2 -l1 -twav

give HDMI sound ?

Further to this, if you are trying to get HDMI sound, and if the above command (trying to push sound through HDMI’s hw:0,3 ) doesn’t work, can you provide the output of:

cat /proc/asound/pcm

I ask that as I note an arch linux user with a PC with ALC892 hardware (similar to yours) struggled a bit with HDMI sound and discovered hw:0,7 and hw:0,8 in addition to hw:0,3 (even though it was not picked up by ’ aplay -l ’ command). In which case tests I gave for HDMI could also be using ‘hw:0,7’ or ‘hw:0,8’ in place of ‘hw:0,3’.

Dear oldcpu,

thanks a lot your reply that’s quite a lot for me to try, appear to live in a different time zone, but thanks a lot for your fantastic effortd at first.

Have not done anything with Linux for some 7 years, so my knowledge, if there was any, is pretty outdated and I am struggling heavily with many issues on suse 12.1

  1. Yes I am using HDMI, which is connected to a TV display with speakers built in
  2. I have pavucontrol installed (learned from one of the posts) did not work and or help

Your other recommendations I will have to understand first and carry out and will revert

Thanks a lot for time being, will revert asap

No worries … it takes time to get accustomed to GNU/Linux. Things have changed A LOT in GNU/Linux over the past 7 years.

One thing I forgot to mention, since you are using HDMI from your radeon hardware, you need to know somethings wrt HDMI audio on radeon hardware with the radeon graphic driver. What graphic driver are you using ? … yes … I know … a sTRangE question to ask for sound, but it could be important …

For HDMI with radeon graphic driver, the audio module is disabled by default in kernel >=3.0. Add to the end of your “kernel” line in /boot/grub/menu.lst to enable it. (and to test just boot with the grub boot code “” ).

If you are using the proprietary fglrx graphic driver than that won’t be the case.

Dear old cpu,

thanks a lot

I tried this option at the end of the boot kernel parameters, which did not work, see my initial post, then I installed the drivers from AMD/ATI giving me this Catalyst stuff, which caused problems to the display output etc., but did not provide sound, uninstalled from repo therefore. I’ am afraid that in the end it is something simple. The Hardware is this AMD E350 Zacate stuff, where, as I understood, the graphics (and here the sound when using HDMI) are part of the cpu.

I am presently quite at loss, actually I cannot connect the repo’s for online updating, although I have no problem to connect with the browser, it is a little too much at once. Plus all of a sudden tight vnc does not work (disconnecting after login) and I am burried in cables and parts and quite puzzled, but this is off the thread (record).

will try to follow your hints and revert asap

Hmmm … IMHO its best when troubleshooting never to try reconfiguring, without (1) restoring any previous reconfiguration and (2) asking for help each configuration step of the way.

Good luck.

For clarification, so that we don’t go barking up the wrong tree, can you confirm that the above diagnostic script output was generated when using the ‘radeon’ open source graphic driver with the boot code ‘’ applied ? NOTE THE SYNTAX ! That needs to be correct (it was wrong in your post which means it could NOT possibly have worked if you typed it in a representative manner in your post). If you can’t then you need to be clear as to what options are applied and what driver in use, you need to type the boot code EXACTLY and be clear what you applied when running that script. Else we just end up chasing our tail which is very counter productive.

dear old cpu,

honestly, I do not remember, whether the script ran with the radeon option or not. the syntax I used was correct, and it showed in the boot sequence on restart, so it should have been working. in my post I did abbreviate all the things I tried, believe me that were quite a lot and I do not recall them all, I would not have posted here, before trying the recommendations in other posts. I have too many issues here at the moment and if this would not be a xmas present for my son, who is meanwhile really disappointed, I would not bother with sounds. I am considering to make a 11.4 install, which appears to not having these issues.

Anyway thanks a lot, will post here once I have a solution


Hi folks,

Sorry that I jump into this conversation, I don’t want to mess, but could I ask something from experts?

Should the “alsasound” service running to get sound? Or this service is not needed to be run?

My reason to ask this… I’m quiet sure one issue that in OpenSUSE 12.1 the alsasound service doesn’t seem to start.
My related topic was here:

Since that, I have installed another OpenSUSE 12.1 installation in VirtualBox, and the alsasound service cannot start in that either.
Plus, I have yet another OpenSUSE 12.1 installation in a real hardware, it has full installation, not minimal as two others. I checked the alsasound on each machine, on every installation the alsasound service is not able to start.

More exactly:

tools2:~ # chkconfig --list alsasound

Note: This output shows SysV services only and does not include native
systemd services. SysV configuration data might be overridden by native
systemd configuration.

alsasound                 0:off  1:off  2:on   3:on   4:off  5:on   6:off
tools2:~ #

tools2:~ # service alsasound status
redirecting to systemctl
alsa-restore.service - Restore Sound Card State
          Loaded: loaded (/lib/systemd/system/alsa-restore.service; static)
          Active: inactive (dead) since Sat, 10 Dec 2011 19:10:08 +0100; 1 months and 13 days ago
         Process: 1160 ExecStart=/usr/sbin/alsactl restore (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/alsa-restore.service
tools2:~ # 
tools2:~ # service alsasound start
redirecting to systemctl
tools2:~ #
tools2:~ # service alsasound status
redirecting to systemctl
alsa-restore.service - Restore Sound Card State
          Loaded: loaded (/lib/systemd/system/alsa-restore.service; static)
          Active: inactive (dead) since Mon, 23 Jan 2012 10:36:48 +0100; 1s ago
         Process: 17470 ExecStart=/usr/sbin/alsactl restore (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/alsa-restore.service
tools2:~ #

So it cannot start.

One thing I tracked down is this:

tools2:~ # chkconfig alsasound off
insserv: Note: sysvinit service alsasound is shadowed by systemd alsasound.service,
**Forwarding request to '/bin/systemctl --root / disable alsasound.service'.
Operation failed: No such file or directory**
insserv: Forward service request to systemctl returned error status : 256
tools2:~ #

If I check the systemctl syntax (command “systemctl --help”), it says this:

     **--root=PATH**      Enable unit files in the specified root directory

For me it seems that command “/bin/systemctl --root / disable alsasound.service” is incorrect, because the equation sign is missing after “–root” string, plus it seaches the service in “/” which seems incorrect. I might be wrong as I’m no expert, but for me it seems.

Searching on net, I found some places mentioning similar issue, and it was the “insserv” command faulty.

Now the main question here, whether all this causes anything in the sound, or not? Because if the alsasound service is not needed to be run to hear sound, then all of I wrote, doesn’t matter.

What do you think?

Hi oldcpu,

For help, could you please post here the following printouts from your machine?

chkconfig --list alsasound
service alsasound status
service alsasound restart
service alsasound status

If it doesn’t run on your OpenSUSE 12.1 machine, then we will know it’s not needed.
But if alsasound service is running on your machine, then we have the issue.

Thanks a lot!

Ok, I checked a SLES10 SP2 machine.
On that server, the alsasound service is running:

tools1:~ # service alsasound status
**ALSA sound driver loaded.                                             running**
tools1:~ # cat /etc/SuSE-release
SUSE Linux Enterprise Server 10 (x86_64)
tools1:~ #

So I guess it should run.

Output of 1st 2 commands:

corei7:/home/oldcpu # chkconfig --list alsasound
alsasound                 0:off  1:off  2:on   3:on   4:off  5:on   6:off
corei7:/home/oldcpu # service alsasound status
ALSA sound driver loaded.                                                      running