openSUSE 12.1 - no sound on Panasonic Toughbook CF52

Hi all,

Just downloaded and installed on Panasonic Toughbook CF-52, no sound.
Have same problem on Mint 12RC, Fedora 16 and Ubuntu 11.10 too.

Card is an HDA Intel (AD1884).
I can get sound from headphones but speakers are no go.
In sound settings I only have 1 output connector ‘headphones’?!

I’ve amended the alsa-base.conf file and added “options snd-hda-intel index=0 model=auto/panasonic/laptop/mobile” each in turn to test, all to no avail!
Alsamixer shows no mutes in force either so I’m of the opinion that this just isn’t supported across these 3 distro’s.
Pity as Mint is my preferred choice and had high hopes that it would install and work but never mind.

Just wondered if anyone else out there knows the ‘fix’, has a CF-52 with same problem and resolved or can shed any light on what’s going on?


#aplay -l reports:-

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 0: AD198x Digital [AD198x Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

Up to now I have tried the following from the hardware list:

options snd-hda-intel model=xxxxxxx

desktop
laptop
mobile
thinkpad
touchsmart
basic
hp
toshiba
dell_desktop
6stack
3stack
laptop-eapd
laptop-automute
ultra
samsung
samsung-p50
6stack-dig
3stack-dig
auto


All models relating to AD198x tested:

options snd-hda-intel model=xxxxxxx

desktop
laptop
mobile
thinkpad
touchsmart
basic
hp
toshiba
dell_desktop
6stack
3stack
laptop-eapd
laptop-automute
ultra
samsung
samsung-p50
6stack-dig
3stack-dig
auto

All work via single analogue connector (headphone) output.
No output via speakers at all.
Not sure if adding index=0, into the “options snd-hda-intel index=0 model=xxxxxx” will help, bit loathed to spend another hour/half gedit alsa-base.conf and sudo reboot’ing to be honest!!

So, hardware is supported, but for some reason the speaker output cannot be generated.
Anyone, anyone, Bueller, Bueller…

:\

In openSUSE we use 50-sound.conf and not alsa-base.conf. Everything you attempted in alsa-base.conf on openSUSE will be ignored.

There are only 7 model options for an AD1988 in alsa as listed in HD-Audio-Models.txt file. You can search google to get that files content, but options are: 6stack, 6stack-dig, 3stack, 3stack-dig, laptop, laptp-dig, auto. Be certain to apply one at a time to correct file with correct syntax.

If all else fails write a bug report on openSUSE which will get SuSE-GmbH sound packager attention (who is also an alsa developer) and he will help you and fix problem for ALL GNU/Linux distros. But you will need to test/support him in the fixes he creates.

I am out of country sending this from my Tablet in my Hotel room (on business)

Many thanks for your reply, good to know re: the 50-sound.conf file!
My problem is this, the #aplay -l states the following:-

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 0: AD198x Digital [AD198x Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

Yet in alsamixer it states that my sound device is an AD1884??
In HD-Audio-Models.txt AD1884 is marked as “N/A”, doesn’t bode well for me then does it??

I’ve chopped and changed the 50-sound file with all AD198x options but guess this is why I’ve had no success.

:frowning:

Yes there are no options for the AD1984.

Be certain your speakers (if external) are plugged in correctly.

There is guidance for raising a bug report here: openSUSE:Submitting bug reports - openSUSE You can use your openSUSE forum username and password when logging on to bugzilla. Attach to your bug report the file /tmp/alsa-info.txt that you get from running the command:


/usr/sbin/alsa-info.sh --no-upload

Be certain to monitor every day or so the bug report, looking for a ‘need info’ flag. When you see that, provide the information and clear the ‘need info’ flag.

I’ll do that this weekend, speakers are built-in.
Thanks for taking the time to post and offer advice.
Much appreciated!

:slight_smile: