openSUSE 12.1 No Default Route from DHCP

Just installed 12.1 on my LapTop here at home. Been running openSUSE for years. After install switched network to IFUP, configured WiFi. Got IP and DNS, but not Default Route. Added route on CMD line and did online update. Reboot system after update, still no Default Route.

Dave W

On 2011-12-17 16:56, dwestf wrote:
> Just installed 12.1 on my LapTop here at home. Been running openSUSE
> for years. After install switched network to IFUP, configured WiFi.
> Got IP and DNS, but not Default Route. Added route on CMD line and did
> online update. Reboot system after update, still no Default Route.
>

Try booting with systemV. F5 at boot.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

You need to reconfigure your ethernet device. And yes, I realize you are using WiFi.

In the Yast → Network Devices → Network Settings
edit the settings for the ethernet device. Go to the “General tab”. Check the “Activate-device” setting. It is possibly set to activate on bootup. Change that to “cable connect”.

What is probably happening, is that your ethernet card is being given priority, and would get a default route. Your WiFi card is treated as secondary. When you switch it to “cable connect” then, assuming that there is no ethernet cable, the WiFi card will be given priority and get the default route.

At least that’s what my testing indicates.

Thank you for the replies.

nrickert,
eth0 was already disabled making the wireless card the only network interface.

Carlos,
I booted the lapto with systemV and received the route from dhcp. I then rebooted to the original mode and still received the route info from DHCP. Not sure if systemV fixed it our if the system decided to behave.

Dave W.

Thanks, nrickert](https://forums.opensuse.org/members/nrickert.html), that worked!
This is still an issue in 12.3

There is already bug filed: https://bugzilla.novell.com/show_bug.cgi?id=802970