openSUSE 12.1 Milestone 3 available for download

Yes it’s true. openSUSE 12.1 Milestone 3 is available for download right now!

Check the download page for more information.



Ok. I brought it down and created a disc at approximately 8:10PM Phoenix, AZ time. After the installation the initial re-boot did NOT succeed. It was required to use the Failsafe boot. It then completed the install. This reply is from the booted Milestone 3 … in Failsafe mode. I’ll try some re-boots and see if it will succeed… normally now that it is fully installed.

Allllrighty now. I tried some restarts and found that it was necessary to put in nomodeset or I would NOT get a desktop. I have an:
HP m7480n with an nVidia 7300LE graphics card.
Haven’t loaded the nVidia drivers … yet, but they didn’t work in M2. I’ll try them here in M3 and see if they fix the problem. Till then
Have Fun,

Is your 7300LE supported by the Nouveau FOSS Nvidia driver? Even if it isn’t, then the VESA driver ought to be set up after install.
Your problem ought to be reported in bugzilla. Did you try rebooting to level 3 rather than graphical, to see if it was just X11 that failed to start with KMS?

I can think of a couple of speculative possibilities. (1) One is UDEV and/or modesetting does not properly identify your card and hence is giving wrong information to X and/or nouveau driver. (2) Another is nouveau driver simply does not work for your card.

By using the boot code ‘nomodeset’ you are instructing openSUSE to use the older ‘nv’ driver.

You could try editing your /etc/X11/xorg.conf.d/50-device.conf file, and below the line with #Driver “radeon” (which is commented out), enter/save the line:

Driver "nouveau"

and then restart and see what happens then. If same thing, then the problem is nouveau driver. If it works, then the problem is elsewhere.

Thanks for the replies. Yes I do believe the 7300 is listed as ok in the Nouveau FOSS cause it was in 11.4 and I don’t believe that it was dropped… yet. Anyway I tried the Driver “nouveau” in the 50-device.conf file and it didn’t help.

Now then, I have been trying the various nVidia Drivers with no success. I have been installing them the “Hard Way”. After receiving the above responses I had to remove my “changes” for the nVidia Drivers. Well, I found something strange. In the /etc/sysconfig/kernel file we are to change
NO_KMS_IN_INITRD=“no” to NO_KMS_IN_INITRD=“yes”. This is the item and value found in version 11.4. However, in version 12.1 I find the following:

It appears that the indicator is changed. I do believe that this is what caused my nVidia failures. Someone reversed the logic. I will experiment and let you know. I think it should be changed to KMS_IN_INITRD=“no” in order to use the nVidia Drivers. The reason I didn’t see this earlier is cause I was using a script and it did not show the before or after results [shame on me:shame:]

I’ve had to use “nomodeset” to boot KDE Live CD!
NVIDIA GeForce 315

Can you add your findings and check the bug I created -
I have the problem, I could not get Networking running with the Live CD, so I’m posting from Windows (and it’s not my PC either)

The binary Nvidia drivers in repo won’t directly support 3.0 kernel or KMS; they can probably be got to work with compilation of the Nvidia interface module.
Nouveau driver ought provide FOSS 3D & KMS on install, so something appears wrong with that, perhaps there’s a slip due to change of variable name & removal of the negativity.

Great to read these posts! As I had d/l the m3 kde live cd this morning and couldn’t get it to boot or install. Had thought that it was just me or a bad cd burn.

Cheated in the end and used a live kde cd from last week and pointed it to an image of the m3 dvd. All seems to be working fine, including the packman multimedia and no problems with the new kernel rc7 so far.

Allllrighty now. What was tried:

  1. We need kernel sources and syms - obtained/installed them.
  2. Make sure they are good and ALL dependencies created.
    …a) make cloneconfig
    …b) make prepare
    …c) make modules <<------- out of frustration!!

So we have ALL the system files. Now we get the NVIDIA files. The “latest” stable release is: … and the latest Beta is …
Both were tried but NOT successfully. They are supposed to work with the 3.0 kernel -but- I had a problem in the installation of both. It would go all the way through, say it was successfully created and wait for you to hit the OK. Then all kinds of text messages flashed by at supersonic speed and then we get a SigAbort. And neither work. I did a “modprobe nvidia” anyway but they did not work. NO graphics. Any modules BEFORE these will NOT work with the 3.0 kernel.

I have tried various ways to catch those messages -but- I have not been successful. Guess I am not as smart as I thought I was. If any of you Guru’s out there can supply some hints as to how to do it, it would be great. I tried the pipe and tee but this installation is somewhat interactive and it would not read my input. So I had to abort and loose all the info I saved.!.! Yep, I’m a little frustrated.

As for the **nouveau, **which led to this in the first place. In openSuSE version 11.4, it worked fine. In fact I was impressed in the beginning that it worked so well with my system… which has an nVidia 7300LE. However, it will NOT work with openSuSE 12.1. I have to use the FailSafe boot-up in order to get a graphical desktop.

NO. The Driver “nouveau” in the /etc/X11/xorg.conf.d/50-device.conf file did NOT work. In fact it made things worse. I could not get a graphical boot-up with it.

I am right now writing this while booted up in 12.1 — FailSafe mode. That is the only way it works … for me.

Oh almost forgot… with the nVidia drivers, I could get a graphical boot-up and get to my SignOn screen. (don’t do auto signon) After entering my Username and Password it would show the Lizard and the progress bar below it. The bar got about 4/5ths of the way across and stop. The system was hung at that point. However… it evidently brought the Desktop up in the background cause as I sat there dumbfounded and thinking … I got the signon tune for the Desktop!! The way out at this point was to use Ctl-Alt-F1 and get a terminal with which to do a proper controlled log-out/shutdown. Sometimes it requires a Power Off reset!!
Other times all I got was a textual bootup. Sorry -but- I don’t totally remember why the difference.

Don’t forget to write a bug report on nouveau. Guidance is here: openSUSE:Submitting bug reports - openSUSE

Don’t write it on proprietary nVidia driver as that will be rejected.

Is there any msttfonts or rar compression for 12.1?

what if you just use the boot code ‘x11failsafe’ instead of all of the codes in Failsafe?

What do you lose by using X11failsafe rather than not using it?

Who is that question to ?

My experience is ‘x11failsafe’ boot code will typically force the loading of the ‘fbdev’ driver (its one of the boot codes in Fail Safe and also safesettings). If one does not use any boot codes (other than the default), then the PC with nVidia hardware with no proprietary driver will attempt to boot the nouveau driver. If one specifies the boot code ‘nomodeset’ the pc with attempt to boot to the ‘nv’ driver.

The question was to you. Thank you for the reply. I’ll try using ‘nomodoset’ and see how it turns out.

OK. I changed the ‘X11failsafe’ option with ‘nomodeset’ option. It still booted with the ‘fbdev’ driver. so is there actually any difference between the ‘X11failsafe’ and ‘nomodeset’ options?

Ok. I’ll try out some of these new suggestions. Especially from ‘oldcpu’ cause, I too am old.:wink: I have been away working but am now back home and will proceed. However, as most of you know… it does take time to put in and take out all these various changes. I glanced at the bug reports and there are many from the 11.4 days … and some are still open. I will examine them closer and see if I can jump on one of them rather than open yet another for our poor developers.
In the meantime … have fun,

Yes there are differences. I am by no means an expert … rather I’m just someone who does this often so gradually a small amount of knowledge has sunk into my thick older skull. :slight_smile: … The ‘nomodeset’ applies a ‘no modesetting’ setup so as to disable kernel modesetting during the boot. My understanding is kernel modesetting is a relatively new kernel feature that allows the kernel to assist in graphic device identification, configuration and resolution changes. BUT as you have discovered it does not always work and hence needs to be disabled for some cases.

Now for openSUSE, the SuSE-GmbH packagers also setup openSUSE 11.3 and 11.4 (and 12.1) such that if the ‘nomodeset’ boot code is applied, then with :

  • AMD Radeon graphic hardware then openSUSE would fall back to use the ‘radeonhd’ driver instead of the ‘radeon’ driver
  • nVidia graphic hardware then openSUSE would fall back to use the ‘nv’ driver instead of the ‘nouveau’ driver
  • Intel graphic hardware then openSUSE would fall back to use the ‘fbdev’ driver instead of the ‘intel’ driver

This is documented in the openSUSE-11.3 and 11.4 release notes.

x11failsafe (note thats a lower case ‘x’ ) causes the graphics to use the ‘fbdev’ driver. I don’t know what (if any) else it does.