OpenSuse 12.1, KDE hang 10~15 seconds after login

This did not happen with RC1, but with 12.1 final, about 1/2 the time after login, the KDE panel is unresponsive for quite a while. This is on a 3.7GHz quad-core system with 8GB of ram and SSD. It was lightning fast under the RC1. A random 15 second delay on log-in is frustratingly maddening!!! Top shows no culprit from text console. Occasionally there is a “ConsoleKit” error message, and once with a couple KDE init crashes. None of this happened on RC1, so I’m not sure what went wrong. Already disabled apper and nepomuk, to no avail. Not seeing anything in log files, or I’m not looking at the right logs.

+1 here.
I made some tests this week-end with KDE and had the same problem.
My observation was that KDE “really” began working when the login sound started to play. Maybe an indication?

Well, I don’t have anything plugged into the sound output, so I don’t hear anything, not sure if that’s the same here or not.

But now, I disabled Desktop Effects (shot in the dark debugging), and it’s totally soft hung at the 5-icon fade-in login splash screen. Oh wait, the desktop just appeared after about 5 minutes, huh.

I got this $$$ SSD drive right, and RC1 went from Grub to Desktop in 6.1 seconds lol (seriously, I timed it!). But now there is this unknown timeout with occasional crashing KDE packages. This is not going to be acceptable for a machine at work.

edit: you might be onto something with the sound thing. PulseAudio has taken over compared to RC1, and I’ve had nothing but trouble with that package in the past.

Okay, I plugged my PC into the stereo. Right, it’s hung until the login sound plays. But the question is, is the delay cause by the sound sub-system, or simply another symptom of whatever is causing the temporary hang. I tried “zypper refresh” + “zypper dup” but the issues remains.

Well, removing all pulse rpms results in not being able to log in, ha. Recovered with “zypper ve” (verify). There’s no sound now, but it hung at the splash screen again after 3-4 logins, so I don’t think sound is the root of the problem.

Cha-ching: YAST -> Hardware -> Sound -> Other -> Pulse -> uncheck Enable.

Problem gone. (I noticed the user PulseAudio process was active and left-over when re-logging in.)

I have the same issue on my box. Disabling Pulseaudio is of course an option, but what’s the solution, if want to use pulseaudio?

I don’t know, but I learned from using Mandriva distro that PulseAudio is generally the devil.

Perhaps file a bug report, and hope for the best. Though it was reported 8 months ago already:

[Bug 267766] New: Pulse audio freezes desktop for 10-15 seconds on first KDE login](

More info:
A Moment of Zen: More PulseAudio Problems

This is interesting. According to that last link, the PulseAudio wiki on KDE, indeed I saw the 2nd image on the page, which claims there is a problem with the KDE / PulseAudio setup on the installation, in the text under the image. It talks about *.desktop files which bug #267766 above also claimed to be the root of their problem. Who knows, but I don’t need a network-enabled sound daemon to hear a login chime.

Please refer to

If all is well, (a) a future update can solve the issue or (b) you can manually apply fix.

I found removing the application ‘tracker’ and all its dependencies removed this unwanted 10-15 second freeze behavior. I recommend removing that application.

PulseAudio cause problem.
Just use command in console use root : #pulseaudio --disable