Opensuse 12.1 KDE 64-bit on Macbook Pro 7.1

I am running Opensuse 12.1 KDE 64-bit on Macbook Pro 7.1. I could not fix wireless yet. The Networkmanager option for wireless if grayed out.

If I see /sbin/ifconfig it does not show anything other than eth0 and lo. wlan0 or eth1 for wireless is not listed anywhere. The output of /sbin/lspci shows the following :

02:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
Subsystem: Apple Computer Inc. Device [106b:008d]
Kernel driver in use: b43-pci-bridge

I have all boradcom drivers installed. Tried several solutions suggested in different threads but to no avail. Wireless works with mac perfectly. No hardware issue.

I appreciate if you help me resolve the issue.

Thanks in advance.

You can find the actual source code at the following location and compile your own driver. Get the 32 or 64 bit version, as you installed openSUSE and the readme file. - 802.11 Linux STA driver

For any task where you want to compile your own driver, do the following:

Open YaST / Software / Software Management - Select the View Button on the top left and pick Patterns. Now, you will see several Patterns listed and you want to select:


[X] Base Development 
[X] C/C++ Development

Ask if you have any more questions.

Thank You,

Hi jdmcdaniel3,

Thanks for your reply. I could follow all instructions given by you and those in the README.txt of broadcom site you referred to. I did not get any error during building except the fact that I can not remove ssb module. It is used by ohci_hcd. I have blacklisted it yet it loads. Please see below:

mac:~/hybrid_wl # lsmod | grep “b43|ssb|bcma|wl”
wl 2577856 0
ssb 67780 1 ohci_hcd
mmc_core 108074 1 ssb
pcmcia 70281 1 ssb

mac:~/hybrid_wl # # echo “blacklist ssb” >> /etc/modprobe.d/blacklist.conf

mac:~/hybrid_wl # rmmod ssb
ERROR: Module ssb is in use by ohci_hcd

I did not reboot the system yet. The networkmanager tab for Wireless is still grayed out. What should I do ?

Thanks in advance.

I think I would restart unless you feel you also have a booting problem. Also, why the need to remove the ssb module (Sonics Silicon Backplane driver)? Does the readme request that? In addition, if you have a problem with a hardware reboot, I do have a bash script called fastboot. You should read about it here:

FastBoot for Grub Legacy Menu using Kexec - Version 1.32 - Blogs - openSUSE Forums

And for looking at loaded modules, why not try this one?

S.K.I.M. - SuSE Kernel Installed Modules - A lsmod replacement- Creates Alphabetized Module Listing - Blogs - openSUSE Forums

Thank You,


yes, I rebooted the system. Still it is all the same (Wireless tab in Networkmanager is gray; /sbin/ifconfig does not list wlan0).

Yes, it was suggested to blacklist and remove ssb module in the README.txt. Also in many other forums which I had read before.

Yes, I have a small issue with reboot or shutdown as well. The screen flickers (with green shades) quite fast before shutting down. I had this issue from opensuse 11.4 as well. I had reported many times in different places but I did not get any fix any where. I have now ignored it altogether.

I will read you links and follow them.

Thanks in advance.

You may need to load kernel firmware. I some times find it is best to go into YaST / Network Devices / Network Settings / Switch back to using Traditional Method with ifup and then doing a manual configuration of the wireless setup. Often, it will even suggest when you need to install another file. I write it down as your wired connection might stop working until you switch back. Its kind of a pain and a catch 22 when you need added files, which you must download with wired to get your wireless working again. And switching the Network settings around almost always needs a few restarts which is why fastboot might be good to have. It reloads the kernel without the need to actually reboot the PC. Anyway your goal is to have Network Manager loading which allows automatic switching between wired and wireless connections.

Thank You,

Hi JD!!

Thanks for that sleek script on fast reboot. I installed it and tested it. It saves a lot of time, especially I have a MAC BIOS which first looks for Mac OS on my PC which I do not have.

Coming back to wireless network issue; I have changed it from NM to Yast (I had tried all this several times before as well) and set up things manually. It did not ask for any new files and did not show up any new errors. The result is the same; /sbin/ifconfig does list wlan0 and if I remove the LAN cable, internet does not work.

Will you please let me know what is the reason why my /sbin/ifconfig does not list wlan0 ? I have tried “/sbin/ifup wlan0” it replied saying “Interface wlan0 is not available”.

Coming to the firmware issue, I remember installing it months ago. Now, I have forgotten how did I do it ? Can you please tell me how to know whether my wireless needs firmware (Yast did not show any)?

Thanks in advance.


Yes, I have the following firmwares installed: b43-firmware, b43-fwcutter, b43legacy-firmware

I have this same wireless setup on my work laptop which is working. I will get it out tonight and see how it is configured and post that info tonight.

Thank You,