OpenSUSE-12.1 installation nvidia workarounds

32-bit OpenSUSE-12.1 graphic install failed and required a simple workaround (with a legacy nVidia FX-5200 graphic card). This 12.1 install, was on my 10+ year old sandbox PC (whose first SuSE was SuSE-Pro-7.3 those 10 years ago). This PC, upgraded over the years, has 2GB RAM and an AGP FX5200 nVidia graphic card, which the nouveau driver does not particularly like.

1/2 way through the openSUSE-12.1 installation, immediately after all software and the boot manager was installed, during the first ‘kexec’ intercepted reboot, I encountered this menu, which was an indication of problems to come:](

Still, for me that was a refreshing openSUSE improvement, with a well coded fall back to an ncurses/text install when the nouveau driver part of the install failed !

Since that was an indication of trouble, I paid particular to the ncurses rendition of the openSUSE-12.1 release notes, which had this section:](
[click on above image for larger view]

In particular, I noted these words warning me that a boot code ‘nomodeset’ may ultimately be required:](
[click on above image for larger view]

and when the install was completed, I was left at this prompt !](

I logged in as user ‘oldcpu’ and then once logged in, typed ‘su’ to switch to root permissions, and typed

shutdown -r now

to reboot.

Then in the grub boot menu for openSUSE-12.1, I entered the boot code ‘nomodeset’. That booted me to X window successfully and I had the LXDE desktop that I like very much on this PC.

It was then a simple matter after that to install the propriertary (legacy) nVidia driver for the GeForce FX5200 graphics card and obtain decent performance with the LXDE desktop.

I was impressed with the improvement in the installation routine, with all the information presented (for the patient reader) as to what was needed to successful install openSUSE on this PC.

Here is the information from the application ‘inxi’ on this PC (with the proprietary graphic driver in place) :

oldcpu@stonehenge01:~> inxi -F
System:    Host: stonehenge01 Kernel: 3.1.0-1.2-default i686 (32 bit) 
           Desktop LXDE (Openbox 3.5.0) Distro: openSUSE 12.1 (i586) VERSION = 12.1 CODENAME = Asparagus
Machine:   Mobo: MSI model: MS-6380E version: 1.0 Bios: American Megatrends version: 07.00T date: 04/02/01
CPU:       Single core AMD Athlon (-UP-) cache: 256 KB flags: (sse) clocked at 1150.045 MHz 
Graphics:  Card: nVidia NV34 [GeForce FX 5200] 
           X.Org: 1.10.4 drivers: nvidia (unloaded: fbdev,nv,vesa,nouveau) Resolution: 1600x1200@50.0hz 
           GLX Renderer: GeForce FX 5200/AGP/SSE/3DNOW! GLX Version: 2.1.2 NVIDIA 173.14.31
Audio:     Card-1: Ensoniq 5880B [AudioPCI] driver: snd_ens1371 Sound: ALSA ver: 1.0.24
           Card-2: VIA VT8233/A/8235/8237 AC97 Audio Controller driver: snd_via82xx
Network:   Card-1: Atheros AR5212/AR5213 Multiprotocol MAC/baseband processor driver: ath5k 
           IF: wlan0 state: up speed: N/A duplex: N/A mac: 00:11:95:91:76:f5
           Card-2: Realtek RTL-8139/8139C/8139C+ driver: 8139too 
           IF: eth0 state: unknown speed: 100 Mbps duplex: full mac: 00:50:fc:5f:ba:6d
Drives:    HDD Total Size: 484.0GB (18.6% used) 1: /dev/sda ST3320620A 320.1GB 
           2: /dev/sdb Maxtor_6Y160P0 163.9GB 
Partition: ID: / size: 25G used: 4.1G (18%) fs: rootfs ID: / size: 25G used: 4.1G (18%) fs: ext4 
           ID: /home size: 50G used: 330M (1%) fs: ext4 ID: swap-1 size: 1.04GB used: 0.00GB (0%) fs: swap 
           ID: swap-2 size: 2.85GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 41.0C mobo: 46.5C 
           Fan Speeds (in rpm): cpu: 4326 fan-2: 0 
Info:      Processes: 106 Uptime: 0:01 Memory: 148.2/2013.6MB Client: Shell inxi: 1.7.24 

64-bit OpenSUSE-12.1 graphic install failed in the middle, but a simple reboot cured (with a nVidia GeForce GTX260 graphic card). This 12.1 install, was on my 2+ year old main PC, which has a Core-i7 920 cpu and 6GB of RAM. The nouveau driver typically works well with this PC, so the glitch in the middle of the install was a surprise…

1/2 way through the openSUSE-12.1 installation, immediately after all software and the boot manager was installed the PC reboots (with this nominal and typical dialog box):](

and then I saw this text …](

the install stopped with this display:](

I waited and waited and waited for minutes, but nothing happened … it just sat there. A <CTR><ALT><F2>, <CTRL><ALT><F3> had no effect, with the same multicolour corrupted display. But a <CTRL><ALT><DELETE> obtained the PC’s attention, as the PC rebooted properly, with the 12.1 grub menu coming up, followed by a boot and a continuation of the installation with this menu:](

I continued the installation, and it was flawless after that. OpenSUSE-12.1 eventually came up to the nouveau driver and everything worked fine from there with proper performance with nouveau. Later I replaced the nouveau with the proprietary nVidia driver, which also works well…

I think it is very well done, to have the openSUSE installation script setup such that if after the software/boot-manager setup that even when the install script has some difficulty wrt the reboot, that a software restart will still enable the install to continue.

Nicely done to see this recover and install so well.

Thus far 12.1 has been running well.

Here is the ouput of ‘inxi -F’ for this computer:

oldcpu@corei7-920:~> inxi -F
System:    Host: corei7-920 Kernel: 3.1.0-1.2-desktop x86_64 (64 bit) 
           Desktop KDE 4.7.2 Distro: openSUSE 12.1 (x86_64) VERSION = 12.1 CODENAME = Asparagus
Machine:   Mobo: ASUSTeK model: P6T DELUXE V2 version: Rev 1.xx Bios: American Megatrends version: 1108 date: 09/21/2010
CPU:       Quad core Intel Core i7 CPU 920 (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) 
           Clock Speeds: 1: 1600.00 MHz 2: 1600.00 MHz 3: 1600.00 MHz 4: 1600.00 MHz 5: 1600.00 MHz 6: 1600.00 MHz 7: 2668.00 MHz 8: 1600.00 MHz
Graphics:  Card: nVidia GT200 [GeForce GTX 260] 
           X.Org: 1.10.4 drivers: nvidia (unloaded: fbdev,nv,vesa,nouveau) Resolution: 1920x1200@50.0hz 
           GLX Renderer: GeForce GTX 260/PCI/SSE2 GLX Version: 3.3.0 NVIDIA 285.05.09
Audio:     Card-1: Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel Sound: ALSA ver: 1.0.24
           Card-2: Logitech HD Webcam C910 driver: USB Audio
Network:   Card-1: Marvell 88E8056 PCI-E Gigabit Ethernet Controller driver: sky2 
           IF: eth1 state: down speed: N/A duplex: N/A mac: 00:24:8c:7e:ee:38
           Card-2: Marvell 88E8056 PCI-E Gigabit Ethernet Controller driver: sky2 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 00:24:8c:7e:ee:39
Drives:    HDD Total Size: 1500.3GB (72.1% used) 1: /dev/sda ST31500341AS 1500.3GB 
Partition: ID: / size: 15G used: 5.1G (38%) fs: rootfs ID: / size: 15G used: 5.1G (38%) fs: ext4 
           ID: /home size: 34G used: 4.0G (13%) fs: ext4 ID: swap-1 size: 6.82GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 47.0C mobo: 45.0C gpu: 68C 
           Fan Speeds (in rpm): cpu: 1917 psu: 0 sys-1: 0 sys-2: 0 sys-3: 0 
Info:      Processes: 249 Uptime: 0:01 Memory: 800.8/5972.0MB Client: Shell inxi: 1.7.24

oldcpu, I installed openSUSE 12.1 on my PC #2 and during the first ‘kexec’ reboot my display also when to garbage. I assume this is due to not having the kernel load option “nomodeset” set as default as some had requested during the test cycle of the new product. I also just allowed the the system to continue loading until all install activity seemed to have completed, based on the disk activity light. Doing a Ctrl-Alt-F1 just gives a blank screen, but nothing more. Doing a Ctrl-Alt-Del did restart the PC as you suggest.

With the openSUSE 12.1 installation disk still in the DVD drive, I selected boot from hard drive and the openSUSE installation continue menu was there. I selected F5 and Vesa and allowed the installation to complete. Once in the desktop, I edited the grub menu.lst file and added in the** nomodeset** kernel load option. I also run the YaST - System - /etc/sysconfig Editor - System - Kernel and changed NO_KMS_IN_INITRD from no to yes. When I did my install, I did a clean install of openSUSE 12.1 (formatted the / partition), but did I did not reformat my /home partition, but only mounted it, thus keeping all personnel settings. I had already downloaded the nVIDIA driver, so I did a restart, added in the kernel load option 3 to bypass the loading of a GUI. Once at the terminal prompt, I ran the latest nVIDIA driver and it installed like normal. Then I did another restart and now the desktop resolution is back to my normal.

So, not sure what to say, but it seems that if you have an nVIDIA video card, the ‘kexec’ restart is not going to result in a usable picture on your video screen which is too bad for our latest release. It is easy to overcome if you know what is going on, but some may not understand the problem.

Thank You,

I too had this on my box which has a nvidia 8500GT. I, like Lee waited until I knew the autoconfig had finished. I then forced a reboot. Added nomodeset to the boot argument and landed at a off centre desktop. I added a widget centre screen so I could work the way to yast. Switched the kernelmodesetting in /etc/sysconfig
Added the nvidia repo from the community list
Installed nvidia
Rebooted (not adding nomodeset)
I was presented with a nice desktop and the nvidia driver in place

BTW: The Graphics and Fonts during Install were fantastic!

I didn’t have the problem you described with graphic install of openSUSE 12.1 32 bit (Gnome) on my old dual Xeon server with nvidia GeForce FX 5500. However as I reported in posts #21 and #26 of this thread, gnome-shell was unusable (but didn’t automatically switch to fallback mode). Graphical setup was OK. When I booted into gnome-shell (before I got to install the proprietary driver), the panel was unreadable. Fortunately I wasn’t interested in reading the panel or looking for icons at this point. I pressed ALT-F2 to open a terminal and installed the nvidia driver from repo (among other things). Notice that this simple task would have failed under Ubuntu - which came directly with the nvidia driver - where the window manager crashes under Gnome-shell. It doesn’t crash under openSUSE, but the desktop becomes garbaged and unusable as soon as I move a window, probably because of the failing GLX TFP (which makes the drawing of pixmaps slow and finally impossible). Kde with compositing is not fun either. Everything else is OK… so far.

  • didn’t need nomodeset either.