opensuse 12.1 HP Pavilion dv7 gets hot

open suse 11.4 worked fine, after upgrading to 12.1 the fan runs and computer gets hot. CPU runs between 1 to 15% and memory use seems to be normal.
Unfortunately my knowledge is limited, and I do not know how to proceed.

CPU Intel Core i7 2630 QM /2GHZ
Grafic Card AMD Radeon HD 6770 M
Help is appreciated
Regards
jan

If this model is anything like the dv6, then overheating is a known problem:

HP Pavilion dv6 has freezing issues

In any case, maybe you should consider installing the proprietary fglrx driver (although I’m not sure if the HD 6770 is yet supported)

SDB:ATI drivers - openSUSE

Read this SDB:ATI troubleshooting - openSUSE if you have troubles, and need to get the radeon driver back.

Thank you for your proposal, deano_ferrari
I have tried proprietary fglrx driver, with no luck according, SDB:ATI drivers - openSUSE.

When I boot Windows 7 then the fan is quiet. It starts when running Battlefield 3, which is understandable.
Even when running opensuse 11.4 the fan is quiet.
So I think it somthing with opensuse 12.1, perhaps the graphic driver? But I do not know how to check it.

jan

I have tried proprietary fglrx driver, with no luck according, SDB:ATI drivers - openSUSE.

Are you saying you could not install the proprietary driver successfully? Did you try building manually?

SDB:ATI drivers - openSUSE

FWIW, a little searching shows same problem reported with other recent distors, and same solution (use the proprietary driver)

[SOLVED] laptop running very hot! [Archive] - FedoraForum.org]([SOLVED] laptop running very hot! [Archive] - FedoraForum.org)

This script (by user please_try_again) may help you to get the proprietary driver installed:

openSUSE Forums - ATI driver with atiupgrade

There is a repo for openSUSE 12.1 (adjust the instructions accordingly)

Index of /repositories/home:/please_try_again/openSUSE_12.1

Good luck.

Thank you for your efforts.
I’ve followed deano_ferraries advice “openSUSE Forums - ATI driver with atiupgrade”
Well, when switching to level 3, I’m not able to connect to the net. Can’t find NetworkMananger.
I’ve had problem with NetworkManager aplet, it dosen’t load att all. So now I’m stuck with the Network Manager problem to be solved first.
Or, can I use the preamble in “SDB:ATI drivers” becuse when I make “mkinitrd” then I can reach the internet.
Regards
jan

Follow the advice given by please_try_again in the atiupgrade guide

Running atiupgrade inside or outside of X.

If another ATI proprietary driver is not already installed - and thus the fglrx module is not loaded - you can run atiupgrade in xterm (or any terminal in a X session), and it should normally complete all the steps. Be warned that X might crash if you do not reboot immediately: Do not just log out! I don’t like this approach very much. There is no point in installing a graphic driver in X when you can do it in console - but that’s just my opinion. However, you might not have the choice if you don’t have a network connection in console - like if you are using the networkmanager. In this case, atiupgrade will build and create the package but not install it, and you will have to run the script again after rebooting in runlevel 3. At that point it will no longer need a network connection. It remembers where it saved the package the first time and installs it.

So, you can run the script (as root) in a graphical environment the first time, via konsole, xterm or similar, and once the script has created (but not installed) the package, then you need to reboot, enter ‘3’ at the grub menu prompt, and run the the script again (as root) from the command prompt.

I have the exact same computer with the same “running hot” problem. When I installed atiupgrade I ran into the following error:

File ‘/repodata/repomd.xml’ not found on medium ‘http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_12.1/

I see the repomd.xml file in the index link above, but …

Any help?

Hi
That repository is no longer in existence hence your error… you need
to delete from your system.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.31-0.9-default
up 21:19, 3 users, load average: 0.51, 0.37, 0.28
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU