opensuse-12.1-GNOME-LiveCD-i686.iso, installation-usb and netbook

I have created an installation medium 4GB usb by the CLI

#ls -l /dev/disk/by-id/*usb*
#mkdosfs -I /dev/sdb
#dd if=openSUSE-12.1-GNOME-LiveCD-i686.iso of=/dev/sdb bs=1M

I checked this medium on my 32-bit Dell-Vostro-1014 laptop and everything went fine.
But when I tried to check the medium on my 32-bit Zenith(India)-ZBook-OEM netbook the machie hung and refused to proceed further beyond the starting screen ‘Zenith-Always ON’ message.
I may mention that I have installed openSUSE-11.4 on this machine from a 2GB installation-usb created in an identical manner. As a matter of fact I am posting this thread from that platform. Also an installation-usb for
debian-squeeze has also worked.
Now I am waiting for advice and direction.

What you are doing should work on most computers.

The difficulty with older computers, is that they don’t all reliably support boot from USB.

But for a Netbook usb is the only way unless one goes for netinstall. And I wanted to use the live version of 12.1 so that I don’t mess with the perfectly working 11.4 version.