OpenSUSE 12.1 Elantech touchpad

Hi guys. I installed OpenSuse 12.1 with Gnome 3 on my new Samsung QX laptop. Unlike the trouble that other people are having, the Elantech touchpad is being detected as a touchpad. I can disable tap-to-click, and have 2-finger scrolling, but I can’t right-click, with the built in button or with 2-fingers. In Windows, the built in button and 2-finger click work. I was able to install a vanilla kernel, which detected the touchpad as a mouse: I had right-click, but no scrolling or disabling of tap-to-click (which I can’t stand using). Is there any way to get right-click on the kernel that detects the touchpad, or get the vanilla kernel to detect the touchpad so that I can disable tap-to-click and get scrolling?

Hello nine9nine,

have a look in following thread:

I have the same problem with an Asus UX31. I “solved” the problem by installing the Linux 3.1 vanilla Kernel (It does not has the “optimisations” for the Elantech touchpad).

Have also a look on the Ubuntu page for the UX31. Here, also the Elantech touchpad problem is discussed (you will find also a script to optimise the touchpad when using a newer kernel).



I just finished trying out Ubuntu on my Asus U46SV, because they have much better Bumblebee support, and it also has the Elantech touchpad.
I discovered that there isn’t a very good touchpad settings manager for Gnome, so I ended up switching to Kubuntu (which is a horrible execution of KDE in my opinion) because the “synaptiks” package for KDE works perfectly with the Elantech and you have most of the same settings as in Windows.

I’d recommend trying the standard OpenSuse live-cd with KDE just for the heck of it. It auto-detects the touchpad and Touchpad Management or Touchpad Settings will be in Desktop Settings under Input Devices.

I know it’s sad, but I’ve switched exclusively to KDE for my laptop just for the touchpad driver.