openSUSE 12.1 does not get to GUI with ATI Radeon 9600 XT

Hello, I’ve got a problem.

I’ve installed openSUSE 11.4 on a computer with ATI Radeon 9600 XT.
The installation went OK, except for the last part when the installer tries to load the system for the first time.
It failed. It failed three times already, no matter what desktop selection I make (tested with LXDE and KDE4).

First thing that I see is the text-based yast, with a message:

The graphical interface could not be started. The required packages were not installed (minimal installation) 
or the graphics card is not properly supported
As a fallback, the text frontend ....

Then, after yast finishes successfully (no error), it presents me with a console login screen.

Logged in, tried to startx the desktop manager. It failed, with an error “Xinit failed. /usr/bin/Xorg is not setuid, maybe that’s the reason”.

Started with sudo, then xinit tried a little bit longer, but could not connect to xserver.

Then I tried booting the Failsafe option. It was successful, but the looks and the speed was horrible (understandibly).

Then I tried nomodeset kernel flag on the main menu option. Nothing.

Then I tried x11failsafe flag, and it worked! But again, slowly, at least the resolution was normal again.

I found that the 50-device.conf file was commented out, so I removed the comments, as it (the file) specified using the radeon driver. And I removed the x11failsafe flag.

It did not boot.

The /var/log/X11.log (or similar) did in fact show that the module died with an error (IIRC, the signal 4 - operation not supported).
And stacktrace.

Sadly I can’t give you the log itself as I removed it as part of my new installation (Kubuntu, using a bit older kernel 3.0, as opposed to openSUSE’s 3.1 )

Can anyone help me on this problem, cause I really like openSUSE… :confused:

Thanks,
Rimas_K

I am having the same problem. When booting from the livecd the screen flashes a few times and i am left with text only login. If I use nomodeset it gives me an error somewhat like “drm writeback failed” several times. I have a radeon 9600 xt as well.

I have a similar problem updating 11.4 to 12.1 it only start with x11failsafe flag, or in safe mode, if no x11failsafe flag it hangs on black screen

SOLVED installing the ati driver in this way
SUSE/openSUSE - cchtml.com
many thanks to the author :-))

Are you just saying you installed the prop. ATI driver for this card in openSUSE 12.1 ?
I thought this card was considered legacy and the driver for it didn’t support current kernel and XOrg.

I hope you visit again to reply with some more details.

[quote="“verstraete_kenny,post:5,topic:74410”]
Are you just saying you installed the prop. ATI driver for this card in openSUSE 12.1 ?
yes

follw the link, it says everything

OpenSuSe 12.1 (Driver from ATI website) easy way--only way so far...

    Download The Latest ATi Driver (11.11) minimum!!! from ATI website
    Open software manager in YAST and install 

  kernel-source,kernel-devel,kernel-default-devel,kernel-desktop-devel,Gcc,Gcc++,Make

    reboot
    Open terminal, SU to get root,cd to directory where "ati-driver-installer" is, 

type:

  sh ati-driver-installer-*.run 

    install default (do not generate distibution package)
    verify /usr/share/ati fglrx-install.log, at the end of the file you should see "build succeeded with return value 0 duplicating results into driver repository...done.
    in terminal type: 

  aticonfig --initial 

    reboot 

merry christmas :-))

Pier_andreit … what graphic card do you have? If you were able to install with the proprietary graphic driver, I’ll lay odds that you do NOT have an AMD/ATI Radeon 9600 XT in that PC.

Type atiupgrade, it does everything. … provided you dont’ have a Radeon 9600 XT or another Legacy model, but you don’t.