opensuse 12.1: deutsche lokalisierung

hi,

ich habe vorgestern opensuse 12.1 (64bit) installiert, um es mal zu testen. hatte vorher kubuntu drauf. wie es mir scheint, gibt es ein problem bei der deutschen lokalisierung. das kmenu ist teilweise auf englisch. die seite auf der man diverse kde-einstellungen vornehmen kann (systemsettings) ist komplett auf englisch. das yast-kontrollzentrum ist auch auf englisch, obwohl ich die primärsprache auf deutsch gestellt habe…

ich habe gegooglet und gelesen, dass solch ein fehler bei früheren versionen schon aufgetreten ist, aber nie wirklich eine verwertbare lösung gefunden.

habt ihr eine idee woran das liegen kann? kann mir nicht vorstellen, dass die lokalisierung nur halb-fertig veröffentlich wurde.

mfg

Am 18.11.2011 19:46, schrieb anton89:
> habt ihr eine idee woran das liegen kann? kann mir nicht vorstellen,
> dass die lokalisierung nur halb-fertig veröffentlich wurde.
>
Nein nicht halbfertig, aber das Problem habe ich gesehen, wenn man von
der Kde Live CD installiert. Es werden offebar ein paar Pakete nicht
mitinstalliert obwohl sie da sind.
Ich habe dann folgenden Befehl ausgeführt


sudo zypper inr

inr = install recommends
das hat alles Fehlende nachgezogen, einmal ausloggen und wieder
einloggen und alles war deutsch.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

Anmerkung: das selbe ist auch bei GNOME’ s Live-CD so, da ist ebenfalls nur einiges deutsch … aber nicht die komplette Umgebung. Mit o.g. Befehl, ist’ s aber schnell eingedeutscht … :wink:

Am 18.11.2011 21:06, schrieb Linuxsusefan:
>
> Anmerkung: das selbe ist auch bei GNOME’ s Live-CD so, da ist
> ebenfalls nur einiges deutsch … aber nicht die komplette Umgebung.
>
Da sind wir dann wohl einfach am Limit dessen, was man auf eine CD
quetschen kann angelangt, ist dann wohl eher eine philosophische Frage
ob mehr Sprachpakete und weniger Software besser ist oder umgekehrt.
Kann man sicher unterschiedlich sehen.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

Vielen Dank!

Am 18.11.2011 22:46, schrieb anton89:
>
> Vielen Dank!
>
Du solltest aber natürlich keine Probleme haben die Pakete
nachzuinstallieren, wenn das System von der Live CD auf der Festplatte
gelandet ist, eigentlich müsste es das sogar automatisch tun.
Alternativ kann man natürlich die Installation von DVD verwenden wo das
Problem nicht existieren sollte weil die Sprachpakete dort immer voll
enthalten waren (ich habe bei der 12.1 das aber noch nicht mit der DVD
getestet).


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

Das Thema macht irgendwie die Runde … sogar in den Mailinglisten. Soweit Rückmeldungen eingegangen sind, kann es wohl sein das:

sudo zypper inr

nicht ganz ausreicht alles komplett einzudeutschen. Da kann es passieren das man ein:

sudo zypper dup

nachreichen muss. Oder gleich letzteren Befehl benutzt … je nach dem wie man will. So oder so, sorgt letzterer Befehl (dup) dann dafür das tatsächlich alles DE ist.

Schönes WE und gutes gelingen!

Ohne das jetzt irgendwie begründen zu können ausser, dass ich natürlich
das Ergebnis sehe hat das “zypper inr” bei mir ausgereicht hat. Ich hab
jetzt sogar die Befehlshistory nachgesehen auf der Maschine auf der die
12.1 von der KDE Live drauf ist (um sicherzugehen, dass ich nichts
anderes gemacht und dann vergessen habe).

Was mir jetzt gar nicht gefällt ist, wenn sich das bei verschiedenen
Leuten unterschiedlich verhält.

Gut, Hauptsache es löst das Problem, wenn man einfach “zypper dup”
absetzt, aber was ist der Grund?
Die Lokalisierungen gehören zu den “Recommends”, das klingt irgendwie
richtig buggy für mich, nicht schön.

@linuxsusefan: Danke für die Zusatzinfo.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

@martin_helm,

bei mir und dem GNOME was ich nutzte bzw testete, genügte ebenfalls ein “inr” fürs eindeutschen. Nur berichtete ein anderer User mir, das es bei ihm nicht reichte. Inwieweit da Vorbedingungen eine rolle spielte, vermag ich nicht zu sagen. Am besten man schaut immer wieder mal auf die KDE/GNOME Mailinglisten was dort bei dem einen oder anderen User sich wie auswirkte. :slight_smile:

Am 19.11.2011 15:56, schrieb Linuxsusefan:
> Am besten man schaut immer wieder
> mal auf die ‘KDE’
> (http://lists.opensuse.org/opensuse-kde/2011-11/msg00085.html)/‘GNOME’
> (http://lists.opensuse.org/opensuse-gnome/2011-11/msg00035.html)
> Mailinglisten was dort bei dem einen oder anderen User sich wie
> auswirkte. :slight_smile:
>
Da muss ich passen, ich folge schon zu vielen Mailinglisten und Foren.
Ich muss das eher einschränken als erweitern, nichts für ungut.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram