opensuse 12.1 connected to router, but no transfer

hi guys,

I have a laptop with both OpenSUSE 12.1 and WinXP installed on it

I’m connecting to the internet through a Tenda wireless router (very poor router, i know)

the problem is that even though I’m connected to the router, wired or wireless, it seems like I don’t have any transfer
I can’t ping Google but I can connect to the routers web interface, from there it all seems okay, and also from network manager, but i still don’t get any transfer…but in XP I do…so I guess it’s not a problem of network card but a configuration issue…

could somebody guide me to, or through a connection settings…??

thanks

Can You ping 8.8.8.8 ? What is the contents of your /etc/resolv.conf file ?

~> cat /etc/resolv.conf

to check.

Best regards,
Greg

yes, pinging 8.8.8.8 does work

here is the content of /etc/resolv.conf


### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search site
nameserver 78.96.7.88
nameserver 192.168.0.1

On 2012-04-09 14:16, harvested wrote:
>
> yes, pinging 8.8.8.8 does work
>
> here is the content of /etc/resolv.conf

Try using different nameservers. Like 8.8.8.8


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

yes, I’ve already done that…and I can see that pinging 8.8.8.8 does work

but I still don’t get any other transfer via HTTP requests through Firefox…

How did you setup networking? Put the IP of your router in Yast - Network - Networksettings - Gateway address.

Question: In the same application in the General tab, is IPv6 enabled? If so, disable, reboot and try again.

Networking is set up by the NetworkManager app from KDE,
I’ve disabled IPv6 from NetworkManage and also from Yast Network,
I’ve manually set-up the IP, SubnetMask and also Gateway for my card but I still don’t get any traffic… :expressionless:

On 2012-04-09 15:16, harvested wrote:
>
> yes, I’ve already done that…and I can see that pinging 8.8.8.8 does
> work
>
> but I still don’t get any other transfer via HTTP requests through
> Firefox…

Does the command “host google.com” work? If it does, then FF is
reconfigured. Perhaps you defined a proxy - or your network does indeed
have a proxy and you did not define it.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 2012-04-09 20:58, Carlos E. R. wrote:

> Does the command “host google.com” work? If it does, then FF is
> reconfigured. Perhaps you defined a proxy - or your network does indeed
> have a proxy and you did not define it.
>

Sorry, errata:
misconfigured, no reconfigured. The spellchecher acted up :frowning:


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I’ve tested “host google.com” and this is what I got


host google.com
;; reply from unexpected source: 193.231.189.18#53, expected 192.168.0.1#53
;; reply from unexpected source: 193.231.189.18#53, expected 192.168.0.1#53
;; connection timed out; no servers could be reached



i don’t know why it says 193.231.189.18 because I’ve set up the gateway to be 192.168.0.1

So what does your /etc/resolv.conf look like now ? Does it include 8.8.8.8 before all other nameservers ?

Did You define any nameservers in YaST in addition to what You’ve got configured in NetworkManager profile ?

Does creating a different NetworkManager profile with different nameservers and switching between then changes your /etc/resolv.conf as well ?

Best regards,
Greg

Best regards,
Greg

On 2012-04-10 18:36, harvested wrote:

> i don’t know why it says 193.231.189.18 because I’ve set up the gateway
> to be 192.168.0.1

Probably the gateway redirects to that server (it is a ns). And it doesn’t
work. So, do not put your gateway there, put a ns that works.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

here is the content of /etc/resolv.conf


### /etc/resolv.conf file autogenerated by netconfig!
  2 #
  3 # Before you change this file manually, consider to define the
  4 # static DNS configuration using the following variables in the
  5 # /etc/sysconfig/network/config file:
  6 #     NETCONFIG_DNS_STATIC_SEARCHLIST
  7 #     NETCONFIG_DNS_STATIC_SERVERS
  8 #     NETCONFIG_DNS_FORWARDER
  9 # or disable DNS configuration updates via netconfig by setting:
 10 #     NETCONFIG_DNS_POLICY=''
 11 #
 12 # See also the netconfig(8) manual page and other documentation.
 13 #
 14 # Note: Manual change of this file disables netconfig too, but
 15 # may get lost when this file contains comments or empty lines
 16 # only, the netconfig settings are same with settings in this
 17 # file and in case of a "netconfig update -f" call.
 18 #
 19 ### Please remove (at least) this line when you modify the file!
 20 search site
 21 nameserver 78.96.7.88
 22 nameserver 192.168.0.1


should I put another nameserver there? like 193.231.189.18 ??

the routers IP is 192.168.0.1
what other configs must be done?

I’ve managed to get it to work
I’ve just placed in /etc/resolv.com the following line


nameserver 193.231.189.18

it works slower than in winXp but it works :slight_smile:
thanks :slight_smile:

On Wed, 11 Apr 2012 22:26:02 +0530, harvested
<harvested@no-mx.forums.opensuse.org> wrote:

>
> I’ve managed to get it to work
> I’ve just placed in /etc/resolv.com the following line
>
> Code:
> --------------------
> nameserver 193.231.189.18
> --------------------
>
>
> it works slower than in winXp but it works :slight_smile:
> thanks :slight_smile:
>

try using google’s free name service instead: 8.8.8.8 and 8.8.4.4 (you can
specify more than one name server, in case one isn’t accessible, too busy,
or whatever).

often these work faster than those supplied by ISPs. they also work ok
with ip v. 6, which may cause delays otherwise if it’s enabled on your
machine.


phani.

On Wed, 11 Apr 2012 22:49:51 +0530, phanisvara das
<listmail@phanisvara.com> wrote:

> On Wed, 11 Apr 2012 22:26:02 +0530, harvested
> <harvested@no-mx.forums.opensuse.org> wrote:
>
>>
>> I’ve managed to get it to work
>> I’ve just placed in /etc/resolv.com the following line
>>
>> Code:
>> --------------------
>> nameserver 193.231.189.18
>> --------------------
>>
>>
>> it works slower than in winXp but it works :slight_smile:
>> thanks :slight_smile:
>>
>
> try using google’s free name service instead: 8.8.8.8 and 8.8.4.4 (you
> can specify more than one name server, in case one isn’t accessible, too
> busy, or whatever).
>
> often these work faster than those supplied by ISPs. they also work ok
> with ip v. 6, which may cause delays otherwise if it’s enabled on your
> machine.
>

oh, and since you don’t seem to be very familiar with these
configurations, you do that by placing another line under the first one,
like in the following. in addition, you could put your previous nameserver
in there, too, in case google isn’t always accessible, as i’ve seen here
in india. (you’re from romania, it seems.)


nameserver	8.8.8.8
nameserver	8.8.4.4
nameserver	193.231.189.18


phani.

yes, thank you
it is indeed working a lot faster
i did wrote them the way you specified…
i know some configurations but not all of them…

actually I didn’t encounter this problem before…
whenever I moved around with my laptop and connected to different routers and different ISP it was all good, so the first time is the hardest, right :wink:

thanks you, though…it’s working quite nice now :slight_smile:

cheers