openSUSE 12.1/Compiz Fusion issues

Hello everyone,

I recently installed a dual boot of openSUSE 12.1 32-bit alongside my Windows 7 x64 OS.

That part is running fine, I’m able to access my Windows partition inside openSUSE from \windows\C… brilliant.

My issues are however:

  1. Compiz Fusion

I ran: zypper install compiz-plugins-extra compizconfig-settings-manager in sudo

However, when I run compiz --replace my screen locks up, and I’m told I have to log out (one of the plugins may have failed it said).

I’m using compatible hardware - I’ve ran Compiz Fusion inside Ubuntu 11.10 live CD before. It’s an Intel graphics chip on board- nothing special but it works fine.

  1. Installing applications using YaST

When I’m trying to install applications, I usually get an error message that some repository isn’t available and the name it refers to is that of my KINGSTON USB flash drive. I installed the OS from booting off the flash drive, just wondering why the OS now looks for the installation files from the flash drive whenever I try to install additional software in YaST.

Any suggestions. thank you all in advance!

Re. Yast: remove the repo entry for your flash drive.

Hello Community,

Just upgraded my notebook to 12.1. I have gnome 3.2, and compiz 0.9.5 (from 12.1 repo). However, the moment I enable desktop effects from compiz-ccsm, the gnome shell crashes and logs out.

My notebook has an integrated intel graphics accelerator, so no messing around with graphics drivers.

I read on the compiz forum that there is less “co-operation” between the new gnome shell and the window manager, and therefore compiz may not work properly. So, is it goodbye to compiz? I used that a lot to make my life beautiful.

Having seen the issues, I am doubtful about upgrading my second notebook, which has an nvidia graphics card. 11.4 seems to be working much better.

Can anyone please let me know how you solved the compiz issue? And also, whether it is a good idea to upgrade the nvidia-card notebook (in the sense, that desktop affects will work, nvidia control center will work).

Thanks a lot!



AFAIK you cannot run compiz on gnome-shell. I could imagine a couple of things that make it a hard job, like the non-fixed no. of virtual desktops in GNOME 3. For what it’s worth: I do use the desktop effects on KDE, but I never felt the urge to have compiz on GNOME 3.

Hello Knurpht

Thanks a lot for this information. I have been debating about whether to switch to KDE from Gnome, since last time, I believed KWin was a major drag, too slow, especially with two large external monitors. I tried experimenting with different options, but got nowhere. I had all correct graphics cards installed, and stuff worked pretty well with Gnome.

I kind of have the impression that KDE desktop is power hungry, although, it is really pretty :). I will try KDE once again, this Christmas.

Thanks once again.


KDE has been working on improving the performance of Kwin, the work should be visible in 4.8 - see the OpenGL ES and Compositing Performance section here aseigo: more plasma workspaces 4.8 news

Hello google01103,

Thanks for the info. Will try when 4.8 is out then!

Till then, I guess it is gnome on opensuse 11.4.