opensuse 12.1 can't connect to internet/ network is unreachable

I’ve been using Windows all my life and few days ago installed opensuse.
The computer is dualboot with XP and suse. XP can connect to internet with no problem

CPU Information
Processor (CPU): Intel(R) Pentium(R) 4 CPU 2.80GHz
Speed: 2,792.88 MHz

Memory Information
Total memory (RAM): 746.9 MiB
Free memory: 73.3 MiB (+ 358.9 MiB Caches)
Free swap: 1.1 GiB

Open Suse 12.1 KDE

I’ve spent a lot of time looking for a solution. Other people seem to ask these stuff, so here you go:
Also I reinstalled opensuse (again) so its in the default settings I believe…

linux-fmvw:~ # ping
connect: Network is unreachable
linux-fmvw:~ # ping
connect: Network is unreachable
linux-fmvw:~ # ping
connect: Network is unreachable I believe its the IP for the router or switch (dunno which, if it is) is the IP for the computer I’m using now. This computer is connected to the same switch that the one with suse is connected. Both computers are on. the computers are connected to the switch, the switch is connected to the router which connects to the internet cable or something like that :
switch is D-Link
router zyxel prestige 600 series

linux-fmvw:~ # route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
loopback * U 0 0 0 lo

linux-fmvw:~ # cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:




or disable DNS configuration updates via netconfig by setting:


See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

linux-fmvw:~ # sudo /sbin/lspci | grep thernet
01:08.0 Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet Controller (rev 02)
linux-fmvw:~ # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

linux-fmvw:~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:11:11:8B:23:CA
inet6 addr: fe80::211:11ff:fe8b:23ca/64 Scope:Link
RX packets:97 errors:0 dropped:0 overruns:0 frame:0
TX packets:406 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9181 (8.9 Kb) TX bytes:131274 (128.1 Kb)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:296 errors:0 dropped:0 overruns:0 frame:0
TX packets:296 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:21280 (20.7 Kb) TX bytes:21280 (20.7 Kb)

PS: I’m a newbie

it turns out that it wasn’t compatible with D-Link, just plugged it to a Lynksis router (which I didn’t metion) instead of D-link and it worked! :D:D:D

Good news
Well done

Well done JSKT. We wouldn’t have thought of that solution, so congratulations!

can anyone help me with my problem. I recently installed openSUSE 12.1 on my desktop. I cannot also connect to the internet… i can connect to the other computers on local network but not to the internet. I don’t know if this has something to do with my dlink router and Attansic Ehternet Controller?

At first, i installed openSUSE 11.0 on the desktop, the problem was it does not automatically configure the Attansic Ethernet Controller. But with openSUSE 12.1, it does automatically configure the Attansic Ethernet Controller but could not connect to the internet. Please help… =)