opensuse 12.1 and not 5.1 sound driver on GA-MA770T-UD3

Hi there,
until suse 11.3 I had 5.1 sound on my sound card. But not in the 11.4 and 12.1. Sound card by hwinfo Hwinfo:
E: ID_VENDOR_FROM_DATABASE=ATI Technologies Inc
E: ID_MODEL_FROM_DATABASE=SBx00 Azalia (Intel HDA)

I’m not able to change to 5.1 or 7.1 - in the system is only stereo audio. Did I missed some somewhere ?

Thanks and best regards
J.K.

I have openSUSE-11.4 on one partition and 12.1 on another partition, and 5.1 sound works on both each time when I boot to either.

I installed the application ‘pavucontrol’ (pulse audio volume control) and it is a configuration setting in pavucontrol.

Hi,
thanks for answer. I’ve only “analog duplex audio” or so in the “Internal sound system”. There are more choices, but no 5.1 sound systems …

This is what I see in pavucontrol:
http://thumbnails60.imagebam.com/17913/c2bdb6179129648.jpg](ImageBam)

and when I look at the drop down menu selection:
http://thumbnails59.imagebam.com/17913/1c5ef1179129649.jpg](ImageBam)

and here is the output from running the diagnostic script /usr/sbin/alsa-info.sh (selecting the UPLOAD/SHARE option): http://www.alsa-project.org/db/?f=d9dba8b8a83f73a9b05b5f760d88cf5644fd0c37

… it just works on my PC.

Heh,
I’ve no “surround” choices, only that “stereo”.
My alsa script output:
http://www.alsa-project.org/db/?f=5032c0b5350e4ccf71dc9fa171acafd170e33189

Seem like using hda intel codec on realtec soundcard chip? But it’s maybe compatible, it was installed automaticali during instalation…

Thanks.

The above was my openSUSE-11.4 partition. So I rebooted to my 12.1 and this is what I get:
http://thumbnails61.imagebam.com/17914/e36939179131438.jpg](http://www.imagebam.com/image/e36939179131438)
and
http://thumbnails47.imagebam.com/17914/e54265179131439.jpg](http://www.imagebam.com/image/e54265179131439)

and script output: http://www.alsa-project.org/db/?f=39582619e1bf5876c6bf94e08e611b04e632289b

it makes me think you have something misconfigured (possibly misconfigured by default).

There is NOTHING unusual in an hda intel codec wrt a realtec sound card chip.

Thats common.

But your motherboard has an ALC892 and that is NOT common. That is pretty new (in relative Linux terms).

If you wish to successfully use new hardware, you often need to use new software. I note you have not updated your kernel for 12.1. Your PC has the 3.1.0-1.2-desktop kernel, while the more up to date kernel is the 3.1.9-1.4-desktop.

So I recommend :

  • 1st - update your kernel to the most current for 12.1 which is the 3.1.9-1.4-desktop. Reboot, test … try to tune with pavucontrol.
    .
  • 2nd - if that does not succeed, try updating your alsa version from 1.0.24 to 1.0.25. I wrote a guide here on how to do that: SDB:Alsa-update - openSUSE … and ensure you install not only the alsa-driver-kmp-desktop for your updated kernel version, but ALSO ensure you update libasound2, and the various alsa apps that you have already installed on your PC. Do NOT install new alsa apps. Just update the existing ones. If those apps are not updated , then you failed in following the guide (I concede, its not the best written guide). Then reboot and try again with pavucontrol.
    .
  • 3rd - if that does not succeed, write bug report. There is guidance here: openSUSE:Submitting bug reports - openSUSE and you can use your openSUSE username and password to log on to bugzilla. Write the bug report against component ‘sound’ in openSUSE-12.1. Do NOT reference this thread but rather make the bug report complete/stand-alone (the openSUSE packager who answers the bug report will not read a forum thread). Ensure you attach a copy of the text file /tmp/alsa-info.txt that you get by running ‘/usr/sbin/alsa-info.sh --no-upload’.

.
Good luck.

Hmm, but what and where, that’s the question . :slight_smile:
modules are loaded:
lsmod | grep intel
snd_hda_intel 33441 2
snd_hda_codec 118874 2 snd_hda_codec_realtek,snd_hda_intel
snd_pcm 109594 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd 86602 14 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc 18572 2 snd_hda_intel,snd_pcm

tried to remove sound configuration and run configure it again, still no “surround” choice avaible. How did you configured sound in the yast ? Leave it automaticaly?

J.K.

As an addendum, I did search the ALC892 on the alsa site, and as you can see from this hit: Search results - AlsaProject for ALC892 it is pretty new.

Quite possibly the alsa version that you have is not up to date. The alsa module (driver) comes with the kernel update. So if you update your kernel, you obtain an updated alsa module (driver). See my above post with 3 suggestions.

I forgot to mention, one rather (very) speculative thing you could try is what is proposed in this URL: Linux surround sound with PulseAudio (mini-HOWTO) which is to edit /etc/pulse/daemon.conf and change the line:


default-sample-channels = 2

to


default-sample-channels = 6

and then restart, and then use alsamixer to unmute if muted: alsamixer -c 0
… using that URL as guidance.

I have never found that necessary , and I have no idea if it works. It make make it worse, so be prepared to undue that change.

On 2012-03-10 22:36, oldcpu wrote:
>
> I forgot to mention, one rather (very) speculative thing you could try

Brief OT note: several of your posts appear non threaded to the thread you
are replying to, via NNTP.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

That OT note (off topic note) is an NNTP problem and nothing that I as a web based user nor as a moderator can do anything about. 4 years ago, when voting whether we should include NNTP with the merged forum, we accepted use of the NNTP interface, warts and all in its implementation. And it appears that randomly starting of a new thread, for no apparent reason, is a wart.

The web based interface is still available for you to use if you wish.

Given this is Off Topic, if you wish to discuss/pursue this NNTP problem/limitation further with the admins, if you wish could you please pursue/bring it up on a separate thread ? (and not disrupt this 5.1 help thread).

Thank you for your consideration in this !