OpenSUSE 12.1 64bit strange installation problem


when I tried to boot the 12.1 64 Bit Kernel on my 16GB / 6 NVIDIA Graphic Card Multiseat system,
the kernel hangs after loading from CD.
After using the boot parameter mem=3000M the kernel is able to boot.
But using the ‘top’ command, the system tells me, that it only recognizes 500M memory.

The 32bit kernel boots without problems, but also shows only 500M available memory.

I then installed the xen virtualized 64 bit system on this computer. The dom0 kernel is able
to use the complete 16 GB memory.

My question is now, which kernel option do I have to activate, that I can use the standard 64bit
kernel with this system?


Frank Knoben

Your problem sounds bizarre, but what do you mean exactly by “boot the kernel…from CD” - is it the Installation / LiveDVD that is causing issues? Could it simply be the LiveDVD and when you perform a full install, you’re OK?

I think, the problem is, how the kernel is compiled. The 64bit Installation / LiveDVD does not boot without the mem=3000M parameter.
Whithout the mem parameter, the dvd starts loading the kernel. After the kernel is loaded the monitor gets black and the system freezes.
It does not start the boot process.
After installation, when I try to boot the standard desktop kernel / initrd from harddisk, I get the erorr message:
Error 28 - selected item cannot fit into memory
So from harddisk, only the 64 bit xen kernel boots, from live dvd, the 64 bit kernel boots with the mem parameter.

I put the boot.msg file on my webserver
This gives more detailed information about how the xen kernel is booted and how all the devices are recognized.

There are some messages with the boot.msg that point to memory address range and i/o address range problems the system has
when booting.



I am a bit interested in this, because it sounds somewhat like what I have seen with the 32 bit desktop kernel on a system with 6G of memory. See Bug 708214 for my report on the issue.

The circumstances are very different, so it might not be related. However, there’s just enough of a hint in your posts to suggest that both problems might come from a common problem in the kernel code.

OK - that is what I was wondering. If the LiveDVD doesn’t boot, I’m afraid I’m way out of my league. Sorry.

The problem has been solved. It was a problem with the bios. The iommu memory hole between 15M-16M was not handled correctly.
I added the iommu=noaperture option to the kernel boot parameter, after that, the system bootet correctly.