openSUSE 12.1: 1) Gaps Between Panel Icons in LXDE; 2) Invisible Pointer Arrow When Choosing Desktop

Hi. From the Internet I downloaded the International Standards Organization (.iso) file for the installation of openSUSE 12.1 on November 19, 2011. I used an optical-disc-recording program to “Burn” that “Image to Disc,” making a Recordable Digital Video Disc (DVD-R) I could use to boot my Hewlett Packard, ZE1110, Pavilion notebook computer. Then I performed what in the openSUSE-12.1 installation program was called an update of openSUSE 11.4 to openSUSE-12.1 Linux; but I like to think of that as an upgrade, which distinguishes that procedure from updating openSUSE 12.1 which I think may replace some files with newer versions of them within openSUSE 12.1. Via Yet another Software Tool 2 (YaST2) while online I updated my openSUSE-12.1 installation on at least two different days. So by the evening of November 28, 2011 my installation of openSUSE 12.1 should have been up to date. I was favorably impressed with the thoroughness and diligence of the openSUSE-12.1 developers who likely even made the necessary replacements in the boot-grub booting procedure and within the repositories for an upgrade from openSUSE 11.4 to openSUSE 12.1.–Thank you for your impressive thoroughness and diligence in these respects!

I have had some experience using this new, openSUSE-12.1, Linux operating system, but in it haven’t tried everything I did in openSUSE 11.4 yet. After booting my computer into openSUSE 12.1 at the login screen and clicking on an icon, I could select the KDE (K Desktop Environment) Plasma Workspace or the Lightweight X Windows System, version 11 (X11) Desktop Environment (LXDE), writing broadly of the general options for me. But sometimes then the pointer arrow disappeared from view when it was moved closed to a radio button for one of the options there (Unfortunately clicking the lizard panel icon, then on “System, Preferences, Personal Settings, Workspace Appearance and Behavior, Desktop Effects,” and then on the “General” tab and under “Activation” unchecking the check box beside “Enable desktop effects at startup” and then clicking on the “Apply” button did not eliminate this problem on the next computer startup into openSUSE 12.1’s logon screen. So I returned to the original state of having that check box checked.). Nevertheless a click of my computer’s left touch-pad button probably did select the desired radio button. After entering my openSUSE-12.1 password, I could enter the LXDE. In it the panel icons on the right-hand side of the long panel at the bottom of the desktop screen initially did not have very large gaps between them. A keyboard-looking icon for the Smart Common Input Method (SCIM) was initially not visible on the panel. But after opening a few program windows, that keyboard icon became visible on the panel. On the panel a large gap appeared between the keyboard- and speaker-looking icons and between one of those icons and the electrical-plug-looking panel icon. Sometimes there was what I could call a momentary “flutter” of the panel icons with the lizard icon normally on the left side of the panel even becoming momentarily invisible, as if it were “pushed off” the left-hand side of the panel. I guess that that phenomenon may have been related to one or both of the gaps between pairs of panel icons which could reduce the space on the panel for other icons to the left of them. I right- or left-touch-pad-button-clicked on the SCIM panel icon and selected “Exit.” After that the SCIM panel icon disappeared from view in the panel, just as it should have.—But then a large gap of about half the width of the panel existed between the speaker- and electrical-plug-looking panel icons. After logging out and back into the LXDE, a smaller gap was visible between the two-monitor-looking panel icon and the speaker icon with the keyboard-looking icon not visible on the panel. After clicking on the panel two gaps were visible, one between the two-monitor-looking panel icon and the speaker icon and another one between the speaker icon and the electrical-plug-looking icon. A gratefully very successful, but only temporary solution to eliminating the gaps between panel icons was to click on the lizard panel icon, then on “System,” I think on “LXDE Control Center,” and then on “Refresh Panel.” After one such click I saw a white- or light-yellow-colored rectangle or square where one might ordinarily find a panel icon. After clicking on “Refresh Panel” a second time, that rectangle disappeared; and there was also no unwanted gap between panel icons.

On the other hand in the KDE Plasma Workspace instead of the LXDE there were no such visible gaps between panel icons. Even with multiple program windows open and the keyboard-looking panel icon visible, I saw no problems on the panel with various rectangles on the panel which indicated open program windows, the keyboard-looking icon, or and the lizard icon. So the problem of one or more gaps between panel icons in my case seemed to be confined to within the LXDE.

Thank you, developers of openSUSE 12.1, for not making openSUSE 12.1 too demanding of Random Access Memory (RAM) and central processing speed! It appears that my computer, which contains an Advanced MicroDevices (AMD), I think Morgan-type, Duron, one-GigaHertz (GHz) central processing unit (c.p.u.) and for which I purchased 1.024 GigaBytes (GB) of RAM can probably handle the KDE Plasma Workspace of openSUSE 12.1 without operating very slowly; so that is an option for me to avoid the problem with occasional gaps between panel icons in the LXDE. Nevertheless when there are no problems in the LXDE, the LXDE has been adequate for me to perform numerous tasks in openSUSE-12.1’s predecessor of openSUSE 11.4.

I think some people prefer to make so-called “clean” installations of operating systems rather than to install a new operating system via an upgrade. I agree that that appears to be the way to avoid possible problems due to making an upgrade; I suppose that making the clean installation would involve reformatting the partition of a hard-disk drive which would contain the new operating system. But for openSUSE if the upgrading process does not cause problems, I like the upgrade process because if it works well, hopefully one can just keep on going with openSUSE as a tool instead of in the so-called “clean” installation having to again select the special programs one wants to install and possibly to perform special adjustments like adjusting the desktop to fit the computer monitor or screen size or selecting a certain text editor as the default program to open files with certain extension on clicking on them. In other words there may be more human time spent in making a clean installation than in performing an upgrade of an operating system, assuming the upgrade works well. So if the two problems I mentioned here can be fixed without making a clean installation of openSUSE 12.1, I would prefer that. But fortunately I am in a good position with a fairly recent backup of my computer’s hard-disk drive before upgrading from openSUSE 11.4 to openSUSE 12.1 and my /home directory on a separate partition from the partition containing the openSUSE-12.1, Linux operating system so that I probably could perform a clean installation of openSUSE 12.1, if necessary, to fix the two problems of occasional gaps between panel icons and the occasional invisible pointer arrow that I mentioned here. Via I think right-touch-pad-button-clicking on the panel I think there may be a way to remove the panel icons and then add them one at a time to the panel. But I haven’t tried that and wonder what each of the panel icons would be called within the openSUSE-12.1 software. What do you suggest I do to fix the two problems I mentioned in the subject line of this posting and explained in the body of this posting?

Correction to the third sentence of the second paragraph in the above posting: But sometimes then the pointer arrow disappeared from view when it was moved over a radio button for one of the options there… (Sorry, my first version of this sentence was not as accurate as this version of it.)

I formatted the openSUSE-12.1-Linux-containing partition of my hard-disk drive and reinstalled openSUSE 12.1 onto it in a so-called “clean” installation of it in this way. But unfortunately the two problems mentioned in the title or subject line of this thread remained. I doubt that data in my /home directory, which was located on a separate partition of my computer’s hard-disk drive that I did not format in this experiment, would have caused either of the two problems. I think it is more likely that the two problems may have been associated with openSUSE-12.1 Linux itself, which I last updated on December 17, 2011. Also the result of this experiment, making use of a so-called “clean” installation of openSUSE 12.1, shows that the problems were not caused by the process alone of upgrading openSUSE 11.4 to openSUSE 12.1 and were not “inherited” from the previous, openSUSE-11.4 installation. With the help of a backup of the partitions of my computer’s hard-disk drive, I restored the contents of the openSUSE-12.1-containing partition to what they were before I formatted that partition in this experiment. The permanent solutions within openSUSE 12.1 to the two very specific problems I mentioned in openSUSE 12.1 are unknown to me.

And given that the gaps between the panel icons and sometimes momentary repositioning of them along the panel occurred in the Lightweight X Windows System, Version 11 (X11) Desktop Environment (LXDE), but not in the K Desktop Environment (KDE) Plasma Workspace, a guess is that those gaps and that momentary repositioning could have been due to a problem of some kind within the LXDE software.

On February 11, 2012 I noticed that the problem of unusual gaps between panel icons in the LXDE (Lightweight X11 [X Windows System, version 11] Desktop Environment) had gratefully been solved. On both that day and February 4, 2012 some updates to openSUSE-12.1 software were downloaded and installed. Of those two days of updates I guess that one or more of the 29 updates downloaded and installed on February 4, 2012 may gratefully have eliminated the gap problem. Among those updates was version 3.1.9-1.4 of the Linux kernel. The pointer arrow sometimes disappearing from view while or after moving that pointer arrow over one or more choices or radio buttons for the type of desktop remained a problem.

My three-year-old notebookcomputer’s hard-disk drive failed two tests. Gratefully I was able to obtain a replacement for it within a five-year warranty period. After loading the openSUSE-12.1, Linux operating system onto that new hard-disk drive, I did not notice any unusual gaps between panel icons. So now I “lean” toward the possibility of the previous, failing hard-disk drive damaging some software on it, causing the unusual gaps between the panel icons, and that an update of the Linux kernel may have written new data onto that failing hard-disk drive that replaced data that may have been damaged by the failing hard-disk drive, therefore eliminating the problem of the unusual gaps between panel icons.

As for the occasionally disappearing pointer arrow, I think I noticed that problem at some time even during the setup for an openSUSE-12.1 installation with the new hard-disk drive. So I don’t think it was caused by a failing hard-disk drive. Also during the setup for the openSUSE-12.1 installation I doubt if my computer was especially “busy” while the installation program was I suppose “waiting” for my input. In openSUSE 12.1 using the updated Linux kernel with version number 3.1.9-1.4 the problem was particularly noticeable when selecting a type of desktop environment before logging into openSUSE 12.1 with a user name and password. As the pointer arrow was moved over the choices for the desktop environment, the pointer arrow flashed on and off. After stopping the pointer arrow motion at one choice, the pointer arrow disappeared completely from view. On the other hand, when moving the pointer arrow over the desktop or computer screen surrounding the dialog box in which the user name and password are to be input, the pointer arrow was visible, not flashing on and off, and was displayed normally. I don’t recall any such pointer-arrow problems in openSUSE 11.4; but I used it more than three months ago. I wonder if the solution is that the pointer arrow needs to be forced to stay displayed on top when it is over another window, such as the sort-of drop-down box or window with radio buttons on it which allows the computer user to select the type of desktop environment.

There is another problem I noticed which may or may not be related to the occasionally disappearing pointer arrow. That is when I input my password just before logging into openSUSE 12.1, I noticed that in my first attempt to do that for one of my keystrokes in the password a solid, black disk did not appear on the computer screen. But after typing the whole password a second or third time, the password entry and login procedure often proceeded normally.

With a new hard-disk drive installed in my computer unfortunately the problem of unusual gaps between panel icons returned in at least the LXDE (Lightweight X Windows System, version 11 [X11], Desktop Environment). Therefore sorry, my guess that the unusual gaps were caused by a failing hard-disk drive was probably incorrect. Also sometimes I had two keyboard-looking panel icons visible for the Smart Common Input Method (SCIM) for the purpose of inputting simplified Chinese characters using its program and/or input method called Smart Pinyin. The recent problems occurred after I input the following series of commands in a terminal program in the superuser mode:

killall scim-launcher
killall scim-panel-gtk
killall skim
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE=scim
export LC_CTYPE=“zh_CN.UTF-8”
export QT_IM_SWITCHER=imsw-multi
export QT_IM_MODULE=scim
scim-panel-kde -d
scim -c kconfig -d
.
Later for one of the text editors Kate or LibreOffice’s Writer I think I could shorten the list of commands to enter to:

export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE=scim
export LC_CTYPE=“zh_CN.UTF-8”
scim -c kconfig -d
.

And, if I remember correctly, I think on at least one occasion using the SCIM’s Smart Pinyin method it may not have been necessary to type any of the above commands to have simplified Chinese characters typed and displayed in a document in one of the programs LibreOffice’s Writer or Kate.

I think the unusual gaps between panel icons were eliminated by, in both the K Desktop Environment (KDE) Plasma Workspace and the LXDE, right-button-clicking on the keyboard-looking SCIM panel icon and selecting “Reload Configuration.” But in the LXDE and KDE Plasma Workspace sometimes there were two keyboard-looking panel icons visible, especially when a few program windows were open. In reverse after closing some program windows the number of keyboard-looking panel icons was reduced from two to one. So it seems as if the opening of perhaps a certain type of program caused the second keyboard-looking panel icon to appear. In rapid succession I right-button-clicked on each of two keyboard-looking panel icons and selected “Exit.” In the terminal program window I saw “iled to open the panel socket,” which I guess should have been “Failed to open the panel socket.” Then I did something in the terminal program window in superuser mode, maybe just clicked once in it or entered ctrl and C, and saw in it the message “XME: not implemented yet: ScimBridgeAgentPanelListenerImpl::slot_exit ()” and saw one keyboard-looking panel icon visible and “linux…#” visible in the terminal program. Later in my LXDE session two keyboard-looking panel icons were visible again in the LXDE. In a session in the KDE in openSUSE 12.1 the terminal command “killall scim-panel-gtk” made two keyboard-looking panel icons disappear from view; afterwards one of them appeared. In a later session of openSUSE 12.1 in the LXDE two keyboard-looking panel icons were visible.

So now I think I need a way to keep a second keyboard-looking panel icon from appearing in the LXDE and KDE Plasma Workspace. What is such a way? Perhaps uninstalling and reinstalling all SCIM software packages could be tried, short of any other specific ideas. Otherwise how do I control which panel icons and whether there are any duplicates of them that appear in openSUSE 12.1 in the LXDE and/or KDE Plasma Workspace? In what directory or else file of an openSUSE-12.1 installation should I find the panel icons, including duplicates of them, which are directed to be visible at any given time? In the Konqueror file manager, when directing hidden files to be displayed, I found the directory /root/.kde4/share/config; but I didn’t know what to do after that. Is it possible for me to delete the duplicate icons or else the direction to display a duplicate icon somewhere within the openSUSE-12.1 directory structure or else a file?

In the openSUSE-12.1, Linux operating system I uninstalled and reinstalled the following software packages: mlterm-scim, scim, scim-bridge, scim-bridge-gtk, scim-bridge-qt, scim-input-pad, scim-m17n, scim-pinyin, scim-qtimm, scim-tables, scim-tables-zh. But afterward with several program windows open in the Lightweight X Windows System, version 11 (X11) Desktop Environment (LXDE) sometimes I could see two, Smart Common Input Method (SCIM), keyboard-looking panel icons displayed, a phenomenon similar to what I described in my previous posting in this thread.

From [SOLVED] : SCIM icon not showing in tray…](http://www.pclinuxos.com/forum/index.php?topic=80119.0) on the Internet I read, “BTW, older versions of both mandriva and pclos had the problem of putting 2 scim icons (one for root/one for user) in the tray.” I guess that “BTW” might stand for “By The Way.” And I assume that “tray” may refer to the “system tray” of panel icons usually located in the right-hand corner of the panel at the bottom of a computer screen in a Linux operating system when using the K Desktop Environment (KDE) or Lightweight X Windows System, version 11 (X11), Desktop Environment (LXDE). I decided to investigate whether a root user could be the explanation for a second SCIM panel icon appearing in my case or not using the LXDE in an openSUSE-12.1, Linux operating system. The LXDE Control Center can be reached within the LXDE by clicking on the green, lizard- or iguana-looking icon for the Kickoff Application Launcher at the lower-left-hand portion of the panel at the bottom of the computer screen; after that in the LXDE click on something like “System” and then “LXDE Control Center.” I found that the second SCIM panel icon appeared in three of four cases after an application within the LXDE Control Center was clicked which required the entry of the root-user password; that is in the cases after clicking on PCManFM Super User Mode, YaST Control Center, and Install Software and inputting the root user password, but not after clicking on LXDM Settings and inputting the root-user password. And among these four applications there is no way to input text within LXDM Settings. On the other hand, after clicking eight of eight applications within the LXDE Control Center which did not require the input of the root-user password, a second SCIM panel icon was not displayed as a result of such clicking. However, starting Terminal Program Super User Mode and inputting the root-user password within it did not cause the second SCIM panel icon to appear. And afterward typing the command “kate” within the Terminal Program Super User Mode to start the text editor Kate did not cause a second SCIM panel icon to appear. So the second SCIM icon appeared after clicking the applications within the LXDE Control Center which required the input of the root-user password and which with proper authorization for use enabled textual input somewhere within them.

I also noticed that after left-button-clicking on one of the two SCIM panel icons I could see “English/Keyboard” and “English/European” displayed as the only selectable options; after left-button-clicking on the other SCIM panel icon, numerous human languages and/or methods for inputting text in various human languages were possible, including “English/Keyboard.” I don’t think the appearance of the second SCIM panel icon hindered the input of simplified Chinese characters using the Smart Pinyin input method into a document within the text editor Kate. And on numerous recent occasions I found that it was not necessary to type special “export…”, etc., commands in a terminal program in super user mode in order to input simplified Chinese characters using Smart Pinyin in a Kate document. So I finally decided that gratefully I did not have to be concerned about the appearance of the second SCIM panel icon.

I use LXDE, so normally I’d read this message. But it’s just line after
line after line of text and to be honest, I can’t be bothered. Please
make more effort to present text sensibly if you want peolpe to read
your messages.

Unfortunately the problem of undesirable gaps between panel icons in the LXDE (Lightweight X Windows System, version 11 [X11] Desktop Environment) of an openSUSE-12.1, Linux operating system returned again for me. Recently I have seen it while offline. In the monitor settings in the LXDE the refresh rate of 60 (probably hertz) is set properly for my S3 TwisterK Hewlett Packard display monitor with a computer screen resolution of (1024 pixels) x (768 pixels). A common, but probably not always constant time interval between noticeable refreshes or updates of the panel seemed to be about nine or ten seconds. The gaps could appear or increase or stay constant in size when I the computer user was not pressing any keys or doing anything at the time on my computer. A similar problem of undesirable gaps between panel icons in the LXDE is reported at http://forums.opensuse.org/english/get-technical-help-here/applications/469491-lxde-panel-icon-spacing-issue.html on the Internet. Still the only temporary solution was to click on the lizard- or iguana-looking icon, then on System, then on LXDE Control Center, and finally on “Refresh Panel” one to three times.

I’d suggest filing a bug report for this. Bring it to the attention of the developers.

SourceForge.net: LXDE - Lightweight X Desktop Environment: Bugs

Thanks, deano_ferrari, for the suggestion of making a bug report. At SourceForge.net: LXDE - Lightweight X Desktop Environment: Detail: 3515301 - systray icons not always well arranged a bug report has already been filed on the problem of gaps between panel icons in the Lightweight X Windows System, version 11 (X11) Desktop Environment (LXDE). As of 1626, Eastern Daylight Saving Time, on June 24, 2012 that problem was unresolved.

Hello. Concerning issue 1 in my title or subject for this thread I am happy and grateful to report that after I replaced openSUSE 12.1 with openSUSE 12.2 the problem of undesired gaps between panel icons now seems to be a historical one. In openSUSE 12.2 I have a different keyboard panel icon appearing on the panel for the purpose of inputting Simplified Chinese characters into a document. In openSUSE 12.1 I think I had the Smart Common Input Method (SCIM) panel icon appearing on the panel. In openSUSE 12.2 I have the FCITX or fcitx (Free Chinese Input Toy of X or other explanations given at History - Fcitx on the Internet) panel icon appearing on the panel. I can’t write for certain whether that panel-icon substitution in the course of my substituting openSUSE 12.2 for openSUSE 12.1 played any role in the elimination of the gaps between the panel icons in openSUSE 12.1 or not. But “Thank you!” to any openSUSE-12.2 developer or developers who may may have solved this problem!

Great to hear. Thanks for your update.