OpenSUSE 11 too small root partition ?


I’m pretty new to Linux, so don’t shoot me if this is a stupid question :slight_smile:

I installed OpenSUSE 11 from DVD with default partition layout.

Since I can’t get virt-manager to work (there seems to be a bug that isn’t fixed yet), I reinstalled the OS and installed VMWare Server 1.6

By default VMWare server stores the virtual machines in ‘/var/lib/vmware/Virtual Machines’.

But the default partition layout seems to only reserve 20GB diskspace for ‘/’

The ‘/home’ got all the other diskspace…

Can anybody explain this to me ?
Why is the ‘/’ so small, and how do I change it ?

Please see accompanying screenshot for more info.

Thank you.


as to why this is the default FS layout? I do not know! I also think this is not the best way to partition a linux system. With the majority desktop installs being on a single disk I see no reason for 1) split filesystems 2) LVM. Usually when I install a desktop system I choose just two partitions a 2gb swap and allt the rest in “/” with no seperate home and with physical partitions and not LVM (a multidisk server would be different of course).

as to how to fix this, I think you have three solutions:

  1. resize your partitions if they are LVM. for “/” this sucks and involves booting from dvd and can be tricky
  2. reinstall on one big partition. probably the easiest but you would lose all your stuff
  3. make a workaround by doing something like this

$ su -
# mv /var/lib/vmware /home
# ln -s /home/vmware /var/lib/vmware

this way you have the VM’s in a folder on home and create a symbolic link to it on the “/var/lib” folder.



The strange partitioning is probably caused by too much experimentation :slight_smile:

I’m currently trying out multiple OS to determine which would be best for my server.

I previously installed VMWare ESX, XenServer, Open Solaris and CentOS, but they all have serious issues with my network card (onboard RTL8111B on Asus P5B-VM).

Actually OpenSUSE is the first Linux OS I tried which doesn’t seem to have problems with my network adaptor.

I will backup my virtual machines and try a fresh install.

Thank you.

instead of a fresh install, why not just resize the partitions ? use something like system rescue cd or Gparted both have tools for resizing partitions & saves a lot of kerfuffle re-installing


Well, the OS installs pretty fast and there’s no data on the disks yet, so I can’t loose any data :slight_smile:

But the repartitioning could be educational, so I’ll try that first.


Create a /home will allow the user to format / without losing configuration files. Separate /var is also useful, since you can tell yast to save every rpm downloaded. So if ever you have to reinstall, it can be done very fast and offline.

So there is a need of separate file systems. Generally, based purely of utility, I would have:
I also have /home/Documents in NTFS so I can access my documents under linux or Windows. And if I need to clean /home, it wont affect my personal files.

Then, if we take into account fragmentation (and ext does fragment):
But this setup is now a little bit pointless, since most of us update at each suse’s release.

instead of a fresh install, why not just resize the partitions ? use something like system rescue cd or Gparted both have tools for resizing partitions & saves a lot of kerfuffle re-installing

I think that suse’s disk provide a partition tool.

20 GB for / is quite a bit for many people.

If you plan to run programs that need to put a lot of stuff in the tmp folder then you may need more than that. But I really can’t figure out why many normal users would ever need more that 20 GB for root.

This isn’t Windows where it takes almost all of that 20 GB to install the OS without software. You could install a ton of OpenSuse and never use the 20 GB for a long time

He use VM, and each virtual image should be around 4gb, so 20gb is a little bit tight.


What you guys are telling about the separately stored user settings makes sense now :slight_smile:
I couldn’t understand how, after reinstalling the systeem, the system still had my file downloads on the desktop, hehe.

Anyway, aparently it is possible to specify a different storage folder in VMWare Server.
So I moved the virtual machine folder to “/home/Virtual Machines”.
Problem solved :slight_smile:

But i wish to thank you guys for giving me some extra insight in this matter.