opensuse 11 + Thinkpad t61 + Atheros AR5212 = no network?

I am trying to set up wireless on my laptop, I have Atheros chip AR5212.

First off, it didn’t work right out of the box. I then blacklisted ath5k module, and tried to install Madwifi from sources. I can see the modules ok:

ath_rate_sample 31232 1
ath_pci 255040 0
wlan 265712 4 wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal 294016 3 ath_rate_sample,ath_pci

but cannot connect. ifconfig shows wifi0 and ath0, I can scan the network and see connection points, but dhclient fails, because no offers received (I am trying to connect to an open network).

Next, I uninstalled my source installation of Madwifi, and tried to install it from the default Suse repository (repo-oss, Madwifi version Same result as before.

Next, I followed the suggestion to use repository /repositories/home:/schmolle1980/openSUSE_11.0. I installed madwifi and madwifi-kmp-default (I tried both versions "trunk+r3717 and r3725), same no-working.

I would think there should be plenty of users who install linux on t61. Can anybody tell me what is the problem here? Please, help!

Meanwhile, I am using my PCMCIA network card… It works, so there are indeed open network access points.


I also tried to use MadWifi-released packages from here

news/20080630/repository-update-for-opensuse-11-0 - - Trac

same result…

I guess this is a standing problem…

have you tried the madwifi drivers from here Index of /repositories/home:/schmolle1980/openSUSE_11.0/i586


Yes, I did, I mentioned that in my original post

RESOLVED!!! Currently I am using madwifi drivers from here:

news/20080630/repository-update-for-opensuse-11-0 - - Trac

BUT this is only part of the solution.

The way it worked for me was:

  1. In Yast Network settings choose “Traditional method with ifup”

  2. Then I edited the configuration for AR5215 chip, and checked “Enable device control for non-root users via KInternet” in the General tab.

  3. I also added “blacklist ath5k” to the end of /etc/modprobe.d/blacklist

After reboot, I was able to see all the networks in KInternet tool, and connected without problems!

ok i managed to get atheros AR2413 working by following this guide openSuSe-Atheros_madwifi thru YaST.

but i noticed that everytime i reboot i cannot connect to the network until i restart the networking from the command line. restarting the network through knetworkmanager (traditional method) doesn’t work.

looking at ifconfig, ath0 is initially assigned with (i use manual ip thru knetworkmanager) after reboot, but i can’t ping the router, other hosts or itself. when i do /etc/init.d/network restart, then that’s the time it can connect

what else should i fix?


I have this same problem, I’m using the “traditional ifup” way and doing static IP. on boot, it says the Access Point is Invalid; restarting the service makes it connect cleanly.

There are no errors in dmesg or in the boot sequence that I can discern; any advice for debugging?

There is a new MadWifi driver since today. I just installed this one and everything is working fine with it.

br, Peter

I have an IBM T43p with the AR5212 as well which does not work on the new OpenSuse 11, but it works on the Suse Linux Enterprise Desktop 10 +SP2 which is based on suse 10.1.

has anyone got any ideas for this.

this yast page works perfect, i edited it to make it so.

Atheros madwifi - openSUSE

this page could use more work. (eg Susu 10.3)
it makes lots of assumptions.
first this driver does not work on all version of Atheros chips sets but does work on ar5210,11 and 12.
you want 12 as it is the newest and supports a, b and g.

details forgotten in the above page: (I added em;)

1: edit, you most be connected to the web by a wired network card (chicken and egg, and assumptions)
2: in the same vain, at the config point (networkmanager)
you must disconnect said wired via the NWmanager first.
DHCP and a common IP address is bad for 2 net connections.

the 1 click yast does perfect , no issues.

then the next link for 10.3 . goes with out a hitch.
Many other linux disto’s die here ( cheers to SUSE !!)

the yast control center and the selection of the above madwifi files are not too good for nOOb’s.
my edit:
if you see dependency fails [on v10.3 you will] then click solve during the update, and accept)

select the first madwifi box ,then the one that says default. shy away from dev. debug , zen , PAE .
this is the only hard part.

ignore zypper and smart paragraphs (Noobs) and compiling.

modprobe ath_pci , now we HAVE A DRIVER loaded , Cheers !

This is champagne time… many fail to get here.
but Suse is firing on all 8 cylinders.

what was missing is the Knetwork manager (missing from the tray) another Noob show stopper.
this might occur if Suse is installed ,sans network.
(this is a theory)
(opened every box and gave up)
so i did a search knetworkmanager (its real name mentioned no where) and launched it. [google helpedme]

SO you want to connect to something.?
if at home , then connect per your own configurations.
you set up the router , so you you wrote it down right?
mine:K_Network manager (KDE , of course)
Pick your device atheros 5212
USE encrpytion [x]
WPA, personal, wpa1, key pass phrase, 123456abcdef
{Noobs, do not use my passphase,please…}
show credential so you don’t muff it.
ESIDD = mysiddname , deadzone < that’s mine , ok?

connect , i have a secure connection.

if at work or at starDoe cafe’ then ask others for the config, why guess?, there are lots of config.

how ever just turn off encryption and it might work.

if at home , turn off your routers encryption and then try to connect.
if that works then move to encryption and make them equal, carefully.

bingo you are talking.

cheers. jerry

This will get lots of AR5212 cards (pcmia and pci ) running.

Linux forever…