openSUSE 11 | Sound problem on Lenovo 3000 N100

I installed openSUSE 11 on a Lenovo 3000 N100 the other day. Everything seems to work fine except the sound; there is no sound at all from the speakers. Has anyone encountered this problem on a Lenovo 3000 N100?

I have read of many sucess stories with this laptop on different linux distributions, but not openSUSE-11.0 yet. Still, if you have not installed Linux on this laptop yet, then some things I’ve read you need to do are:
a. Disable the external Amp in your mixer
b. ENABLE the modem in the BIOS
PLEASE do the above two steps, and test your audio. Test your audio by copying and and pasting the following into an xterm/konsole (not it is case sensitive):
speaker-test -c2 -Ddefault -l5 -twav


If the above does not work by itself, with the above appropriately set, try working your way through the audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

If that guide stumps you, then please run the following two diagnostic scripts in an xterm/konsole (do a simply copy and paste), providing here the URL(s) that they will create.

wget -O && bash

For this next script, enter root password when prompted, and post “NO” for every question you do not understand/can’t answer:

su -c 'wget -O tsalsa wget && bash tsalsa'

And also paste output of typing the following in an xterm/konsole:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound


After trying step 2 on SDB:AudioTroubleshooting - openSUSE the sound is now working. However, sounds is still too low even on full volume.

Thanks again.


This is almost always a mixer problem.

I recommend you record your exact mixer settings now (such that you can always go back) and then check your master volume and PCM controls and make certain those are turned up to about 75%.