openSUSE 11 RC1: gvfs: Permission denied


I have an error message in Smart Package Manager, It says:

error: failed to stat /var/lib/gdm/.gvfs: Permission denied

That showing to me after doing smart upgrade

I don’t have any problem, but why it show me that message?

I’ve seen this error pop up here and there and mostly seems to be related to software installation.

As far as I’ve seen this is merely a cosmetic error but it would be good if they tackle it to avoid confusing users.

GVFS was updated and you should try a zypper ref && zypper dup to bring your RC up to date.

Note that it may download a lot of files.

Actually I am using SMART as default package manager in my system, and this is my channels:

type = rpm-md
name = openSUSE-11 Updates
baseurl =

type = rpm-md
name = Webcam Drivers (openSUSE_11.0_Update)
baseurl =

type = rpm-sys
name = RPM System

type = rpm-md
name = Packman repository
disabled = yes
baseurl =

type = rpm-md
name = X11 configuration (Factory)
disabled = yes
baseurl =

type = rpm-md
name = Stable Version of  (openSUSE_11.0)
disabled = yes
baseurl =

type = rpm-md
name = Repository for Xgl and related packages that give your Desktop some bling (X11:XGL)
baseurl =

type = rpm-md
name = Latest packages for Mozilla projects
baseurl =

type = rpm-md
name = Experimental/beta Mozilla versions (openSUSE_11.0)
baseurl =

type = rpm-md
name = Banshee Media Player (openSUSE_11.0)
baseurl =

type = rpm-md
name = openSUSE Factory
baseurl =

type = rpm-md
name = Beagle Desktop Search (openSUSE_Factory)
disabled = yes
baseurl =

type = rpm-md
name = Games (openSUSE_11.0)
baseurl =

type = rpm-md
name = Latest smart packages for openSUSE
priority = 10
baseurl =

type = rpm-md
name = Stable branch of GNOME (openSUSE_11.0)
baseurl =

type = rpm-md
name = X.Org development (openSUSE_11.0)
baseurl =

type = rpm-md
name = openSUSE Factory NON-OSS
baseurl =

type = rpm-md
name = Open repository for GNOME related packages (openSUSE_11.0)
baseurl =

type = rpm-md
name = Wine (openSUSE_11.0)
baseurl =

And I try using zypper ref && zypper dup but there’s no any updates for GVFS.
gvfs version on my system is: gvfs-0.2.3-28

You are indeed up to date - odd because I was having an issue where I was getting the message pre-version patch.

As far as I can see it is all about permissions on the folders .gvfs. On my OpenSuse 11 distro the permissions on /var/lib/GDM/.gvfs are:

d??? ? ? ? ? ? .gvfs

Anyone know how to fix this?

I’m having the same issue on openSUSE 11.0 GA.

# cat /etc/SuSE-release 
openSUSE 11.0 (i586)
VERSION = 11.0

# ls -lha /var/lib/gdm
ls: cannot access /var/lib/gdm/.gvfs: Permission denied
total 20K
drwxrwx--T  4 root gdm  4.0K Jul  2 23:49 .
drwxr-xr-x 42 root root 4.0K Jul  3 00:12 ..
-rw-------  1 root root   33 Jul  2 23:49 .cookie
drwx------  3 gdm  gdm  4.0K Jul  2 18:02 .dbus
prw-rw----  1 root root    0 Jul  2 23:49 .gdmfifo
d?????????  ? ?    ?       ?            ? .gvfs

Any ideas? Thanks


I can’t reproduce that error here but there is a bug open for this :

Maybe you can add your comments and get it sorted?


I have same problem to and simple solve it.

Reinstall all packages gvfs with YAST such as gvfs,gvfs-backends,gvfs-devel,gvfs-fuse,gvfs-lang,libgvfscommon0

Have a nice day!

Just Install openSUSE 11(i586)(no RC1!)
Some problem and reinstall packages with YAST dont work for me!!!
Anyone else got an idea how I can fix it? :confused:


Hi Sergey,

Have you run the openSUSE YaST online updates? Also, are there issues or do you just want to resolve the message?


Same problem openSUSE 11 x86_64:mad:

I have the same problem, and the link at bugzilla wrote above seems do not work…

Friends, I think the T means that you have to be a member of the gdm group in order to modify what’s under /var/lib/gdm. Or be full root.

Anyway, I had this problem when I tried to install the Sun 64-bit JVM ('cause the one that came with 11.0 isn’t worth spit when you try to run real Java applications on 64-bit like Eclipse or Pulse).

I encountered it when I installed Sun’s 1.6 rpm.bin and, because I hadn’t solved the problem (still don’t know IF I solved it), I had to create the links by hand:

in /usr/bin: ln -s /etc/alternatives/java
in /etc/alternatives: ln -s /usr/java/jdk1.6.0_07/bin/java

Now I’m up and running in Eclipse.

It’s too bad this stuff comes broken. I’ve got real work to do and it shouldn’t have to include removing software that comes with an installation and going somewhere else to get the stuff that does work.

(as root) try to do an updtedb in a terminal: you’ll encounter the same error the OP posted.
Bugfile was posted at:

I have the same problem. Tried installing from live CDs and the Full DVDs no joy.

I have also logged in as root and had the same problem. Also chmod does not work on the directory, I hope there is a fix for it soon as I really like Suse 11

I had this problem when I was installing Groupwise and Vmware. It was troubling me as well. So I did some googling and I came up with this procdure.

  1. I Installed the complete FUSE package - Basics - make sure packages are complete if you are using it.

  2. Just before installing your package - umount the /home/username/.gvfs - gvfs-fuse-daemon mounts your network connections as local file systems. The .gvfs dir is where any mounted network/other file systems are stored. So just make sure you are not using network connection resources before you umount.

  3. chmod the /home/userdir/.gvfs (I am not too sure you need to do this)

  4. Install your package

Good luck


I’ve been having this problem with Suse 11 for some time as well, with the file permissions being shown as ???.

I just tried a umount .gvfs command and heard the DVD drive working. I removed the DVD and a ls -la showed the .gvfs permissions as is normal.

This fixed it for me

umount /home/[username]/.gvfs
rm -r /home/[username]/.gvfs

Got it from the good ppl at ubuntu
[ubuntu] What is GVFS? I get permission denied when I rsync. Why? - Page 2 - Ubuntu Forums](

I’m still having this problem even though I’ve tried everything what’s mentioned here and on any other forums…

I’m using 11.0