openSUSE 11 on Virtual Box 1.6.2 - KDE does not start

Hi there,

I installed openSUSE 11 on my wife’s old laptop. The laptop was too old and too slow so I decided to put install Virtual Box 1.6.2 on my PC running WinXP SP3.

After I installed Virtual Box 1.6.2, I installed openSUSE 11 on my virtual machine (guest). Installation went fine but when I boot using the default option (openSUSE …blah blah), I got a classic UNIX logon screen instead of a GUI:

Welcome to openSUSE 11.0 (i586) - Kernel (tty1).

cbd451 login:

cbd451 is my host name.

Yes, that is all I can see. Where is the GUI?

If I boot the machine using safe mode, I can see the GUI/Logon screen.

So what have I done wrong?

I am a newbie on Linux and my UNIX is skill is quite limited. Your help is very appreciated.



Sounds like the graphics card is not set up properly. Enter startx at the command prompt if you get an error you will have to set up the graphics card. This is how to configure it. Login at the command prompt with the user you created. Then enter su press enter then the root password. Run sax2 this will set up the graphics card and monitor.

Hope this helps


It could also be that your box boots in init 3 mode. That means no graphical login. Try to login with root. Type this command:

init 5

If it boots into graphical mode you’re done. To automatically boot into graphical mode, edit the file /etc/inittab as root, and change this line:

Anyway, try harrylanza’s suggestion first, if that doesn’t help, try the init command

Hi all,

Thank you all for your help.

My installation does have a run level of 5. The problem was caused by the Virtual Box “virtual display card”.

When I installed openSUSE 11, I pick a resolution of 1280x1024 with a color depth of 24 bit.

After I run startx at command prompt, it failed. Then I run sax2 to change the color depth to 16 bit and reboot, things worked fine. Thanks Larry!

I am enjoying my Linux experience now.

Once again, thank you all for your help.