opensuse 11 on dell studio 1535

hey there,
i’ve installed the latest opensuse on a dell studio 1535 laptop.
the install (from a live desktop iso) went ok, but i now have no sound or scrolling from the synaptics touchpad.

my xorg.conf is below, and apart from the touchpad issue, it seems to work ok.

the sound card in the machine is detected like this:
#/sbin/lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
01:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]

any ideas?
thanks for reading.

I am not familiar with an RV620 … but I can try anyway to give some support.

First, did you try working your way through the audio troubleshooting guide? That is here:
SDB:AudioTroubleshooting - openSUSE
Please work your way through that guide.

when testing your sound I recommend you use this:
** speaker-test -Dplug:front -c2 -l5 -twav**

If the audio troubleshooting guide does not help, then please post here the very latest output of running the diagnostic script in the guide. To do that, please copy and paste the following into a gnome-terminal / konsole with your PC connected to the internet:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password, enter the root password. The script will give you a URL when it is complete. Please post that URL here.

Please also try to answer the question re: the number of plugs/jacks as accurately as possible. For example my PC has 3 sound input/output pugs/jacks.

Also, please post here the output of copy and pasting the following one line at a time in a gnome-terminal / konsole:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Are you running gnome? kde-3.5.9 ? or kde-4 ?

hi there,
thanks for the reply. after playing around with some settings described in the links from your post, i now have sound! :slight_smile:
although, i’m not sure if it’s 100% functional (there doesn’t seem to be any bass, so the sound quality isn’t great - nor is the volume).

the tsalsa script produced the following output:
tsalsa.txt - nopaste.com (beta)

and the rpm/kernel/module commands gave:


linux-cg53:~> rpm -qa | grep alsa
alsa-plugins-1.0.16-57.1
alsa-firmware-1.0.16-24.1
alsa-devel-1.0.16-39.1
alsa-oss-1.0.15-48.1
alsa-utils-1.0.16-35.1
alsa-1.0.16-39.1
alsa-plugins-pulse-1.0.16-57.1

linux-cg53:~> rpm -qa | grep pulse
libpulse0-0.9.10-26.3
pulseaudio-module-lirc-0.9.10-26.3
pulseaudio-module-zeroconf-0.9.10-26.3
pulseaudio-0.9.10-26.3
pulseaudio-module-gconf-0.9.10-26.3
pulseaudio-utils-0.9.10-26.3
gstreamer-0_10-pulse-0.9.7-42.pm.1
libpulse-browse0-0.9.10-26.3
pulseaudio-module-x11-0.9.10-26.3
pulseaudio-module-bluetooth-0.9.10-26.3
libpulse-mainloop-glib0-0.9.10-26.3
libpulsecore4-0.9.10-26.3
pulseaudio-esound-compat-0.9.10-26.3
alsa-plugins-pulse-1.0.16-57.1

linux-cg53:~> rpm -q libasound2
libasound2-1.0.16-39.1

linux-cg53:~> uname -a
Linux linux-cg53 2.6.25.11-0.1-pae #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux
linux-cg53:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel,snd-hda-intel
# NXNs.zLbcdSmaRU4:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-0 snd-hda-intel
# u1Nb.5McvgV6tXe2:82801H (ICH8 Family) HD Audio Controller
alias snd-card-1 snd-hda-intel

my desktop is gnome.

thanks again!

Ok, thanks for that. According to the diagnostic script, your ATI RV620 has a STAC 92HD73C1XS codec. Thats new to me. I did some research on this. There is improved support for it under 1.0.17 of alsa (you have 1.0.16).

I recommend you update your alsa per this page:
Alsa-update - openSUSE

which means to update, you should, with your PC connected to the internet, open up a gnome-terminal, type “su” to get root permissions (enter root password) and then copy and paste the following in sequence, one at a time, executing them one at a time:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
zypper install alsa alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar 
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ multimedia

zypper install alsa-driver-kmp-pae
zypper rr multimedia

Then you can reboot your PC (to reloaded the updated alsa modules) and test your sound.

You may still need to edit your /etc/modprobe.d/sound file to have this latest codec recognized. I note from the ALSA-Configuration.txt file for 1.0.17 of alsa (its not in 1.0.16 ALSA-Configuration.txt file) the following entry:

	STAC92HD73*
	  ref		Reference board
	  dell-m6	Dell desktops 

So that suggests only after updating your alsa (per the above and rebooting to reload the updated alsa modules) you should change your /etc/modprobe.d/sound to:

options snd slots=snd-hda-intel,snd-hda-intel
options snd-hda-intel model=dell-m6
# NXNs.zLbcdSmaRU4:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-0 snd-hda-intel
# u1Nb.5McvgV6tXe2:82801H (ICH8 Family) HD Audio Controller
alias snd-card-1 snd-hda-intel 

and restart your alsa with rcalsasound restart and test it.

I confess, since your analog audio is identified as one sound card, and digital is identified as a second sound card, I am not 100% certain that will work.

You may have to try this instead:

options snd slots=snd-hda-intel,snd-hda-intel
options snd-hda-intel model=dell-m6 index=0 enable=1
# NXNs.zLbcdSmaRU4:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-0 snd-hda-intel
# u1Nb.5McvgV6tXe2:82801H (ICH8 Family) HD Audio Controller
alias snd-card-1 snd-hda-intel 

and restart your alsa with rcalsasound restart and test it.

or if it is the digital audio that you are using then:

options snd slots=snd-hda-intel,snd-hda-intel
options snd-hda-intel model=dell-m6 index=1 enable=1
# NXNs.zLbcdSmaRU4:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-0 snd-hda-intel
# u1Nb.5McvgV6tXe2:82801H (ICH8 Family) HD Audio Controller
alias snd-card-1 snd-hda-intel 

and restart your alsa with rcalsasound restart and test it.

where index is specifying which sound device the “dell-m6” is applied to. (At least that is my speculation).

Hopefully one of those 3 will improve your sound (or better yet, maybe no change to the /etc/modprobe.d/sound file will be needed).

Good luck, and let us know how it works out.

For strictly information ONLY, in case you are curious about your codec, … I was put on the right trail by this post:
Gmane – Mail To News And Back Again
and it links to a page that provides info on your codec here:
Integrated Device Technology

also this post was an interesting read:
Kernel Linux support for Dell Studio 15 (AKA Inspiron 1535)

I looked, but could not see if your 92HD73C1XS codec is supported yet by the codegraph diagnostic application:
HDA codec graphing tool

It looked to me like it is not. … I don’t have an HDA Intel, so I have been unable to play with the codecgraph application myself, although after installing graphviz and graphviz-devel, codecgraph was an easy compile with checkinstall (to a custom rpm). I just don’t have the hardware to test/play with it.

I’m thinking I might ask one of the packagers to package this as an rpm for openSUSE (but this is just me babbling … ) .

Good luck with your efforts.

Let me fix those zypper commands. In my effort to format them for web presentation, I messed up the commands.

So go by this instead:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
zypper install alsa alsa-oss alsa-devel alsa-utils alsa-plugins alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ multimedia

zypper install alsa-driver-kmp-pae
zypper rr multimedia

Then you can reboot your PC (to reloaded the updated alsa modules) and test your sound.

and then back to the original post.