Opensuse 11 on a Netbook...anybody?

I’m planning to buy the Acer Aspire One netbook when it comes to market.
Has anyone tried installing Opensuse 11 on a netbook - Airis Kira/EEE PC/OpenBook?
I have the opensuse 11 kde4 live cd; if i copy it to a usb thumb drive, will i be able to boot from it on the Aspire One ?
Do I really have to use an external CD drive to install opensuse ?
Any suggestions…:slight_smile:

Well, i can understand there’s an article here:
OpenSUSE on the EeePC - openSUSE

but still i would like first hand info from clever souls on this forum…:rolleyes:

have istalled it on my acer aspire 5520.
Everything is perfect,apart from that wlan card.If the one u want to buy comes with atheros chepset as well,then it will be a real pain in the a*** to make it work.But in the end it will work.Other than this,everything is perfect.
Check here as well for laptop hardware support

I just installed openSuSE 11 in an Acer One, I had o do a network install booting from an USB memory. The only problem I had is that GRUB was not correctly configured so I was unable to boot from hd, I had to plug the USB. I will play with it for a few days and let you know how it went.

I installed OpenSuse 11 on my EeePC (see CurvyTail’s post for a link to the instructions), and it works wonderfully. Not sure about the specific driver needs of another netbook, but the performance is fine.

I have openSuse 11 running on Advent 4211 (rebranding of MSI Wind U100) with no problems at all. I had to tweak it a bit to make resolution work on 10’ screen and to compile Realtek drivers (not supported by default) but it all went smoothly. There is an excellent forum of MSI Wind users with a lot of information for different operating systems (including Ubuntu and opensuse) and all the possible upgrades and tweaks: MSI Wind News and Reviews.



I’ve been running OpenSuse 11 on an EeePC 900 (the white 20GB on) for a few months now and am an Avid fan of the combination. You can find an outline of how I did the install here:

Pale Heretic: Installing OpenSUSE 11 on an EeePC 900

There are only a couple of the hardware elements that I haven’t been able to get working so far.

My biggest problems at the moment are installing Suse on an EeePC 901 - the hardware for the wifi and nic are different and I cannot find any drivers that support them… I’m just about to start a new thread about this here…


Nice to see that more than I have the idea of running suse on netbooks without DVD/CD-ROM hw in them.
I will try to upgrade my Acer Aspire one from WXP before I start to use it.
I see the methods of using live CD and a second PC with network connection.
I find it at dissapointing though, that no one have prepared a descent manual on hot to easy get in the DVD-iso on a USB-stick and make it bootable.
Really, Im still a Linux-newbie but have at least no problem installing via DVD on any computer.
But trying to follow this manual is really a bit over most heads, I must say:
Installation without CD - openSUSE

Is it that difficult to write a step by step howto on how to get the content of an ISO-file onto a USB-stick the right way, and make it bootable?
I dont see the network soulution as an easy one and its giving you extra work for no good reason at all.

Sorry for being a bit negative, but if Linux will ever make it to the masses, issues like this have to be more well documented.
The Netbooks are coming heavily now, and SUSE should be well prepared to take care of new users on these light hardware PC:s.

OK, a more direct question then:
On without CD - openSUSE
it is written:

Assuming the version of openSUSE is 10.3 x86_64 or i386 and the usb stick is E: in Windows:


If you have a large usb drive you can do the same with the install CD!

I have not tried this with the DVD but i know it works with the CD.

So I have a 8gig usb-stick. Ofcourse I would like to put all SUSE DVD on it. (Not messing around with another networked computer)
But HOW?
Cant someone write a script or something makning all this happen?
Why is it so different from burning a DVD of an ISO?

No clew at all?

Hi all! I fortunately did it. After all, it mostly ran out of the box. I bought “the one” with 120G Hitachi an redmond-os on it, the shop had no others left. Started that os once. Copied the installer (openSUSE11_0_LOCAL.exe) via usb-stick on it and it ran! First came a lan-config, then a nifty net-installation (put main repository in the fields), Partition everything, even the restore-stuff, merge into one partition, run install, do something useful…

If there’s nothing on it you can also do a complete net-install via bootable usb-stick.

Post install: Upgrade, add smart package manager, add repositories, add wifi (a bit tricky… say: madwifi), fan silencer-script… Hope that will be automated/integrated one day. Netbooks are the thing to come.

I purchased in about one week ago, it runs silent and smooth. More later…

For Acer One I recommend the following repositories. After trial and error I selected madwifi ng_r3366+ar5007-1.8@i586.rpm as driver and ng_r3366+ar5007_2.6.25.17_jen67-1.4@i586 as kernel module. Works!

Now we are talking!
I also have the redmond bug started.

I also had the idea that it should be possible to copy the content from the SUSE DVD over to a USB-stick and use it as a harddrive. (Just like it is with a DVD on a computer with DVD-drive installed)
I ran the installer, (openSUSE11_0_LOCAL.exe) and the Aspire installed in windows and restarted.
Came in to main menu and choosed language and keymap.
But then I got stuck again…
I picked “start installation or update”, and then were to choose source medium.
I know its on the USB so I choose “hard disk”
I also know its the vfat, 7.5 Gb named sdb1
Then, “enter the source directory”…
Well, isnt that the usb?
Tried /, /boot/i386 , and some other ideas but none worked.
Why is this?
I dont have a working network yet, so I want to use the repositories on the downloaded DVD, is that too much to ask…
Are there any way to use the data on the usb now?
Or do I really have to get internet working for a network installation?

Small update…I hit ctrl-alt-delete and rebooted another time and picked suse-installer ofcourse.
All seems to install and soon back to installation panel.
After a while I get: “Make sure that number 1 in in your drive”…
Well…if I press “OK” nothing happens and “back” takes me back to keyboard mapping. after which I can choose “start installation” and then there is either “CD-rom”, “Network” or “Hard disk”
Ill pick hard disk and then sdb1 vfat
And then are supposed to “enter the source directory”…

So, where is it…?

OK, so I found this…:
Installation without CD - openSUSE

Remove any CDs or DVDs from their drives. You will just need to reboot and then choose Install SUSE Several choices need to be made. It mainly is clicking OK several times until you must select a way to install

* The first message will be Make sure that CD number 1 is in your computer. Press OK.
* You then get notified that it could not find the CD and it will start the Manual Setup. Press OK.
* You need to select the Language. Press OK.
* Choose the keyboard map. Press OK.
* You get the main menu. Select Start installation or System which is the default and press OK.
* You get Start installation or Update and must choose either network (via FTP) or Hard Disc (local drive)
      o Via Network. Choose the server and directory containing the install files.
      o Hard Disk. You will be asked to choose the partition. Next choose the directory.
            + For ISO files you will need to type the directory and complete filename of the first ISO file.
            + Example -- Partition: /sda1 (USB hard drive) Directory: /SUSECDs/SUSE-Linux-10.1-GM-i386-CD1.iso 

OK, so for some reason, I have to use the .iso file and not all the files existing on a SUSE DVD…
Not very obvious I must say if you dont find this howto…

I spent some hour on copying the .iso file to the USB-stick instead of all the files of the DVD, and gave it a try.

Seems to get me bit longer but:
“Sorry, linuxrc crashed at adress 0x08084236.
Linuxrc has been restarted in manual mode”

Back to “enter the source directory” I write the same:

But then get:
“installation failed” and after another 2 or 3 try the system hangs and only 2-3 crtl-alt-del can make a reboot.

What is going on here?

OK, I know that I cant expect an answer in some few hours but…?
No one wanting to help out here?

So are you intending to prepare this from a windows os or a linux os?

From memory I think the net iso has the option to use a local harddisk
for the install, I imagine creating a partition for the boot iso and
another for the dvd iso should work.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 14:45, 2 users, load average: 0.16, 0.17, 0.16
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

The Acer Aspire One comes with WXP installed and I want to switch to Linux before I start to use it.
The easiest way to me seems to be not to have to prepare and make the USB-stick bootable.
Instead just run an .exe program from within XP. (as U can do with a DVD also if XP is working but U cant get the PC to boot from DVD)
So I liked the idea of install the installer (openSUSE11_0_LOCAL.exe) via usb-stick and then just have a copy of the DVD-iso in place when rebooting via the installer.
Rebooting is working fine, and the install menu comes up where i can choose location for the .iso file, + its full path and then reading the .iso also seems to work, it comes 3 messages of successful reading of 3 parts, but then some adress conflict which stops the installation.
Its probably a simple thing, but its really beyond my skills…

Does it write an install log somewhere? If so you could post it on so we can all have a look :slight_smile:

Do you have another computer with a dvd you could use to run the live
CD and setup the flash drive?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 23:45, 2 users, load average: 0.09, 0.03, 0.01
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80