OpenSUSE 11 & Nagios 3.0.3 Sending Notifications

Hi guys. I am OpenSUSE \ Linux noob so please be gentle with me. I am not a total noob as i am a Microsoft Networking expert but dont hold that against me;)

I have installed OpenSUSE 11 and Nagios 3.0.3 and have got it up and running and all is good.

However i can not get Nagios to send me any notification even though i am 99.9% sure i have it setup correctly.

I did notice in /var/spool/mail/nagios that it could not find my domain so email was failing. I am using Microsoft Exchange as our in house email system.

Can anyone help me figure this out as right now i am loving OpenSUSE and Nagios and i could well become a Linux convert at this rate:P

Thanks in advance

Hi!

Maybe, this guide would be useful for you.

openSUSE Quickstart

Look the “contacts.cfg” edit part.

Have a nice day :wink:
TooManySecrets

Hello mate. I know what you are saying read the manual but i have done that and now i am asking for help.

Anyway as i said before if i look in /var/spool/mail/nagios i have the following.

can you please see anything from below as to the cause of why this is not sending email. I use Microsoft Exchange 2003

Part 1

From MAILER-DAEMON Thu Aug 28 23:42:20 2008
Return-Path: <>
X-Original-To: nagios@LNMON01.Withers.net
Delivered-To: nagios@LNMON01.Withers.net
Received: by LNMON01.Withers.net (Postfix)
id 58BF516DDA; Thu, 28 Aug 2008 23:42:20 +0100 (BST)
Date: Thu, 28 Aug 2008 23:42:20 +0100 (BST)
From: MAILER-DAEMON@LNMON01.Withers.net (Mail Delivery System)
Subject: Undelivered Mail Returned to Sender
To: nagios@LNMON01.Withers.net
Auto-Submitted: auto-replied
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
boundary=“38E2016D95.1219963340/LNMON01.Withers.net”
Message-Id: <20080828224220.58BF516DDA@LNMON01.Withers.net>

This is a MIME-encapsulated message.

–38E2016D95.1219963340/LNMON01.Withers.net
Content-Description: Notification
Content-Type: text/plain; charset=us-ascii

This is the mail system at host LNMON01.Withers.net.

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

               The mail system

<MY-EMAIL@Withersworldwide.com>: Host or domain name not found. Name
service error for name=Withersworldwide.com type=AAAA: Host found but no
data record of requested type

–38E2016D95.1219963340/LNMON01.Withers.net
Content-Description: Delivery report
Content-Type: message/delivery-status

Reporting-MTA: dns; LNMON01.Withers.net
X-Postfix-Queue-ID: 38E2016D95
X-Postfix-Sender: rfc822; nagios@LNMON01.Withers.net
Arrival-Date: Thu, 28 Aug 2008 23:42:20 +0100 (BST)

Final-Recipient: rfc822; MY-EMAIL@Withersworldwide.com
Action: failed
Status: 5.4.4
Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
for name=Withersworldwide.com type=AAAA: Host found but no data record of
requested type

–38E2016D95.1219963340/LNMON01.Withers.net
Content-Description: Undelivered Message
Content-Type: message/rfc822

Received: by LNMON01.Withers.net (Postfix, from userid 1001)
id 38E2016D95; Thu, 28 Aug 2008 23:42:20 +0100 (BST)
Date: Thu, 28 Aug 2008 23:42:20 +0100
To: MY-EMAIL@Withersworldwide.com
Subject: ** PROBLEM Service Alert: London Main SQL Servers/Explorer is
CRITICAL **
User-Agent: Heirloom mailx 12.2 01/07/07
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: quoted-printable
Message-Id: <20080828224220.38E2016D95@LNMON01.Withers.net>
From: nagios@LNMON01.Withers.net

***** Nagios *****

Notification Type: PROBLEM

Service: Explorer
Host: London Main SQL Servers
Address: 10.10.100.62
State: CRITICAL

Date/Time: Thu Aug 28 23:42:20 BST 2008

Additional Info:

Explorer.exe: not running=

–38E2016D95.1219963340/LNMON01.Withers.net–

Try adding this line to /etc/sysconfig/postfix from the YaST sysconfig editor to stop Postfix from trying IPv6 name resolution:

POSTFIX_ADD_INET_PROTOCOLS="ipv4"

and then restart postfix.

Another way might be to disable IPv6 globally and then Postfix will not try to use it. I have not done this on my system but here is a page explaining how:

SDB:Disabling IPv6 completely - openSUSE

Thanks mate.

I have disabled IPv6 from within the network configuration setup would this be the same as if i put POSTFIX_ADD_INET_PROTOCOLS="ipv4 in the postfix file?

If not where in the postfix file do i put it? every where i stick it it just produces an error when the service is restarted

Thanks for your help in advance

Craig

Do you have an MX, A, and PTR record setup for the mail server?

Hummm… This is a “typical” error; it frequently happens when the receiving server is behind a router or something that doesn’t really comply to the Rules of Ripe. Delete the IPv6 support (as one mate was said to you).
You can create an AAAA record for a_certain_domain.com on the authoritative name server for that domain.

Have a nice day :wink:
TooManySecrets

Hi guys.

both thanks for the reply. I have removed IPV6 from the network card config.

I am a little lost in the Linux to be honest right now. We use in my company Microsoft Exchange and we have services that we allow to relay through and with that we have to tell the service the IP address or hostname of the server to send email to.

Do i not have to specify an address in Linux?

Thanks in advance

Hi guys.

I have got the email function working now under openSUSE 11.

What it was i had to run the Yast Mail Config and once i entered the ip address of my exchange server all the emails started to come through.

Anyway thanks for the help

Cheers

Craig

Could be this could give some tips : Installing Nagios on openSUSE 11.0 :slight_smile:

Cheers,
Wj

Hi guys.
would you please help me configure the yast mail config? lets say my exchange server is 192.168.1.26 and i have an email account on the exchange server, say “nagios@test.uk”. and my nagios server is at a remote site say 192.168.1.81. what exactly do i put in the mail config?
Thanks in advance.

On 2011-03-01 14:06, izimbiri wrote:
>
> Hi guys.
> would you please help me configure the yast mail config?

No.

Please create a new thread. The subject says that you are asking about:

Re: OpenSUSE 11 & Nagios 3.0.3 Sending Notifications

which has nothing to do with email config, AFAIK.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

my bad! I asked that because one of the guys said he got the email notification working by configuring yast mail config. I cant get the alerts to go.
Id really be grateful if anyone could help me get the email notifications working whether by yast mail config or any other way! Thanks in advance.

On 2011-03-01 17:36, izimbiri wrote:
>
> my bad! I asked that because one of the guys said he got the email
> notification working by configuring yast mail config. I cant get the
> alerts to go.
> Id really be grateful if anyone could help me get the email
> notifications working whether by yast mail config or any other way!
> Thanks in advance.

Still no >:-)

You are replying to a thread dated August 2008, so I have no idea what you
are talking about and I’m not going to look it up. So, please, create a new
thread and explain your query in enough detail.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

At the risk of continuing an irrelevant thread but assuming that you’re actually talking about running Nagios on openSUSE,

  • A “site” usually is defined as geographically separate. If you’re really in a different site but using the same NetworkID (192.168.1.x) then pls explain topology.
  • YAST mail config configures a local mailserver, that’s it. Beyond that, need something specific.
  • If you’re really emailing a notification from Nagios, then you need to also configure Nagios to mail from/to, not just the local mailserver.

HTH,
Tony