OpenSuSE 11: mount error 13 = Permission denied

I’m running into issues just testing a share I have setup using Yast -> Samba Server.

My user is mturcotte and its home is under /home/mturcotte.

I also have a directory structure / that belongs to mturcotte, i.e. /bea belongs to mturcotte (as well as anything belong /bea).

I created /bea/domains/ac_domain which I which to share (to subsequently mount it from many VMware instances, but that would be later).

Here’s the ownership / permission of /bea/domains/ac_domain:

kevlar:/bea/domains # l
total 12
drwxr-xr-x 3 mturcotte users 4096 Jul 21 20:25 ./
drwxr-xr-x 13 mturcotte users 4096 Jul 21 20:25 …/
drwxr-xr-x 2 mturcotte users 4096 Jul 21 20:25 ac_domain/

Here’s my /etc/samba/smb.conf:

kevlar:/etc/samba # cat smb.conf | grep -v ^#
workgroup = WORKGROUP
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = Yes
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = No
domain master = No
security = user
lanman = Yes
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
browseable = Yes
comment = ac_domain
force group = users
inherit acls = No
path = /bea/domains/ac_domain
read only = No
username = mturcotte

Here’s my /etc/samba/smbusers:

kevlar:/etc/samba # cat smbusers

This file allows you to map usernames from the clients to the server.

Unix_name = SMB_name1 SMB_name2 …

See section ‘username map’ in the manual page of smb.conf for more


This file is not included in the default configuration as it makes the

usage of an user named administrator impossible.

;nobody = guest pcguest smbguest

I tried different ways (pointing to different IPs that are configured on my host, as well as using either user mturcotte or root) to mount but I always get “mount error 13 = Permission denied”

mount -vvv -t cifs // /home/mturcotte/ttt -ousername=mturcotte,domain=WORKGROUP
mount -vvv -t cifs // /home/mturcotte/ttt -ousername=WORKGROUP/mturcotte
mount.cifs -vvv // /home/mturcotte/ttt -ousername=mturcotte,domain=WORKGROUP
mount.cifs -vvv // /home/mturcotte/ttt -ousername=WORKGROUP/mturcotte

mount -vvv -t cifs // /home/mturcotte/ttt -ousername=root,domain=WORKGROUP
mount -vvv -t cifs // /home/mturcotte/ttt -ousername=WORKGROUP/root
mount.cifs -vvv // /home/mturcotte/ttt -ousername=root,domain=WORKGROUP
mount.cifs -vvv // /home/mturcotte/ttt -ousername=WORKGROUP/root

Obviously, I made sure directory /home/mturcotte/ttt exists and is owned my mturcotte.

I’ve seen some posts that indicate that mount -t smbfs should work, but I get this when I tried it:
mount: unknown filesystem type ‘smbfs’

I had not worked with Samba in quite a long time, so maybe something changed that I’m not aware of…

Any ideas?



I just realized I forgot to post the output from one of my attempts:

kevlar:~ # mount -vvv -t cifs // /home/mturcotte/ttt -ousername=mturcotte
mount: fstab path: “/etc/fstab”
mount: lock path: “/etc/mtab~”
mount: temp path: “/etc/mtab.tmp”
mount: spec: “//
mount: node: “/home/mturcotte/ttt”
mount: types: “cifs”
mount: opts: “username=mturcotte”
mount: external mount: argv[0] = “/sbin/mount.cifs”
mount: external mount: argv[1] = “//
mount: external mount: argv[2] = “/home/mturcotte/ttt”
mount: external mount: argv[3] = “-v”
mount: external mount: argv[4] = “-o”
mount: external mount: argv[5] = “rw,username=mturcotte”
parsing options: rw,username=mturcotte

mount.cifs kernel mount options unc=//\ac_domain,ip=,pass=urdbhok?,ver=1,rw,username=mturcotte
mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page ( mount.cifs)

This is the same error I’m getting with all of the various mount commands I listed in my previous post.



I also forgot to mention other details:

  1. I tried with and without the lanman = Yes lines in my /etc/samba/smb.conf and still got the same error (I only tried the lanman = Yes because I saw a post about it; but clearly it did not help me)

  2. Here’s the output from smbtree:
    kevlar:/etc/samba # smbtree
    \KEVLAR Samba 3.2.0rc1-22.1-1795-SUSE-SL11.0
    \KEVLAR\profiles Network Profiles Service
    \KEVLAR\users All users
    \KEVLAR\groups All groups
    \KEVLAR\ac_domain ac_domain
    \KEVLAR\IPC$ IPC Service (Samba 3.2.0rc1-22.1-1795-SUSE-SL11.0)

…Just to confirm the ac_domain was listed as a share.

  1. I tried with Samba configured as a Primary Domain Controller as well as configured a no domain controller. Again same error.

  2. In my listed mount attempts, I tried root to see if even that user would get the same permission denied, and it did.

I really don’t know what else to try.



Apparently this is a known bug, check this for a workaround: Vijay Kumar’s Blog: Cifs “mount error 13 = Permission denied”