OpenSuse 11, laptop microphone


this is the output of

general pastebin - root - post number 1073174

My laptop microphone doesn’t work. If I use the headset microphone is all Ok.

Can you help me?


p.s: I have a Acer laptop 7720 G

obviously check you volume levels. You might want to switch on the mic boost. In the volume control go to the switches tab and make sure all of them are turned on.
I have an Acer 5920 and my mic is working so I guess yours should work as well.
Good luck.

Look up a user on the forum called oldcpu, he is the audio master :).

All volumes are ok…

Surfing a couple of the Linux laptop sites, I note a few users have not succeeded in getting their internal microphones to work under Linux (Ubuntu/Gentoo) on the Acer 7720G.

When it comes to a microphone, my experience is that one’s mixer settings are very important (and very finicky). For mixer settings, the tsalsa diagnostic script provides better formatted information (a nicer summary) than the script. So can you please run the tsalsa script by copying and pasting the following into an xterm/konsole:

wget && su -c 'bash ./tsalsa' 

When running the tsalsa diagnostic script, when prompted for a password, enter the root password. Type “NO” for every question you do not understand, please give an accurate answer to the # of input/output jacks, and please post here the URL that you will be provided when the script completes.

Please also provide the output of copying and pasting the following commands (one line at a time) into an xterm/konsole:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
cat /etc/modprobe.d/sound

Also, are you using KDE or Gnome? If KDE, is it 3.5.9 or 4.x ?

The alsa-info-sh script has this for your mixer:

# Simple mixer control 'Input Source',0
#  Capabilities: cenum
#  Items: 'Mic' 'Internal Mic' 'Line'
#  Item0: 'Mic' 

Ie you have it set to your external mic, and not an internal mic.

When looking at your boost for your internal mic:

# Simple mixer control 'Internal Mic Boost',0
#  Capabilities: volume
#  Playback channels: Front Left - Front Right
#  Capture channels: Front Left - Front Right
#  Limits: 0 - 2
#  Front Left: 0 [0%]
#  Front Right: 0 [0%] 

the levels are at zero. Why?

If you want the Internal Mic to work, I think you need to set your mixer to the Internal Mic. Also, as gielhendriks noted, move up your boost levels.

That’s not to say there are not other problems, but the above is rather obvious.


I have changed the mic boost volume. Now, this is the output of

general pastebin - root - post number 1074132

This is the output of tsalsa:

tsalsa.txt - (beta)

rpm -qa | grep alsa:


rpm -qa | grep pulse:


rpm -q libasound2:

cat /etc/modprobe.d/sound:

options snd slots=snd-hda-intel

u1Nb.Z0J4Co96n9E:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

I use Gnome.


Thanks for this. But when I look at your mixer, you have it set for “mic” (which I assume is the mic “in” jack, and not the internal mic. If you wish to test the internal mic, do you not have to select it? You don’t have it selected.

Amixer contents for card 0 [Intel] _____________________________________
amixer set ‘Master’,0 98%,98% on
amixer set ‘PCM’,0 66% 66%
amixer set ‘Line In Boost’,0 100% 100%
amixer set ‘Mic Boost’,0 100% 100%
amixer set ‘Capture’,0 Capture 24 77%,Capture 24 77% on
amixer set ‘Beep’,0 92%,92% on
amixer set ‘Input Source’,0 Items: ‘Mic’ ‘Internal Mic’ ‘Line’ Item0: ‘Mic’
amixer set ‘Internal Mic Boost’,0 100% 100%
Again, the above illustrates you do NOT have the 'Internal Mic" selected. Instead you have the headphone Mic selected!


If setting your mic to “Internal Mic” does not work, then you could try a custom edit to your /etc/modprobe.d/sound file. The ALSA-Configuration.txt file notes the following entries are applicable for an ALC268 (which your laptop has):
Linux Kernel Documentation :: sound : alsa : ALSA-Configuration.txt

824		ALC268
825		  3stack	3-stack model
826		  toshiba	Toshiba A205
827		  acer		Acer laptops
828		  dell		Dell OEM laptops (Vostro 1200)
829		  test		for testing/debugging purpose, almost all controls can
830				adjusted.  Appearing only when compiled with
832		  auto		auto-config reading BIOS (default) 

I’ve also read the default “auto” setting is not being applied by default for some openSUSE-11.0 users. So first try the “auto” setting, and if that fails, since you have an acer laptop, try the “acer” setting… ie. more specifically, try this /etc/modprobe.d/sound file first:

options snd slots=snd-hda-intel
options snd-hda-intel model=auto
# u1Nb.Z0J4Co96n9E:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

and then restart your alsa from an xterm with root permissions with rcalsasound restart and test your audio/mic. Don’t forget to check your mixer.

If that doesn’t work, then try

options snd slots=snd-hda-intel
options snd-hda-intel model=acer
# u1Nb.Z0J4Co96n9E:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

and then restart your alsa from an xterm with root permissions with rcalsasound restart and test your audio/mic. Don’t forget to check your mixer.

As a final note, no amount of editing the /etc/modprobe.d/sound file will work, if you do not setup your mixer correctly.


How can I do to set my mic to “Internal Mic”.

Thakns for your help…

I am a KDE user. I don’t have such problems. In the case of KDE, kmix provides a simple mouse click setting. For non KDE desktops, also check your desktop setup, as some desktop’s control the mic via a desktop window manager setting.

Maybe also look at amixer or alsamixer.

amixer: amixer(1): mixer for ALSA soundcard driver - Linux man page
alsamixer: alsamixer(1) - Linux man page or Alsamixer - ALSA wiki

I set the Input Source to Internal Mic:

tsalsa.txt - (beta)

with the command:

amixer set ‘Input Source’ ‘Internal Mic’

but the result is the same.

To testing my mic I use gnome-sound-recorder 2.22.0.There is another tool?


I typically use a simple arecord command. ie something like
arecord -d 10 myrecording.wav
arecord -d 10 -f cd secondrecording.wav
where “-d 10” sets a 10 second recording.

Don’t forget to try the /etc/modprobe.d/sound edit, that I noted above.

No, doesn’t work.

If I use:

amixer set ‘Input Source’ ‘Mic’

with headphone mic is all ok (I get the sound from aplay myrecording.wav)

If I use:

amixer set ‘Input Source’ ‘Internal Mic’

I get nothing…

I have set model=acer and restart the service rcalsasound.


Did you test that with the Internal Mic selected?

Also, don’t forget to test “model=auto” as recommended. Again restart alsa, and ensure the “Internal Mic” is selected.

And note I posted the entire ALC268 section from the ALSA-Configuration.txt file for you to examine. You can also try the 3-stack, toshiba, and dell model options.

Yes, I tested with Internal Mic selected.

I tested with model=auto.

Tomorrow I’ll try with other models.


Good luck with that test.

If that doesn’t work, there is something else you could try. … because your sound works generically, I did not suggest this before, but I think it worth considering now.

I see you have an ALC268. In the script output you posted, you have a 64-bit kernel

I note from the post I quote below you have “mostly” updated your alsa:

When updating, was there a reason why you did not install alsa-driver-kmp-default? Maybe try again with the latest alsa:

zypper ar multimedia
zypper install alsa alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar media
zypper install alsa-driver-kmp-default
zypper rr multimedia


now, the situation is:

rpm -qa | grep alsa


I have tried with other model in /etc/modprobe.s/sound but nothing (with this models I have problem with play a simple mp3 sound)

The model correct is acer, but my mic internal doesn’t work.

Any other idea?


Ok, now please run the tsala script again (with the model=acer in your /etc/modprobe.d/sound file). I want to see what it notes about your alsa update, and also your mixer, to see if the settings have changed.

Also, please provide output of
cat /etc/modprobe.d/sound

I think you should also check to see if there is a BIOS upgrade for your Acer (that may be related to your microphone). And check to ensure you don’t have any inappropriate settings in your BIOS blocking your microphone.

This is the output of tsalsa:

tsalsa.txt - (beta)

And this the /etc/modprobe.d/sound

options snd slots=snd-hda-intel
options snd-hda-intel model=acer

u1Nb.Z0J4Co96n9E:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

In my laptop also I have Vista, and Internal Mic works well :frowning:


The both look fine.

I “hear” what you are saying, and I note your point, but given nothing else has worked thus far (to get your mic working for Linux) that strikes me as being, if you please pardon the expression, a bit cavalier.

I’ve read of many cases where a BIOS will work fine with one OS, and not another, and hence the motherboard supplier will release a BIOS update, such that another OS can function better. I’m not saying this is the case for your laptop, as IMHO the odds are extremely unlikely. But I’m running out of ideas, and I think you should check this.

I did a cursory look for your acer 7720, and I noted the following BIOS updates relating to audio:

Major Version      : V1.38 (for MP-EN)   RELEASE DATE : 05/07/2008
   1). Add SVID of ATI M86M audio.

Major Version      : V1.33 (for MP-EN)   RELEASE DATE : 03/15/2008 
  1). Fixed BOBO sound when play music

Major Version      : V1.32 (for MP-EN)   RELEASE DATE : 03/13/2008
  1). Solve BOBO sound when play music

Major Version      : V1.31 (for MP-EN)    RELEASE DATE : 03/10/2008
  1). Improve BOBO sound when play music.

Major Version      : V1.03 (for UMA Golden)   RELEASE DATE : 05/15/2007
	2). Fixed Audio noise.

Major Version      : V0.20 (for C) RELEASE DATE : 04/11/2007 
        13).After install OS finish, have a "High Definition Audio Controller" show
            exclamation mark in Device Manager.Fail with ATI M74M/M76M platform.

Major Version      : V0.13        RELEASE DATE : 02/07/2007
        6). Speaker no sound after S3 resume.

Major Version    : V0.09          RELEASE DATE : 01/15/2007
	1). Modify EC_Mute behavior to avoid abnormal bobo sound.

Major Version    : V0.02         RELEASE DATE : 11/29/2006
	4). Implement Realtek Audio verbtable and modem. 

Now its quit likely none of them have anything to so with Linux and quite likely they have nothing to do with your mic. … but thats not the point.

The point, IMHO, is you should have still checked.

Anyway, I’m out of ideas.

All I can recommend now is you repeat what you tried above to see if you made a mistake in your checks, … ie repeat:
a. mixer checks,
b. trial of different /etc/modprobe.d/sound model options.

You could write a bug report on this (to openSUSE and alsa), if you are happy your checks were thorough.

Good luck.