Opensuse 11 installtion issues

I just finished installing 11 and it seemed the installation went fine. Now when it rebooted it goes to command promt and asks me to enter password and username which I did.

After that I typed in kdeinit and it still does not go anywhere. What am I missing here.

I was on 10.3 and just deleted those partitions and installed 11 (64bit).

Any help is appreciated.

If I understand you well you did a fresh install.
The initial boot does it goes well ?
If you also install KDE or Gnome you should start in A GUI just like opensuse 10.3
If you log in as root and give the command init 5
than than startx does it give a GUI ?

When I get to the command prompt and I go into root and do startx it says fatal error and cannot start xserver.

I installed kde 4. Did not install gnome.

Below are the specs of the machine if that helps.

• Intel Core 2 Quad Q6600 2.4GHz Quad Core Processor $1,195.00
• Intel P35DPM Motherboard
• 4096 MB (4GB) DDR II 800MHz PC6400 Memory
• 74GB SATA 10,000 RPM 16MB Cache Hard Drive
• 20X DVD±RW Burner Dual Layer Drive
• NVIDIA Quadro NVS 440 256MB Video Professional Graphics Card $435.00
• 8 Channel High Definition onboard sound
• 10/100/1000 Gigabit Network Interface
• Microsoft Windows XP Professional 64-bit Edition OR vista
• Front Ports : (2) USB 2.0
• Rear Ports : (6) USB 2.0 (some by headers), (2) IEEE1394a (1 by header), (1) Serial header, Audio I/O Panel, (1) RJ45
• Expansion Slots: (1) PCI-Express x16, (3) PCI-Express x1, (3) PCI

Nice machine. Nice and expensive video card.

Try this originally written by deltaflyer and plagiarised by me:
At the prompt type


& let it load. You can now reconfigure your graphics. Once you have tested & saved your new configuration you will be back at the prompt.
Now try this:


You should now be in gui land.
If the above fails, start again and instead of “sax2” try this:

sax2 -m 0=vesa

( where 0 is a number not a letter )
This should give you basic graphics when you next log in.
From there you can go to yast ->hardware ->graphics card & monitor & set up your card there.

If that also fails, at the prompt type

sax2 -a

and this will automatically try to set up your graphics.

If that fails, then at the prompt type

sax2 -l

which will give you low res graphics when you next login.

If all this fails then report back.
If success == “yes” somewhere, then install the nvidia drivers

I tried all the above and it does not go anywhere accept the prompt.
i have taken of 64 bit install of 11 and got 32 bit 11 installed and tried all of the above and still same problem.
i am trying to go back to 10.3 now and see if it works.

And with 11.0 or 10.3 are you using the proprietary nvidia graphics driver? That’s a new card; you probably need to do so.

I was able to install 10.3 and run with no problem.

can I just do a simple upgrade if go to 10.3 64 bit installation or do I have to delete the partition and start again. (I have program on the 32 bit which I will need to activate again if it will be a fresh install.)

Thanks for you help dobby9 mingus725 and swerdna

Can you look in Xorg log and tell me whether near the end you have any no core pointer error messages as this caught me out alot even after a fine install.

Sorry, but I don’t think I understand your question. You re-installed 10.3 as 32-bit and now you want to upgrade to 11.0 64-bit? If that is what you mean, then no, not a good idea. The upgrade will stay on the same architecture. Is there a reason why you have to have 64-bit?

Or, maybe you are asking something else? (By the way, what is the “activation” you are referring to?)

And, again, on 10.3 are you using the proprietary nvidia driver (name “nvidia”) or the open source nvidia driver (name “nv”)? You can verify that by looking at /etc/X11/xorg.conf, the Device Section. It’s important to understand this, as when you upgrade you may encounter the issue again.

That is exactly what i was asking.

Or, maybe you are asking something else? (By the way, what is the “activation” you are referring to?)

It is a work related program that needs activation every time you change something.

QUOTE=mingus725;1877849]And, again, on 10.3 are you using the proprietary nvidia driver (name “nvidia”) or the open source nvidia driver (name “nv”)? You can verify that by looking at /etc/X11/xorg.conf, the Device Section. It’s important to understand this, as when you upgrade you may encounter the issue again.[/QUOTE]
I will check

The only ways I can think of to maybe upgrade from 32-bit to 64-bit:

Use 64-bit DVD with upgrade option.

Use YaST Software Management, manually selecting parent or base packages which would throw many dependency errors; select the x64 alternatives offered.

Use zypper with wildcards or regular expressions. Doubtful.

Of the three, the first is the best bet by far. With all three, things will break.

SO I upraded to opensuse 11 from 10.3 (still the 32 bit version though).

I am still having trouble getting the gui.
I have tried all the commands that mingus had suggested and no luck so far. although now it says when i type starts x or sax2 that configure through sax2 -p.

I am not familiar with the opensuse or any linux systems for that matter and I am learning slowly.
I believe my problem is the NVS 440 quadro graphics card and if there was a to update the drivers through the command prompt I might be ok.
ANy suggestions help?

I checked the “supported products” list for the nvidia driver that is in the repository; according to it your Quadro NVS 440 is supported. Boot into runlevel 3 (type the number 3 in Boot Options on the boot menu), at the prompt login, and then switch (“su”) to root. Then do

zypper sa nvidia
zypper in x11-video-nvidiaG01
shutdown -r now

Try booting as normal. If you still do not have the gui, reboot into runlevel 3 again as above. Then do

sax2 -r -m 0=nvidia

Configure. Save. Exit. Then do


I was able to successfully get the GUI. Thanks a lot for your help.
Appreciate it.
Have a good weekend.

You’re very welcome, glad to have been of some help. :slight_smile:

So I went ahead and installed 64 bit version and downloaded the nvidia drivers as suggested in mingus’s earlier post adn now I cannot get GUI anymore. I have tried all the options from earlier posts on this thread and I do not get to GUI land. Any suggestions would be appreciated.

IT was a fresh install incase anybody is wondering.
The error I am getting is
these is from teh xserver log

Data incomplete in file /etc/x11/xorg.conf
Atlease one device section required
Problem parsing the file
Error parsing the file

xf86Closeconsole:kdsetmode failed
bad file descriptor
VT_getmode failed Bad file descriptor.

The X server configuration file is corrupted . . . Boot into runlevel 3, logon as user, switch (“su”) to root, then do:

cd /etc/X11
mv xorg.conf xorg.conf.mybackup
sax2 -r -m 0=nvidia

Sax will come up, click on Change Configuration, verify it is what you want, then Save. Sax2 will close and a new xorg.conf will have been created. Then do:


That will take you out of the root su mode back to your user, and then start the X server.

i tried the above and it is saying cannot find directory!

That is not really helpful . . . exactly what gives the error message? Are you sure you switched to root?