Opensuse 11 installation keeps continuing after it's done

Hi folks, this is what is happening:

I downloaded the Opensuse 11 image, made an md5 check after I burned it (everything fine) and then tried to install it.
Thats when the Problems began to start.

I tried to install it twice, the first time everything seemed fine at first, but after the restart the installer popped up (the ascii one, interrupting kdm and forcing me to switch to tty1) and said something about there was a problem during the installation, and that the installer needs to repeat some steps.
So I select OK, and the installer asks me about the data for the “new user”, I type it in and first error: “User already exists, choose another name please” or something.
So I just chose another, continued the last configuration and hardware recognizing steps, and restarted. What happend: The installer pops up again and starts (again) from asking me for the user login data he wants to write to /etc/passwd.

I skipped that part this time, canceled the installation, and switched to kdm, logged in (at least that worked the first time) and tried to get root. The installer must have gotten something wrong with the pam.d settings, too, as I can’t get root without being member of wheel.

So as I didn’t know what exactly the problem was, I just killed my harddrive again, and reinstalled opensuse.
What this time happend is more strange: Opensuse didn’t save one **** setting.
At first the installer didn’t set a root password so I did it by myself with a live-cd, and second it didn’t even create a user, nor did it save my network settings.
The installer problem also (without even touching my passwd file) also occurred every time I made a restart.

That was the point where I gave up and installed archlinux again. I think, despites the fact the I like opensuse, that its to complicated for someone who never really worked with suse to figure out what may have caused that error.

The hardware I tried to install Opensuse on is the following:
Processor: Intel Pentium D Processor 935
Mainboard: Abit I-N73V
Ram: 4 Gb standard DDR2 ram (800mhz)
And a common mouse, keyboard and dvd drive.

During the installation itself never(!) occurred an error and the installer never aborted anything.

As I had to wipe the drive to install arch, I don’t have any log files left, but I hope you can help me.

Cheers, blue-dev.

(Excuse my poor English please)

What I forgot to add: I can’t provide any kind of network access during the installation because my network card is only running with the ndiswrapper.

you don’t need the internet to install.

did you try any of the install options like a text mode install?

did you run the media check on the dvd and or cd?

I know that I don’t need internet to install, I just wanted to answere the question if I updated anything after I installed opensuse before it could be asked :slight_smile:

And no, I didn’t try any other method but I think it makes no big difference as the text-mode installer calls the same functions just in another layout.

And I checked the dvd twice, first under arch after I burned it, and second in the grub boot menu of the dvd after the second failed install, both times successfully.

I just installed (if I can call it that) opensuse again, and the same problem occurred. This time I even re-downloaded the image and burned it on a new dvd, checked the md5 sum in windows and linux, and checked the dvd on the menu.
Still no error, but I read something like “Can not access memory” after the installation in the console.
Can opensuse completly handle 4 GB-Ram (what I mean is, is the default kernel compiled with high-mem support?).

Now, I’m just were I started, hope somebody cann help me :confused:.

I’m not sure. But I think there might be an issue here. Maybe some more advanced users will read this and help.
If it were me I would just take some out to give it a go.

I somehow solved the problem now (at least for myself).
I installed Opensuse a few times and first found out that I need to disable autoconfig to at least create the standard configs.

After the installation itself is complete and configuring starts, the installer always crashed, so I just klicked “no” when it asks me to rerun the installation, and instead wrote the remaining configs myself.

I needed to write / rewrite 10% of the overall configs but know I guess its working, at least I didn’t get anymore errors.

I somehow solved the problem now (at least for myself).

Well done, hope it continues to work well