opensuse 11 installation issue

Ok, what’s going on here? I’ve downloaded the opensuse 11 64-bit DVD ISO, checked the md5 checksum and it passed. Proceeded to burn it to a DVD-R at the lowest speed possible. So far so good. Before I continue, this is the system configuration of the PC I’m attempting to install suse 11 on:

Processor: AMD Athlon 64 X2 5600+ 2.8GHz
Motherboard: Gigabyte GA-M57SLI-S4
RAM: 4GB (4 x 1GB) G.Skill DDR2 PC6400 @ 800MHz
Video Cards: 2 x BFG GeForce 8800GT OC 512MB
Sound Card: Creative SB Audigy 2 ZS
HD: Seagate Barracuda 320GB

So, I have 1 partition on this HD taking 200GB where Windows XP is installed, the rest of the HD is not partitioned. I proceed to boot from the opensuse 11 DVD and start the installation. I run the installation, and everything seems to go just fine. I let the installation program create partitions on the unpartitioned half of the HD. So, after it installs it goes to the boot screen. But, when I enter my password it says login invalid. I am pretty certain that my password is correct, but is still tells me login invalid. I then reboot the PC, and while booting it shows me a window that says: “The previous installation has failed. Would you like to continue?” I click Yes, and it seems to be trying to detect the video card again, takes me to the login screen again, and once again I cannot login. I reboot and the cycles repeats. Why is this happening?

One note though. I have a Logitech Wireless Laser mouse. I remember that when I used to install opensuse 10.3, during installation I had to hook up a regular PS/2 mouse I have here instead of using the Logitech mouse during installation, otherwise it wouldn’t detect the video card right for this computer, oddly. I tried this here but didn’t have such luck. Could this have anything to do with it?

Any help will be appreciated.


Well, I did some experimenting. I suspected that it had trouble with my dual video card setup, since that’s where it would hang. So I opened up the case and removed the second video card and tried to boot up again. This time it finished the setup and allowed me to login. So my suspicion was right, opensuse 11 x64 hardware autodetect has trouble with dual video card setups.

But it is a pain though as every time I may need to install opensuse 11 I have to open my PC’s case and remove a video card.

You could write a bug report on this:
Submitting Bug Reports - openSUSE

IMHO there is a better chance of this being addressed if in addition to writing a bug report on openSUSE-11.0, you also download openSUSE-11.1 alpha2, try to install on it, and then write a separate bug report on 11.1 alpha2. Even then (also IMHO), it may be a few releases before such a bug is addressed …