opensuse 11 installation fail

I tried to install openSUSE 11 but I found some strange bugs. MD5 sum ok, I have a PS/2 keyboard (previously I had problems with usb keyboard)
When booting from DVD the menu appears with the list of choices, but there is a small black box in the front of the menu. I made a screenshot for better understand
If I touch up/down, or pgup/pgdown in some seconds it switches into a black console screen with ‘boot: _’ prompt.
Finally if I hit <Enter> then the usual grub boot screen follows with the usual choice

Does anybody know how to solve this problem? Please help.

I have not seen anything like the black box. My crazy guess would be that it’s being invoked by some keystroke combination (an error from the language translation?).

You are getting to what’s shown in your second screen shot by breaking out of the first menu (you probably hit Escape). At :boot you don’t enter anything; if you just hit return the installer will start.

The last screen looks like a grub menu from a previously installed openSUSE. Right? I would expect that once you’ve upgraded, you’ll not see the black box, just as you are not now with your current openSUSE.

> Does anybody know how to solve this problem? Please help.

don’t know if this helps or not:

from the third image you posted it looks like you have a WORKING SuSE
10.3 on that disk…

is 10.3 doing what you need it to do, reliably? if so, i’d say you are
MUCH better off staying where you are, for now…

if it is not doing what you need i DOUBT that 11.0 will fix your
problems with 10.3, and it is probably easier to get 10.3 working the
way you want than 11.0, today…

at least, from all of the trouble i see folks having with 11.0 let me
suggest you wait a while…say until version 11.1 is available…

and, if you ignore that advice DO NOT INSTALL KDE4 when you go to 11.0,
get the KDE3…

(my GUESS, when you first boot from the install disk, and it has the
black box…if you can quickly highlight “Installation” with the
up/down keys or Tab) and press enter…i guess the black box will go
away…BUT, i still suggest you avoid 11.0 for now)

DenverD (Linux Counter 282315)
A Texan in Denmark

I’ve seen that black box before … or at least one very similar to it.

In my case it was caused by bad hardware - ie caused by a failing hard drive with a bad/corrupt MBR.

I didn’t hit any keys, only <scroll up/down>, and <enter>. I recognized, that with key ‘K’ (as far as I know <ctrl>+k is an alias for <enter>) the same process will start. Previously I had the same problem, but that was a usb keyboard and now I use PS/2.
If I hit <enter> at the boot prompt the boot process will follow with grub.
You’re right I have a previous openSUSE and a windowsxp but both are working perfect.

Thanks for answer. Yes, I have a working 10.3. All that I want is some experience in Linux systems.

I think you have right. While booting to windows xp I can see a message about some corrupted boot initialization file (I don’t used to sit in front of computer while booting:)). I’ll try to fix it, hopefully the black box will not appear.

I applied fixboot and fixmbr but didn’t help. Anyone has any other ideas?

If its like the case when I saw something like that “screen shot” on my test PC, the only fix was a new hard drive.

Looks like a failing hard disk. Do you get any gentle click sound from your system when in use, especially when you try to open your My computer and access your drives?

No, it’s working well. This drive is about 4-6 ys old so I backed up all my data:) I should try with a quite new one.

I had similar behaviour on my failed drive. Only the MBR was corrupted and not repairable. And I obtained the images that you posted.

I ordered a new drive because I already needed it, maybe this will solve the problem.

Problem solved. It was about the failing DVD ram. Maybe that black screen stands for some hardware problem. Thanks for help!

Terrific! And, welcome!