OpenSuse 11 installation and booting problems

Hi all,
Im not completely a newbie coz ive used Linux before but that was a long time ago. I recently downloaded the iso for OpenSuse 11 64 bit version and burned it onto a DVD.
When i tried to install it, it used to get struck after i press enter at the "Install from DVD " option. I fiddled with the settings and finally installed everything after selecting Kernel Safe Settings in the install screen.
But now the problem is that when i try to boot onto Suse, i get the green screen at the start and the progress bar is stuck at the beginning and no progress after that. Could someone help me find how to solve this. Ive already tried changing the boot options ( IDE, ACPI, failsafe etc ) .
I had selected KDE 4.0 as the default window manager but later got greedy and selected both Gnome and KDE to be installed in the package manager during install. Could this be the problem?

Im using an HP DV5 laptop with AMD Turion 2 GHz, 2 GB RAM, ATI Radeon HD 3450 graphics card.
Any suggestions are appreciated.